Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: INDI/Linux driver for the QHY Polemaster, developers needed.

INDI/Linux driver for the QHY Polemaster, developers needed. 4 months 3 days ago #16271

Thanks Jasem!

I tested the new build and initially had issues:
- needed GCC 5.x for qhy driver
- my polemaster was not receiving the firmware blob upload and thus was not being recognized by indilib

My polemaster is showing up as Bus 001 Device 006: ID 1618:0940
After loading firmware, it shows up as 1618:0941. I had to modify 85-qhy.rules to include 1618:0940. Disconnecting and reattaching the PoleMaster after making this change resulted in the firmware getting loaded and the device being recognized by indilib.

I found that I was getting about 1FPS while framing. I guess this is to be expected since I am using an Intel Edison which is a dual-core Intel @500MHz, plus I am connecting via WiFi.

I did notice a message about SQM while starting the server which I didn't notice prior to loading the QHY module. Is there perhaps plans to use the PoleMaster as a SQ Meter, because that would be a cool use for the device.

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 4 months 3 days ago #16272

I attempted to enable compression and got about the same framerate from the camera... it turns out that the CPU was limiting.

I compiled on my pine64 and connected via GigE. Framerate was about doubled, however it appears that compression is single threaded.

I left the indi server up for 2 hours why grabbing frames continuously, and I did not experience issues.

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 4 months 3 days ago #16274

Thanks for the test, I will relay this to QHY. I updated the rules file to fix the issue. For SQM, it can be done if someone works on the math and algorithm. I have a separate SQM LE device and I wanted the SQM reading to be in the FITS header.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

INDI/Linux driver for the QHY Polemaster, developers needed. 4 months 1 day ago #16299

The camera looks to take images just fine in INDI, is there something specific we should be testing out?

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 3 months 4 weeks ago #16338

I managed to use the Polemaster as a guider in EKOS last night with my rPi GPIO ST4 implementation. I did run into an issue while attempting to use it for imaging. It appears to have problems when exposure times exceed 45sec or so, where images returned were just black and contained no data. It could have been a software issue on my end, I'll test again this evening with a pristine installation of INDI.

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 3 months 3 weeks ago #16372

There is certainly something odd about this camera when using longer duration. I tested with a pristine installations.

If you capture with a 1.0 sec exposure, the image downloads almost instantly.

If you capture with a 10.0 sec exposure, it takes about 11.5 seconds to download the image after exposure stops.
If you capture with a 15.0 sec exposure, the image downloads almost instantly.
If you capture with a 18.0 sec exposure, the image downloads almost instantly.
If you capture with a 20.0 sec exposure, the image never downloads and EKOS will just hang waiting for the data. Have to kill indiserver and the indi_qhy_ccd driver, as well as unplug and re-plug the polemaster to resume capture.
21.0 sec exposure is fine.
29.0 sec is fine.
30.0 sec bombs just like 20.0 sec did.
40.0 sec bombs just like 20.0 sec did.
50.1 sec took 52 seconds to download after exposure ended.
89.0 sec took 91 sec to download image.
93.0 sec worked fine.
118.0 sec worked fine.

It appears that multiples of 10.0 seconds will cause issues with the driver and/or camera. Getting close to a multiple of 10.0 sec can sometimes trigger a situation where it appears that a second image is captured and sent since the delay in downloading appears to be equal to the exposure time.

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 2 months 4 days ago #17318

Which software should we use(modify) to make it working ? On windows, we can use the one provided by QHY.

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 2 months 4 days ago #17319

It's already working with INDI, no need for additional software. If you want to use Polar Assistant tool under Linux, you can use Ekos Polar Assistant.
The following user(s) said Thank You: maudy

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

INDI/Linux driver for the QHY Polemaster, developers needed. 2 months 4 days ago #17320

  • maudy
  • maudy's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 239
  • Karma: 2
  • Thank you received: 19
Not sure how I missed this. I will definitely be giving this a try with the RPI3 next time skies are clear.

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 2 months 7 hours ago #17378

  • maudy
  • maudy's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 239
  • Karma: 2
  • Thank you received: 19
How do I configure for the Polemaster camera to work with the Polar Alignment?

Setup:
1. EdgeHD11 - 2800mm FL
2. ASI1600mm
3. ASI224MC
4. Polemaster
5. using OAG

Issue is that the pole alignment cannot be started due to the FOV reported when combined with the 2800mm focal length.

Is there a way to setup correctly with the polemaster?

Thank you

Please Log in or Create an account to join the conversation.

INDI/Linux driver for the QHY Polemaster, developers needed. 2 months 2 hours ago #17379

You could perhaps use the "Guide Scope". So even if you do not have one, adjust the Celestron "Guide Scope" so that whatever focal length you put there results in the correct FOV for Pole Master. Then from Align tab, you can select "Guide Scope" and FOV will be updated accordingly.
The following user(s) said Thank You: maudy

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

INDI/Linux driver for the QHY Polemaster, developers needed. 1 month 4 weeks ago #17389

  • maudy
  • maudy's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 239
  • Karma: 2
  • Thank you received: 19
Yes, this worked for me in my test!

The primary scope is defined and now used for both imaging and guide camera. The guide scope is now fictions (120mm aperture and 480mm FL) and used with polemaster.

Now I just need skies... oh where did they go?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.610 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica