Welcome, Guest
Username: Password: Remember me
02 Jan 2018
INDI development team is happy to announce the release of INDI Library v1.6.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: Change to Guide Module with recent update?

Change to Guide Module with recent update? 1 week 14 hours ago #23186

I can confirm the behaviour reported here. I have an ASI120MC-S (USB3) and use it on an HEQ5-Pro that is connected to Ekos with an EQDir cable (EQMod driver).

When using the EQMod guiding within Ekos, guiding works fine although the guiding errors are rather large, around 5” either way on both axes and more. Quite consistently.

When using the camera for guiding, calibration never stops. The mount just starts drifting and will never revert direction. I need to physically shut it down and restart it (not just Ekos/KStars, the mount as well) before it starts responding again.

When using PHD2 for guiding with on-camera, guiding goes very well. The errors generally remain within 2.5” though occasionally (every 5 to 10 frames) a large step (7.5” or more) is taken in RA followed with a reverse step tow or three frames later.

All guiding is done with 4.0 sec frames.
The following user(s) said Thank You: El Corazon

Please Log in or Create an account to join the conversation.

Last Edit: by wvreeven.

Change to Guide Module with recent update? 1 week 11 hours ago #23199

Thanks, wvreeven. Exactly what I am seeing in all respects, except I don't need to shut down the mount to recover, just Ekos and KStars. However, I think I have found a way to make the guiding through the mount, using the internal guider, more consistent. Can you try playing with the proportional gain in the Control Parameter settings and set proportional gain for the RA axis to 200% and DEC axis to 100%. In my case, that brought the deviations down to <2" on an Atlas Pro, 70% of the time <1" with guide pulse lengths rarely exceeding 400 ms, 200-250 ms most of the time. If you can improve further, please let me know. But with those settings, it is quite workable at the focal lengths I am using (~800mm and at the abysmal seeing I had in my light polluted and smog-filled inner city area. In my case, I used 2" frames, not ideal, so I will change to 4" frames next time. I thought I had set the guider to 4" frames, but it reverted on its own without me noticing. Thanks for pointing that out.

Please Log in or Create an account to join the conversation.

Change to Guide Module with recent update? 1 week 11 hours ago #23200

Jasem, can you post instructions on how to perform that update on the Pi3? I installed the latest indi-asi update today, but the USB2 ASI120MM still won't capture any images, although the camera is recognized by Ekos. However, when I try to capture an image, the timer either counts down to 0.01" and then stops, freezing Ekos to the point where I cannot disconnect the camera or stop Indi, I need to force quit Ekos and restart it, or it will loop endlessly without ever rendering a frame.
I am running all services directly on the mount, nothing remotely on my desktop, I merely connect to the Pi3 via VNC.

Please Log in or Create an account to join the conversation.

Change to Guide Module with recent update? 1 week 10 hours ago #23201

El Corazon wrote: Thanks, wvreeven. Exactly what I am seeing in all respects, except I don't need to shut down the mount to recover, just Ekos and KStars. However, I think I have found a way to make the guiding through the mount, using the internal guider, more consistent. Can you try playing with the proportional gain in the Control Parameter settings and set proportional gain for the RA axis to 200% and DEC axis to 100%. In my case, that brought the deviations down to <2" on an Atlas Pro, 70% of the time <1" with guide pulse lengths rarely exceeding 400 ms, 200-250 ms most of the time. If you can improve further, please let me know. But with those settings, it is quite workable at the focal lengths I am using (~800mm and at the abysmal seeing I had in my light polluted and smog-filled inner city area. In my case, I used 2" frames, not ideal, so I will change to 4" frames next time. I thought I had set the guider to 4" frames, but it reverted on its own without me noticing. Thanks for pointing that out.


I set the Proportional Gain as you indicated but to no avail as you can see in the screenshot. I'm not sure if my guide scope is focused well enough though. I ordered a new one with a better focuser so maybe that'll help.
Attachments:

Please Log in or Create an account to join the conversation.

Change to Guide Module with recent update? 1 week 7 hours ago #23204

Nevermind, I figured it out.
indilib.org/devices/ccds/zwo-optics-asi-cameras.html
I had flashed the firmware, but I had a) not selected to OVERWRITE the old firmware and b) used the ASI120MM.icc file, not the ASI120MM-compatible.icc file to change the firmware.
Now that I flashed the firmware with the -compatible version, the USB2 version of the ASI120MM captures and loops images just fine.
That does not resolve the original problem for which I opened this topic, though, i.e. that ST4 guiding through the ASI120MM-S (USB3 version) does not work.

Please Log in or Create an account to join the conversation.

Change to Guide Module with recent update? 1 week 4 hours ago #23209

wvreeven wrote:

El Corazon wrote: Thanks, wvreeven. Exactly what I am seeing in all respects, except I don't need to shut down the mount to recover, just Ekos and KStars. However, I think I have found a way to make the guiding through the mount, using the internal guider, more consistent. Can you try playing with the proportional gain in the Control Parameter settings and set proportional gain for the RA axis to 200% and DEC axis to 100%. In my case, that brought the deviations down to <2" on an Atlas Pro, 70% of the time <1" with guide pulse lengths rarely exceeding 400 ms, 200-250 ms most of the time. If you can improve further, please let me know. But with those settings, it is quite workable at the focal lengths I am using (~800mm and at the abysmal seeing I had in my light polluted and smog-filled inner city area. In my case, I used 2" frames, not ideal, so I will change to 4" frames next time. I thought I had set the guider to 4" frames, but it reverted on its own without me noticing. Thanks for pointing that out.


I set the Proportional Gain as you indicated but to no avail as you can see in the screenshot. I'm not sure if my guide scope is focused well enough though. I ordered a new one with a better focuser so maybe that'll help.


Give PHD2 or LinGuider a go and see if the results are different.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Change to Guide Module with recent update? 1 week 4 hours ago #23210

El Corazon wrote: Nevermind, I figured it out.
indilib.org/devices/ccds/zwo-optics-asi-cameras.html
I had flashed the firmware, but I had a) not selected to OVERWRITE the old firmware and b) used the ASI120MM.icc file, not the ASI120MM-compatible.icc file to change the firmware.
Now that I flashed the firmware with the -compatible version, the USB2 version of the ASI120MM captures and loops images just fine.
That does not resolve the original problem for which I opened this topic, though, i.e. that ST4 guiding through the ASI120MM-S (USB3 version) does not work.


Did you try sending pulses manually via the INDI Control Panel like you did with the USB2 version?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Change to Guide Module with recent update? 6 days 21 hours ago #23219

Yes, that was part of the original troubleshooting. I have not tried it with the USB2 version yet since the firmware flash, but since it worked before and since it works for you, I assume that will not change. The ST4 guiding through the USB3 version is the problem. wvreeven (see a few comments above) found exactly the same problem, during calibration the mount never reverses, but drifts away into one direction, so it can't be my camera or isolated to the settings on my Pi3, as the issue reproduces on his setup.

Please Log in or Create an account to join the conversation.

Change to Guide Module with recent update? 6 days 21 hours ago #23220

It’s probably worth noting that my setup doesn’t use an RPi but simply a (2010) Dell laptop with Ubuntu Mate 17.10.1 (artful).

Please Log in or Create an account to join the conversation.

Change to Guide Module with recent update? 6 days 21 hours ago #23221

If USB3 version produces same problem, it's probably time to call ZWO about this.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Change to Guide Module with recent update? 6 days 21 hours ago #23222

And tell or ask them what exactly? Remember, guidng via ST4 on the USB3 versions works in PHD2. Just not in Ekos...

Please Log in or Create an account to join the conversation.

Last Edit: by wvreeven.

Change to Guide Module with recent update? 6 days 21 hours ago #23223

In PHD2 you're using ZWO driver or INDI driver?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Time to create page: 0.136 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica