Welcome, Guest
Username: Password: Remember me
27 Feb 2017
INDI development team is happy to announce the release of INDI Library v1.4.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers. Several improvements and enhancements are included in this release including native support for Cygwin and MacOS platforms in addition to Linux, BSD, and Windows (Client only).
Read More...

TOPIC: Ekos on Mac OS X ?

Ekos on Mac OS X ? 1 week 5 days ago #16753

Jasem just uploaded the dmg I built yesterday. Please test thoroughly. I think I have fixed the dbus issue. I bundled a dbus server and if Kstars on mac does not detect one on startup, it launches a dbus server of its own. Also the qhy driver that we worked on last week is now int there. And eqmod should now be fixed. Plus i noticed xplanet was not working properly and fixed that too. This also of course includes all other recent changes such as the fixes I did to the gphoto drivers and updates to whats interesting.

Please test it to make sure all these updates work! Thanks,

Rob

edu.kde.org/kstars/
The following user(s) said Thank You: alessio.beltrame, anofeles

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 5 days ago #16754

Jasem said he is planning to add the splitter that was requested today and he is bumping the version number to 2.7.8. I plan to build a new dmg later today after he does that. If you guys could try out the dbus server today and other items I listed in my post a minute ago, that would be most appreciated

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 4 days ago #16759

can't do much testing my observatory is down for refurb :(

Please Log in or Create an account to join the conversation.

Kstars Mac osx
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
HEQ5 pro / Atik titan / Atik 314L+

Ekos on Mac OS X ? 1 week 4 days ago #16762

Rob,
I tried hard to test is ASAP. It's a very preliminary bunch of tests, so take them with a grain of salt.

Bad new first: EQ MOD still does not work if launched directly from the EKOS UI. However....

Good news: I tried launching indiserver from the CLI (browsing through kstars.app/Contents/MacOS/indi) with:
./indiserver -vv ./indi_eqmod_telescope ./indi_canon_ccd ./indi_skysafari ./indi_qhy_ccd

and it worked! I tested the EQMod driver through a Bluetooth-to-serial adapter connected to my Orion Atlas, together with my Canon EOS 7D Mark II. I also connected SkySafari and it worked very smoothly. I tried slewing to a dozen targets, took sample pictures, used SkySafari for GOTO's and everything worked.

On the wings of enthusiasm, I also tried to connect my Orion SSAG through the QHY CCD driver, but it didn't work. I previously tested the SSAG with CloudMakers indiserver and it worked. Apparently, it uses the Indi_qhy_ccd driver, but I'm not really confident about that, maybe I misinterpreted its drivers.xml file.

To me this is a great step forward. I'll test it on the field this weekend, if weather forecasts are right.

P.S. Just in case you need them, I'm attaching the logs. It seems that Indi_eqmod crashes immediately after it finds the mout is parked.
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by alessio.beltrame.

Ekos on Mac OS X ? 1 week 4 days ago #16766

  • maudy
  • maudy's Avatar
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 148
  • Karma: 1
  • Thank you received: 11
New DMG works for dbus.

Test:
1. Stopped dbus: brew services stop dbus
2. Uninstalled dbus: brew uninstall dbus
3. Use current Kstars was started, scheduler executed and it timed out.
4. Quit KStars
5. Copied new KStars from newly downloaded DGM over the current KStars
6. Used new Kstars, scheduler executed and it WORKED.

Other than this dry run I have no clear skies to test further. Will do ASAP

Thank you!

Forgot to mentioned - this test was done using Mac to connect to indiserver running on RPI3 via INDIWebserver.
The following user(s) said Thank You: anofeles

Please Log in or Create an account to join the conversation.

Last Edit: by maudy.

Ekos on Mac OS X ? 1 week 4 days ago #16767

Rob and Jasem,
one additional remark. The two latests releases have the same version number. Do you think it would be a good idea to mark them with a further versioning level (2.7.7.1 or 2.7.7b) or a build number? In such a way it would be simpler to know if you are running the right version and if you actually downloaded the latest one. Thanks.
The following user(s) said Thank You: anofeles

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 4 days ago #16770

I would really like to see a build number or something similar so, as you said, it would be easier to make sure you are running the correct version.

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 4 days ago #16771

I'm glad the dbus solution I came up with appears to work!! That took me hours to figure out. It wasn't much code to implement in the end, but figuring out how to make it work took some time because I was having trouble figuring out exactly what it needed in order to run and how to pass it the correct path variables.

Sorry to hear about EQMod not working yet. Jasem and some others were working on that. I thought it was fixed. I will check with them. From what you said, it sounds like it is there and it works properly but that some environment variable is required in order to run correctly. I think this is true because processes that start from inside programs do not have the same environment as a console does. Usually, I have found that they just need to be passed some environment variable. It could also be accessing a path that is not in the bundle and thus would be on one person's computer but not another which makes it harder to test. We will look into it.

For version or build numbers, I will have to ask Jasem what he thinks about that.
The following user(s) said Thank You: maudy

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 4 days ago #16776

  • maudy
  • maudy's Avatar
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 148
  • Karma: 1
  • Thank you received: 11
What are the rules/settings for Ekos on Mac and the syncing of the RPI3 time/date and location?

I can confirm updating the INDI driver from CGEM long/lat. on the Site Information tab definitely works.

I power up the RPI3 and CGEM all at the same time. Then the CGEM is setup: polar aligned, long/lat, time, date and star alignment.

Once this is done I typical start up Ekos on the RPI3 and do platesolve to align coordinates.

After disconnecting Ekos on RPI3 and connecting the Mac Ekos to the indiserver on RPI3, the long/lat for site information went to 0's. Let's say that plate solving grass does not work, lol. Using the indi driver settings and its l site information the long/lat were restored and things worked out, and Mac was skewing correctly again...

Any ideas on what went wrong?

Thank you

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 2 days ago #16818

So the EQMod issue was indeed an environment variable called INDIPREFIX. Jasem and I worked to fix that over the last 2 days. Also Jasem has been working on this great new feature with a mount toolbox that you should check out! In addition, we came up with a solution to the build version problem you reported earlier. In the "About KStars" window, we added a timestamp which will indicate the date and time on which the program was built for your reference.

I just finished building the dmg. Jasem will be posting it tomorrow, but I thought it might be good for you guys to test it out before then if you have time.
Please check it out!

drive.google.com/file/d/0B_ivMJINsdQ8SzF...ZWM/view?usp=sharing
The following user(s) said Thank You: alessio.beltrame

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 2 days ago #16820

Rob,
I just had a few minutes this morning, before leaving for work. I tested the EQMod driver only and it worked perfectly. I parked and unparked the mount, slewed to different targets (also involving meridian flips), changed tracking speed and aligned with the CCD simulator and offline Astrometry.net. All tests run smoothly and competed successfully. Excellent work!

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 week 19 hours ago #16858

Rob,
it's still cloudy here, don't even remember the last time I had a clear sky. Anyway, I performed an additional dry run and I confirm that 2.7.8 works as expected. I tested the following:

EQ Mod driver: pass
Canon DSLR driver: pass
AStrometry: pass (both offline and online)
SkySafari: pass
Simulators (focuser, filter wheel, CCD): pass
Scheduler: pass (first time I tested this)
SSAG -a.k.a. QHY5 (through QHY CCD driver): (partial) fail

The workaround for the SSAG is to use CloudMakers's Indi Server as a secondary server (with indi_ssag_ccd driver), then launching Ekos builtin server as the primary one from the CLI on a different TCP port and relaying the CM server through it. Not suitable for the typical Mac user, but it works nicely. After that, the SSAG connects to Ekos and works smoothly in the guiding module. Well, of course that only proves the SSAG/QHY5 isn't handled by the indi_qhy_ccd driver as expected. The Kstars Mac build per se is great!

Next week I should be able to get my hands on a new USBfocusv3 and I'll report on that ASAP. In the meantime I'm very confident that this built is ready to be used in the field.

By the way, what'd you mean with "Jasem has been working on this great new feature with a mount toolbox that you should check out!"?


EDIT: I can now confirm that the USB_focus v3 also works with 2.7.8 on Mac.

Please Log in or Create an account to join the conversation.

Last Edit: by alessio.beltrame.
Time to create page: 0.684 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica