Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: Astroberry Server

Astroberry Server 2 months 1 week ago #17708

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 368
  • Karma: 3
  • Thank you received: 120
There are some strange things happening with your system. I would strongly recommend reflashing.
What I mean by "restart your RPi (over ssh)" is to start terminal and or connect to the RPi over ssh and run "sudo reboot" - this will safely reboot your device.
Beware that switching RPi off and on by just disconnecting power plug is not safe. It will for sure corrupt your filesystem. It's just like disconnecting power plug of your PC. What you need to do is to safe shutdown (ex. sudo poweroff) or safe reboot (ex. sudo reboot). You should never unplug power before safe shutdown.
The following user(s) said Thank You: HelgeMK

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 1 week ago #17753

Dear Radek,

With rebooting I usually manage to get the system running again, after a few attempts. I reflashed the sd card, but issue is persisting. Could it be that it has to do with the certificate? (I saved the certificate on my laptop, and confirmed exception, following a security alert). Not sure what else I can do.

Btw: focuser runs smoothly, see picture.

Best, Helge

Best, Helge
Attachments:

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 1 week ago #17756

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 368
  • Karma: 3
  • Thank you received: 120
Hi Helge
What issue stays unresolved? Can you confirm you follow guidelines in readme file ?

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 1 week ago #17776

Hm...I find it difficult to admit, but since I have run an update of the operating system, as suggested in the guideline (sudo apt-get update), now seems fine!

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 5 days ago #17863

  • maudy
  • maudy's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 282
  • Karma: 2
  • Thank you received: 23
Is there a way for force RPI3 to update time right away?

Something has changed and it seems to take 5 minutes or so for the NTP server to grab the correct time.

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 5 days ago #17865

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 368
  • Karma: 3
  • Thank you received: 120
Do you mean updating time from the Internet or from GPS?

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 5 days ago #17867

  • maudy
  • maudy's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 282
  • Karma: 2
  • Thank you received: 23
Internet please.

Ideally the time is updated from Internet or I can do manually.

Manually would be done from a remote site. Or done with Kstars syncing computer to device time.

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 4 days ago #17873

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 368
  • Karma: 3
  • Thank you received: 120
As already described in this thread the system time is synchronized with NTP. It works in two modes: (1) if you have Internet connection NTP gets time from public NTP servers, (2) if you don't have INternet connection NTP gets time from GPSD server (assuming you have a gps connected to your raspberry). If you don't have INternet connection and gps connected to your raspberry the only option is to set the time manually.
Now, where the time setting delay may come from? NTP does not set the time in one jump. Instead it sets the system time in a few jumps, chasing the actual time. I believe this is for consistency of many processes running on a system. To get it quicker you need to install ntpdate and run it once at system boot. It will set the time and leave little distance for NTP to chase the exact time.
Anyway I would advice to use GPS module with RTC (real time clock) or just RTC module so your raspberry keeps the date and time between reboots.

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 4 days ago #17879

  • maudy
  • maudy's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 282
  • Karma: 2
  • Thank you received: 23
I installed ntpdate. Running it states the socket is in use.

GPS is not possible for me at this time. Need to get a few other things first :)

Kstars still crashes on me on the RPI3 unfortunately. To restart and match date ASAP, I want to get the time reset. Is there a process to stop, perhaps gpsd, so that ntpdate can work quickly?

Thank you

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 4 days ago #17886

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 368
  • Karma: 3
  • Thank you received: 120
The very first result of this query gives you exact answer: www.google.pl/search?q=ntpdate+socket+is+in+use

General comment to the thread: many of you contact me asking for support in your specific needs and customizations. I treat all of these queries as a feature or change requests. I cannot handle every single case so Astroberry Server fits all your needs. It needs to stay generic to be usable and simple. The more you customize the system the more you need to fix the issues on your own.
The following user(s) said Thank You: maudy, HelgeMK

Please Log in or Create an account to join the conversation.

Astroberry Server 2 months 3 days ago #17904

  • maudy
  • maudy's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 282
  • Karma: 2
  • Thank you received: 23
Understood, it is Ubuntu.

The way it is working now is all that I need. No change sought.

Thank you Kaczorek.

Please Log in or Create an account to join the conversation.

Astroberry Server 1 month 2 weeks ago #18289

Dear Kaczorek,

I just installed astroberry and was able to run a few first tests. I am very impressed! You managed to put together a very useful project. I can't wait to collect some reaö photons with astroberry. Thanks a lot for sharing your work!

Are you familar with THELI as a software for astronomical data reduction?

www.astro.uni-bonn.de/theli/

I was wondering whether the RPI3 powerful enough to run THELI. Just a thought.

Best wishes
Stephan

Please Log in or Create an account to join the conversation.

Last Edit: by Pepe.Lombris.
Time to create page: 0.434 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica