Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Indi 1.5.0 compilation problem with Goqat

Indi 1.5.0 compilation problem with Goqat 1 month 2 weeks ago #18942

  • oleg
  • oleg's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 264
  • Karma: 3
  • Thank you received: 75
Wait...
What is your OS?

I do not have any problem in GoQat 2.1.2 compilation with INDI Library: 1.5.0
astronom@ubuntu:~/goqat-2.1.2$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for ./autogen.sh... no
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking dependency style of gcc... gcc3
checking for bash... /bin/bash
checking for perl... /usr/bin/perl
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK... yes
checking for LIBGOOCANVAS... yes
checking for gdk_seat functions in gdk... no
checking for glib-2.0 >= 2.32... yes
checking for main in -lqsiapi... yes
checking for ReadoutSpeed in QSI library... yes
checking for LIBUSB... yes
checking for libusb_init in -lusb-1.0... yes
checking for libusb_error_name... yes
checking for LIBUDEV... yes
checking for libindi >= 1.4.0... yes
checking for connect in -lindiclient... yes
checking how to run the C++ preprocessor... g++ -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for LIBGTHREAD... yes
checking for LIBV4L2... yes
checking for GraceOpenVA in -lgrace_np... yes
checking for pin_init_user in -lparapin... yes
checking for XPAOpen in -lxpa... yes
checking for /usr/include/xpa/xpa.h... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for std::unique_ptr... no
checking for std::auto_ptr... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating data/DemoScript.pl
config.status: creating data/DemoScript.sh
config.status: creating data/Analyse_HFD.pl
config.status: creating data/GoQat_SExtractor.pl
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating src/config.h
config.status: executing depfiles commands
The following user(s) said Thank You: knro, dudrea

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy
Last Edit: by oleg.

Indi 1.5.0 compilation problem with Goqat 1 month 2 weeks ago #18967

  • dudrea
  • dudrea's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Thanks Oleg for your answer,

I use Ubuntu 16.04

Like for you the ./configure command doesn't fall in error. See below

Problems are lined to the make command
decebal@Hei-Long:~/softs-Astro/goqat-2.1.2$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for ./autogen.sh... no
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking dependency style of gcc... gcc3
checking for bash... /bin/bash
checking for perl... /usr/bin/perl
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK... yes
checking for LIBGOOCANVAS... yes
checking for gdk_seat functions in gdk... no
checking for glib-2.0 >= 2.32... yes
checking for main in -lqsiapi... no
configure: ******** No QSI library - compiling without QSI CCD camera support!
checking for ReadoutSpeed in QSI library... no
checking for LIBUSB... yes
checking for libusb_init in -lusb-1.0... yes
checking for libusb_error_name... yes
checking for LIBUDEV... yes
checking for libindi >= 1.4.0... yes
checking for connect in -lindiclient... yes
checking how to run the C++ preprocessor... g++ -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for LIBGTHREAD... yes
checking for LIBV4L2... yes
checking for GraceOpenVA in -lgrace_np... no
configure: ******** No grace library - compiling without Grace support!
checking for pin_init_user in -lparapin... no
configure: ******** No parapin library - compiling without parallel port support!
checking for XPAOpen in -lxpa... no
configure: ******** No xpa library - compiling without DS9 support!
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for std::unique_ptr... no
checking for std::auto_ptr... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating data/DemoScript.pl
config.status: creating data/DemoScript.sh
config.status: creating data/Analyse_HFD.pl
config.status: creating data/GoQat_SExtractor.pl
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating src/config.h
config.status: src/config.h is unchanged
config.status: executing depfiles commands

Please Log in or Create an account to join the conversation.

Denis Decebal UDREA
Last Edit: by oleg.

Indi 1.5.0 compilation problem with Goqat 1 month 2 weeks ago #18979

  • oleg
  • oleg's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 264
  • Karma: 3
  • Thank you received: 75
You have to install these:
sudo apt install gawk grace
The following user(s) said Thank You: dudrea

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy

Indi 1.5.0 compilation problem with Goqat 1 month 2 weeks ago #18982

  • dudrea
  • dudrea's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Thanks. Not really sure I need Grace... But I did it however.
Same results error from indiclient.cpp

"indi_client.cpp
In file included from /usr/include/c++/5/thread:35:0,
from /usr/include/libindi/baseclient.h:27,
from indi_client.cpp:36:
/usr/include/c++/5/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
#error This file requires compiler and library support \"

Please Log in or Create an account to join the conversation.

Denis Decebal UDREA

Indi 1.5.0 compilation problem with Goqat 1 month 2 weeks ago #18983

  • dudrea
  • dudrea's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
After some web exploration I succeed to put an compiler's option like CCCFLAGS=-std=cxx11
This options works and the preceding error has disappeared.

But ther's another one now : "cannot convert 'std::__cxx11::string{aka std::__cxx_string<char>} to 'const char*' for.......
After exploring the net I founded that problem seems linked to an incompatibility with .... CXX11 option !
It's quite embarrassing... For one part I need this option for the other it's incompatible !

Please Log in or Create an account to join the conversation.

Denis Decebal UDREA

Indi 1.5.0 compilation problem with Goqat 1 month 2 weeks ago #18985

  • oleg
  • oleg's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 264
  • Karma: 3
  • Thank you received: 75
Hmm...
My OS based on Ubuntu 16.04.3 (64-bit), but I do not have similar problem.

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy

Indi 1.5.0 compilation problem with Goqat 1 month 2 weeks ago #19036

  • dudrea
  • dudrea's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Hi
Goquat Author thinks there's a retro-compatibility problem with indi version 1.5.0. He's yet looking...

I should like try to use the indi version 1.4.0 But cannot install it ! There's a broken packet with the + libgsl0-dev dependency

Have I to compile source of 1.4.0 or does some another solution exists ?

Please Log in or Create an account to join the conversation.

Denis Decebal UDREA

Indi 1.5.0 compilation problem with Goqat 1 month 1 week ago #19038

  • oleg
  • oleg's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 264
  • Karma: 3
  • Thank you received: 75

dudrea wrote: Hi
Goquat Author thinks there's a retro-compatibility problem with indi version 1.5.0. He's yet looking...

I should like try to use the indi version 1.4.0 But cannot install it ! There's a broken packet with the + libgsl0-dev dependency

Have I to compile source of 1.4.0 or does some another solution exists ?


Another solution is Ubuntu Astronomy 16.04 .
The following user(s) said Thank You: dudrea

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy

Indi 1.5.0 compilation problem with Goqat 1 month 1 week ago #19039

  • dudrea
  • dudrea's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Thanks Oleg. Will try that

Please Log in or Create an account to join the conversation.

Denis Decebal UDREA

Indi 1.5.0 compilation problem with Goqat 1 month 1 week ago #19072

  • dudrea
  • dudrea's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
I've tried Ubuntu Astronomy. Nice ! but most of capture programs doesn't recognize my DMK21 and the one I wanted since the beginning is GoQat .

Goqat is present in this distribution, but say :

"Error when loading shared libraries libindi.so.1: cannot open shared object file: no such file or directory"

Quite vexing isn't :-(

And I can't get this file cause I'm connected with a guest account, given the fact I don't know password of "astronom" user

Please Log in or Create an account to join the conversation.

Denis Decebal UDREA

Indi 1.5.0 compilation problem with Goqat 1 month 1 week ago #19073

Ok, so I took a look at it. In Makefile.am, after bin_PROGRAMS = GoQat, add this:
AM_CXXFLAGS = -std=gnu++11

Then in indiclient.cpp, go to the end of the file, replace function newMessage with this:
void INDIClient::newMessage (INDI::BaseDevice *dp, int messageID)
{
	/* Display a message from the indi server */
	indi_new_message (dp->messageQueue (messageID).c_str ());
}

I was missing few dependencies as well, so I ran this:
sudo apt-get install libudev-dev automake

Then simply run ./configure --prefix=/usr

then make and make install. I tested it with latest INDI and it works.
The following user(s) said Thank You: nmac, dudrea

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Last Edit: by knro.

Indi 1.5.0 compilation problem with Goqat 1 month 1 week ago #19082

  • dudrea
  • dudrea's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Thanks,

I'll try that in a few day : I've a little travel now..

Please Log in or Create an account to join the conversation.

Denis Decebal UDREA
  • Page:
  • 1
  • 2
Time to create page: 0.222 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica