Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: apt-get update problems with INDI (Unmet dependencies)

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22391

Hey guys,
A while back I installed the latest KStars or maybe it was Stellarium? That had the INDI drivers included. Since then when I do the apt-get upgrade/install I get a message about unmet dependencies and I can't get further.
This is the result:
tegwilym@Tom-Ubuntu:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.2) but 1.1.0-1ubuntu1 is installed
 libindi-dev : Depends: libindi1 (= 1.6.0+r3702~201801031125~ubuntu16.04.1) but 1.1.0-1ubuntu1 is installed
E: Unmet dependencies. Try using -f.
Running the "-f" option doesn't do anything to fix the problem. Is there a way that I can remove INDI from my computer? I've checked other messages in this forum with similar problems and their fixes don't work either. I'm currently running Ubuntu 16.10 and will upgrade to 18 LTS, but just skipping 17.x for now since it seems to be a mediocre update. I do hope to get deep into INDI eventually, when I set up a new observatory (probably with a NexDome) since I plan on moving and will probably sell/donate my Technical Innovations dome (which isn't supported). I really want to get away from Windows 7 and go totally Linux eventually!

Any ideas how I can just remove it for now so I can run updates on my OS?
Thanks,
Tom
The following user(s) said Thank You: oleg

Please Log in or Create an account to join the conversation.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22392

did you try sudo apt-get dist-upgrade?

Please Log in or Create an account to join the conversation.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22395

Yep! Tried that. Got this result. (same thing)
sudo apt-get dist-upgrade
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.2) but 1.1.0-1ubuntu1 is installed
 libindi-dev : Depends: libindi1 (= 1.6.0+r3702~201801031125~ubuntu16.04.1) but 1.1.0-1ubuntu1 is installed
E: Unmet dependencies. Try using -f.

Please Log in or Create an account to join the conversation.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22397

sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt-get update && sudo apt-get install kstars-bleeding indi-full gsc

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22417

I had almost the same problem, try this....it worked for me as my updates would not work and got dependencies error...
Did a search on the web and came across this.....
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by AstroNerd.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22434

  • oleg
  • oleg's Avatar
  • Offline
  • Moderator
  • Moderator
  • Astronomy Linux
  • Posts: 294
  • Karma: 5
  • Thank you received: 87
Tom,
you can download and try my open project "Ubuntu Astronomy 16.04" (64-bit).
IMHO, it can help you on your Linux newbie road :)

Please Log in or Create an account to join the conversation.

You can try my open project Astronomy Linux

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22435

  • oleg
  • oleg's Avatar
  • Offline
  • Moderator
  • Moderator
  • Astronomy Linux
  • Posts: 294
  • Karma: 5
  • Thank you received: 87
On the other hand, you can use synaptic, if you want to delete this old version libindi1 (1.1.0-1ubuntu1).

Open the terminal and run:
sudo apt-get install synaptic

sudo synaptic

Please Log in or Create an account to join the conversation.

You can try my open project Astronomy Linux

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22437

Tried this and the previous suggestion. Still the same thing.

Please Log in or Create an account to join the conversation.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22438

oleg wrote: Tom,
you can download and try my open project "Ubuntu Astronomy 16.04" (64-bit).
IMHO, it can help you on your Linux newbie road :)


I already have! Excellent variation of Ubuntu. I have it as a dual boot on my laptop. Eventually I'll probably try dual booting with Windows 7 (yuck!) on my observatory computer. I just would have to reboot to Windows to control my dome since I don't see any support in INDI for the Technical Innovations dome. :(

Thanks for your work on Ubuntu Astronomy, I really do like it, and hopefully will be the main OS in my observatory one of these days! :)
Tom

Please Log in or Create an account to join the conversation.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22439

Tried Synaptic and get this familiar message.
tegwilym@Tom-Ubuntu:~$ sudo apt-get install synaptic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.2) but 1.1.0-1ubuntu1 is to be installed
 libindi-dev : Depends: libindi1 (= 1.6.2+r3729~201801140557~ubuntu16.04.1) but 1.1.0-1ubuntu1 is to be installed
 synaptic : Depends: libept1.5.0 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
tegwilym@Tom-Ubuntu:~$

Please Log in or Create an account to join the conversation.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22440

  • oleg
  • oleg's Avatar
  • Offline
  • Moderator
  • Moderator
  • Astronomy Linux
  • Posts: 294
  • Karma: 5
  • Thank you received: 87
sudo apt-get -f install

Please Log in or Create an account to join the conversation.

You can try my open project Astronomy Linux
Last Edit: by oleg.

apt-get update problems with INDI (Unmet dependencies) 4 months 1 week ago #22441

Seems that the INDI problem is blocking me from installing any "apt-get install xxxx" packages.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.116 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica