Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Synscan coordinates differ from those of the solver

Synscan coordinates differ from those of the solver 3 months 2 days ago #26001

I played with this some over the weekend. I changed the code so it sends RA/Dec instead of Alt/Az. The Dec axis gets updated just fine, but the RA axis wouldn't update. Not sure what's going on. I will have to mess with it some more.
The following user(s) said Thank You: gbeaton, Frank

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 3 months 2 days ago #26012

  • Frank
  • Frank's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 24
  • Thank you received: 0

kross wrote: I played with this some over the weekend. I changed the code so it sends RA/Dec instead of Alt/Az. The Dec axis gets updated just fine, but the RA axis wouldn't update. Not sure what's going on. I will have to mess with it some more.


Brilliant!! :o
This sounds considerably good! Thanks for your efforts. I'm curious to see the final result and to finally use the SynScan also with ekos.
I look forward to hearing from you!
Bye! ;)

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 3 months 2 days ago #26014

kross wrote: I played with this some over the weekend. I changed the code so it sends RA/Dec instead of Alt/Az. The Dec axis gets updated just fine, but the RA axis wouldn't update. Not sure what's going on. I will have to mess with it some more.


By the way, I hope you guys can keep this driver compatible with the V3 hand controller because I discovered that older HEQ5 mounts cannot upgrade to the V4 version. Thank you for your work on this!

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 3 months 2 days ago #26015

  • kecsap
  • kecsap's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 85
  • Karma: 4
  • Thank you received: 34

gbeaton wrote:

kross wrote: I played with this some over the weekend. I changed the code so it sends RA/Dec instead of Alt/Az. The Dec axis gets updated just fine, but the RA axis wouldn't update. Not sure what's going on. I will have to mess with it some more.


By the way, I hope you guys can keep this driver compatible with the V3 hand controller because I discovered that older HEQ5 mounts cannot upgrade to the V4 version. Thank you for your work on this!


The driver is compatible with V3/V4 handsets, just be sure to upgrade the firmware to something recent V3.37+/V4.37+.

Although I don't have a cable I plan to submit a fix for the syncing issues, but I am very busy these days.
The following user(s) said Thank You: Frank

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26063

  • kecsap
  • kecsap's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 85
  • Karma: 4
  • Thank you received: 34
I created a fix for this issue ( github.com/indilib/indi/pull/598 ) and it was merged. It will appear tomorrow or after that in the PPA updates.

Disclamer: I don't have a Synscan cable nor an EQ mount. My change _should_ work out of the box, but no guarantee as it was not tested. Please test first carefully, do manual syncs without plate solving and see if +/- RA/DEC coordinates are synced correctly to the handset. And report back the results in any case.

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26064

  • Frank
  • Frank's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 24
  • Thank you received: 0

kecsap wrote: I created a fix for this issue ( github.com/indilib/indi/pull/598 ) and it was merged. It will appear tomorrow or after that in the PPA updates.

Disclamer: I don't have a Synscan cable nor an EQ mount. My change _should_ work out of the box, but no guarantee as it was not tested. Please test first carefully, do manual syncs without plate solving and see if +/- RA/DEC coordinates are synced correctly to the handset. And report back the results in any case.


Hi kecsap!
Thank you very much for your work. I will test your fix as soon as possible.

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26068

Your change was near identical to what I tried. Same result, too. Dec gets updated fine, but RA either has some really weird offset, or doesn't update at all. :(

Maybe Frank will have better luck with his mount.

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26073

  • kecsap
  • kecsap's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 85
  • Karma: 4
  • Thank you received: 34

kross wrote: Your change was near identical to what I tried. Same result, too. Dec gets updated fine, but RA either has some really weird offset, or doesn't update at all. :(

Maybe Frank will have better luck with his mount.


There are two things in the Sync() function: position reset and the actual sync command. Can you do a quick check what happens if you remove the position reset command? Does it fix the situation? As I remember, the position reset was not there originally before my refactor, but it was needed for Alt/Az mounts to work properly. It is possible that it is unnecessary for EQ mounts.

Please Log in or Create an account to join the conversation.

Last Edit: by kecsap.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26074

  • Frank
  • Frank's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 24
  • Thank you received: 0
Hi guys!
in which folder have I to insert the synscanmount.cpp fixed file? I think this should be the fixed package to replace somewhere...
I have a Mac OS Sierra and the tree folder of kstars is /Applications/kstars.app/Contents/

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26075

  • kecsap
  • kecsap's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 85
  • Karma: 4
  • Thank you received: 34
Frank, please wait a bit, the issues are not fixed yet as you can read in the previous two posts.

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26076

  • Frank
  • Frank's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 24
  • Thank you received: 0
Ok! ;)
I was just curious to test your change. I will wait for the final fix! Thank you! :)

Please Log in or Create an account to join the conversation.

Synscan coordinates differ from those of the solver 2 months 4 weeks ago #26092

kecsap wrote:

kross wrote: Your change was near identical to what I tried. Same result, too. Dec gets updated fine, but RA either has some really weird offset, or doesn't update at all. :(

Maybe Frank will have better luck with his mount.


There are two things in the Sync() function: position reset and the actual sync command. Can you do a quick check what happens if you remove the position reset command? Does it fix the situation? As I remember, the position reset was not there originally before my refactor, but it was needed for Alt/Az mounts to work properly. It is possible that it is unnecessary for EQ mounts.


I tried it both ways, with and without that extra bit, with no difference. I made a video showing the behavior.



Sorry, the equatorial grid lines in KStars don't show up unless you watch it in 4K mode. But trust me, the lines are there. :)
The following user(s) said Thank You: knro, kecsap, Frank

Please Log in or Create an account to join the conversation.

Time to create page: 0.190 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica