Get Connected!

Come and join our community. Expand your network and get to know new people!

Sorry, we currently have no events.
View All Events
Magnus replied to the topic 'DIY Flatfield Dustcover with RPi' in the forum. less than a minute ago

RobJones wrote: you might try a count weight along the plane of the flap.
provided you have clearance along the OTA, then only a very small weight would be required.

This would of cource depend on the orientation of the scope when unparking.
I park my scope at alt +1, so a counterweight would not work when unparking the cap at that position.

However... You could add a spring to the equation. Fasten it so the spring is slightly tensioned when the lid is at it heaviest. This might cause the lid to not stay completely closed when the servo is not powered, so possibly not a god idea? Ebay id for some springs 281291676039


Rob Jones replied to the topic 'DIY Flatfield Dustcover with RPi' in the forum. 40 minutes ago

you might try a count weight along the plan of the flap.
provided you have clearance along the OTA, then only a very small weight would be required.


Khalid replied to the topic 'IOptron Driver NOT WORKING with 8401 Hand Controller' in the forum. 4 hours 16 minutes ago

I have a Celestron CG5 mount with the GotoNova Upgrade Kit. The hand controller is 8401. The one with a standard printer type USB cable for connection to a computer.

On a laptop running Xubuntu 16.04, I installed kstars-bleeding, and indi-full from Jasem's PPA. It is from three days ago.

Initially, I used the Astro Physics (lx200ap) driver under the stars and posted about that here:

Per Jasem's comment in the same thread, I am testing the ZEQ25.

It is daytime here, and there is no clear skies in the forecast, so testing is indoors.

I right clicked on Muscida, and then from the context menu, I asked the mount to slew. It does slew successfully to this star. Can't tell of the Goto is accurate or not, or whether there is an offset due to time zone or such. I then selected a sync from the context menu.

The next slew was to 15 Lyncis, and that was successful too.

Then I asked the mount to go to the Double Cluster (Chi Persei), and the mount moved a tiny amount (a degree or less), then reported a time out. Opening the Mount Control from Ekos, searching the name of the object, and selecting Goto does the same thing: mount moves for a degree or less, then stops. Clicking Goto again makes it move a degree or less, then stops. Timeouts are reported in the bottom part of the INDI panel.

Any help appreciated.


pauledd replied to the topic 'DIY Flatfield Dustcover with RPi' in the forum. 4 hours 28 minutes ago

Thank you Magnus_e for your detailed ideas!

I am nearly 98% sure its a weight issue. The cap moves fully if the scope is slightly of the home-position so that the cap is not in its "heaviest position". I currently discuss my torque/weight calculations on a physic-board and its a little bit more complex than I thought.
Someone presented a formula to get the caps torque when its opened at 90° degree (the most heavy position):
Mk: is the needed cap torque
m: is mass of the cap
g: Gravitational acceleration (9.81)
l: length of the cap (diameter)

With that formula he got about 13Ncm force needed to move the cap.
My motor has 46Ncm divided by 3.8cm of the servo arm that makes ~12Ncm.
I have no confirmation yet that its the right way to calculate it but it seems my motor
specs missed the caps torque very close. So I am quite shure replacing the acrylic cap
with 0.5 or 1 aluminium will do the trick. I will order two sheets of it, its quite cheap.


Magnus thanked Stephane in topic DIY Flatfield Dustcover with RPi 5 hours 8 minutes ago
Magnus replied to the topic 'DIY Flatfield Dustcover with RPi' in the forum. 5 hours 12 minutes ago

Great work, and nice to see you are making progress :)

Something you can try to be 100% sure that it is a weight issue is to see that your servo in fact can move further with the lid disconnected (just remove the bolt that is connecting the brass / anodized servo horn to the wood linkage.

The reason for this is that from watching the video I'm not entirely sure if the lid stops when it has past the point where it's the heaviest, or just after.
(When I think about it, you don't have to unscrew anything. Just point the scope at the zenith. If it fails to move at all or if it opens to the expected position, it's the weight for sure).

However it might be servo centering. When you hear the bussing at the most open position, and it stops to move then it is binding.
There is three ways a servo can bind.
1. The object that is being actuated reaches a mecanical endpoint, and can move no further.
2. The object being moved is to heavy and the servo motor is skipping.
3. Internal binding.

If the weight test above do not proove it's the weight (i.e servo motor skipping) then it's allmost certanly internal binding.
Servos work at a PWM pulse from 0.5 - 2.5, at least some of them! There is no standard that ceeps a servo from actually woriking in PWM range 1.0 - 2 as an example.
If you tell a servo to go to PWM 0.5, and it has internal limits at 1, then the servo will appear to bind, even if it is not binding at an endpoint or skipping from overload.

If you have not done so allready, you can disconnect the servo horn completely, and try to Park / Unpark while encreasing / decreasing the (Max travel limits [set open travel (ms), set close travel (ms)]) in the Calibrate tab. You should aim for the limits closest to 0 and 3 that you can acchieve while the servo makes no sound at the endpoints. You should do this while the (Preffered travel limits [set open limit (%), set close limit (%)]) is set to 100, 100

After that set your close limit to 90 - 95%, park the cap and attach your servo horn and linkage while the lid is closed against the telescope. (Then you have 10 - 5 % to work on when the lid is connected to the servo, to ensure that it can close fully). Leave your preferred open limit at 100%, as it does not look like your setup will bind.

Hopes this helps to determen if you need new servo / lighter lid, or if you can calibrate it out, (not sure if I explaned thiswell enough on the github readme, so tought I'll go into some detail :) )


Dan Holler created a new topic ' IOptron Driver NOT WORKING with 8401 Hand Controller' in the forum. 5 hours 13 minutes ago

In spite of thoughts this bug has been eliminated in the IOptron driver, it hasn't. When using a series 8401 hand control, the driver does connect, does some motions and displays do appear on the KStars map, but, the system hangs and is not working properly. Any help would be greatly appreciated.



Olivier Masse replied to the topic 'Problem with EQMod' in the forum. 6 hours 37 minutes ago


To test my Raspberry (I was thinking about a USB problem), I did a restore with a March backup without performing update, and all is ok.

Thanks knro


Jasem Mutlaq replied to the topic 'Problem with EQMod' in the forum. 6 hours 59 minutes ago

It _might_ be an issue with the PPA build, please wait until later today for an update.


Jasem Mutlaq replied to the topic 'iOptron Gotonova driver' in the forum. 7 hours ago

The information is this thread is obsolete. There is already a ZEQ25 driver you can use. Use "SmartEQ" or "ZEQ25", they're the same. When using Ekos, there is no need to perform 2/3 star alignment, you can use Ekos right away and do the sync in there. I do not recommend you "Sync" manually, use Align module to do any syncs by solving images. But you can just click on the sky map on any object and then from the mount submenu you can select sync.

For other issues, please open a new topic.


Dan Holler replied to the topic 'iOptron Gotonova driver' in the forum. 7 hours 56 minutes ago

If you go back a page in this thread, I have already posted all of my findings involving the 8401 hand control. My suggestion would be, if your upgrade kit is still under warranty, contact IOptron and request they visit this topic. Perhaps, they will correct the driver to be more versatile than just the 8407 hand controller.

Other possible solutions were to contact IOptron and purchase the 8407 hand control as a replacement part, however, only with their assurance would I do this. Because the cost is likely almost as much as the upgrade, I never followed this option.

Please do post whatever you might find. Thanks,


David Sidote created a new topic ' QHY5L-II Mono maximum exposure' in the forum. 9 hours 38 minutes ago

I am running Kstars/Ekos on a RPi3 with a QHY5L-II M as an all-sky camera. It works great except I can't take exposures longer than 19 seconds without the download hanging. If I try to take a 20 second exposure in either preview or as a series in the sequence queue, the exposure timer counts down and then nothing happens. The image doesn't download and the camera becomes unresponsive requiring a restart of the indi_qhy process.

Does the INDI QHY driver have a maximum exposure for this camera or do I have something set incorrectly?



Stephen thanked Keith Cobby in topic Reasonable Align Accuracy for CGEM 9 hours 39 minutes ago
Stephen replied to the topic 'Reasonable Align Accuracy for CGEM' in the forum. 9 hours 39 minutes ago

I believe so, the astrometry files are the recommended, and some smaller ones were just added in case it can help resolve faster.

As things seems to work, the FOV was not directly calculated. I will double check.


Stephen replied to the topic 'INDI/Linux driver for the QHY Polemaster, developers needed.' in the forum. 9 hours 41 minutes ago

Yes, this worked for me in my test!

The primary scope is defined and now used for both imaging and guide camera. The guide scope is now fictions (120mm aperture and 480mm FL) and used with polemaster.

Now I just need skies... oh where did they go?


Stephen replied to the topic 'PHD2 and scheduler shutdown...' in the forum. 9 hours 45 minutes ago

I will definitely give this a try.

Perhaps some day I will be able to get leaving the guiding as part of the scheduler, checked off in the scheduler. Until this perhaps this can help get dither working for me :)


Stephen thanked Patrick Chevalley in topic PHD2 and scheduler shutdown... 9 hours 47 minutes ago
pauledd replied to the topic 'DIY Flatfield Dustcover with RPi' in the forum. 13 hours 17 minutes ago

I made "some" progress with my dustcover. I decided to make parts of it made of wood because that was the easiest. In the course of this I realized that I was maybe wrong with the assumption that my littly tiny servo would have enough power.

I left the EL-Flatfield Foil away to just concentrate on the dustcover. The cover itself as baseplate for the foil was made of acrylic glas.

Its weight is about 150g. Some tests showed I would need about 800g force to lift the arm. That approx. matched my calculations I did before:

However this does not work. I can unpark the cap but the servo never reaches the end position and stays making noise.
I tried to increase the servo voltage up to 6.7 Volts but it still doesn't reach the end position. I dont know whats wrong here because with that 3.8cm servo arm it should be able to handle up to 1.2Kg on that arm.

Before I consider to buy another stronger servo I'll try to replace the dustcover with an aluminium one, 0.5mm thickness, that should give a weight of about 20cmx20cmx0.05cmx2.6g= 52g and that should give a load on the servo of about 52x4.73= 245g, one third of my current weight.

Here's just a short video of my dustcover in action, looks good but doesn't reach end position and continuously makes noise.


Khalid replied to the topic 'iOptron Gotonova driver' in the forum. 16 hours 22 minutes ago


Can you please elaborate a bit? Specifically, what works, what does not, problems faced, ...etc. I would really appreciate it if you find the time to do.



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!