Scott Muckleroy replied to the topic 'FocusLynx Motor selection' in the forum. 4 weeks ago

Strange. Are you connected by USB or Eth? I'm connected Eth.

Read More...

Scott Muckleroy replied to the topic 'FocusLynx Motor selection' in the forum. 4 weeks ago

Do you have the same problem of INDI resetting the focus position to 0 when you connect to the FocusLynx? I have posted a request to have INDI just connect and NOT reset the focus position but not sure how long it will take to be resolved.

Read More...

Scott Muckleroy replied to the topic 'Easy Backup/Restore of KStars/INDI' in the forum. 1 month ago

Thanks! I'm fortunate to have the 150ft USB3 cable to my mount so I run everything on my PC (Ubuntu 18.04) so no Pi running at the mount.

Read More...

Scott Muckleroy created a new topic ' Easy Backup/Restore of KStars/INDI' in the forum. 1 month ago

It would be nice to have a Backup/Restore module in KStars that could be used to backup all KStars/INDI settings, Add-on's(images/catalogs), profiles, astrometry.net files, darks, etc.

Read More...

Scott Muckleroy replied to the topic 'FocusLynx Motor selection' in the forum. 1 month ago

I choose the High-speed motor for my HSM30 and it seems to be working fine. I tried the High-torque option and the focuser made a very unhappy sound so I assumed high-torque was not the correct optioin.

Read More...

Scott Muckleroy replied to the topic 'FocusLynx last focus Position not pulling from controller' in the forum. 1 month ago

Another feature that would be nice is to add options to disable temperature compensation during auto focus routines and then re-enable when complete. I'm not sure if it is good to have AF and T.comp running at the same time.

Unrelated to this issue a nice feature would be a setting to skip any auto focus routine that might be part of a Imaging sequence; If last focus < x min ago and/or temp change < 1 degree.

What I have noticed is that when setting up sometimes I will run an autofocus and then run a sequence and it will Autofucus when solving the location. Or for this do I just need to uncheck the "Focus" box in the profile for the sequence? that doesn't disable focus routines for time/temp change does it?

Let me know if you need any more information for the original focus position reset issue.

Thanks,
Scott

Read More...

Scott Muckleroy replied to the topic 'FocusLynx last focus Position not pulling from controller' in the forum. 2 months ago

See attached logs.

This is a link to the FocusBoss II controller. I think it is just a rebranded version of the OpTec: starlightinstruments.com/store/index.php...oduct&product_id=305

I just discovered that connecting to F2 also resets F1 to "0".

Thanks,
Scott

Read More...

Scott Muckleroy created a new topic ' FocusLynx last focus Position not pulling from controller' in the forum. 2 months ago

For some reason INDI doesn't pull the focus position from the FocusLynx/Focus Boss II when you connect to it. Even worse when you connect it resets the focus position to "0" which forces you to manually focus to "0" and "sync" in INDI. The Default INDI behavior should be to pull the focus position from the Hub. Maybe add an option/check box to "Reset focus position to 0 on connect" if there is a situation that that would be preferred?

Read More...

Booom! Problem solved! Thanks for your help!

Read More...

I just tried again after an update and still have the issue. Is the PPA update for this issue there? Do I need to do a clean install?

Thanks,
Scott

Read More...

I did a sudo apt-get update/upgrade and it updated 3 kstars packages and I still have the same issue. Is a Git pull different?

Read More...

Here are the logs. I was wrong before. Looks like I am still getting both the error and the Warning. See attached.

Read More...

Good news; This error is gone now- 2018-07-31T14:13:19: [WARNING] Could not process mount date and time: 07/31/18#T

Still getting this error- 2018-07-31T14:13:24: [ERROR] Error setting local date.

After connecting the scope still doesn't point at polaris. On the Site Management tab, the UTC can't be set and is Red not Green.

Thanks for your help getting this resolved!

Read More...

Having issues getting it to work again but attached are the logs with it failing. I must be missing an uninstall or configuration file(s) someplace. I'll keep working on it. Let me know if you need a different log file.

Read More...

Maybe this will help narrow down the issue? After opening testing and closing KStars several times and Gemini working correctly I installed this and started getting the errors in the logs again.

Installed this: sudo apt-get install libindi1 indi-bin

And started getting this in the logs again:
2018-07-31T05:23:17: [INFO] Site location updated to Lat 48:03:48 - Long 237:04:01
2018-07-31T05:23:17: [ERROR] Error setting local date.
2018-07-31T05:23:02: [WARNING] Could not process mount date and time: QT
2018-07-31T05:22:47: [WARNING] Failed to get site latitude from device.
2018-07-31T05:22:37: [ERROR] Failed to retrieve time format from device.
2018-07-31T05:22:27: [INFO] Losmandy Gemini is online.
2018-07-31T05:22:27: [INFO] Connecting to 192.168.0.111@11110 ...

Read More...

Uninstalled KStars/INDI and deleted all of the config files and directories I could find. Installed Kstars 2.9.4 from the Ubuntu app store and mount control is working correctly again. Now I'm going to figure out how to install just the INDI modules for my QHY and ASI cameras without installing INDI-Full. Do you know how often KStars gets updated on the Ubuntu app store?

Read More...

Gerrrrr! I'm about to shoot my mount or something. I uninstalled Kstars and did a test with just the stable version of KStars 2.9.4 installed and it worked correctly. Then I installed INDI-Full, added the rest of my devices and now it is doing the same thing, Connect to the mount and Kstars thinks it is pointing below the horizon. If I sync Losmandy on Polaris and do a slew it slews but doesn't update in KStars (2.9.4 still)and goes back to pointing below horizon after disconnect/reconnect.

I uninstalled indi-full and it still doesn't work correctly. I'm going to try to uninstall everything again and see if I can see where everything goes wrong. This is so strange because everything worked great for several weeks.

Here are the logs:
[2018-07-30T15:28:27.877 PDT DEBG ][ org.kde.kstars.ekos] - 1 devices connected out of 1
[2018-07-30T15:28:27.877 PDT INFO ][ org.kde.kstars.ekos] - All INDI devices are now connected.
[2018-07-30T15:28:27.959 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < ON_COORD_SET >
[2018-07-30T15:28:27.973 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < EQUATORIAL_EOD_COORD >
[2018-07-30T15:28:27.976 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_ABORT_MOTION >
[2018-07-30T15:28:27.979 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_TRACK_MODE >
[2018-07-30T15:28:27.980 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_TRACK_STATE >
[2018-07-30T15:28:27.981 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_MOTION_NS >
[2018-07-30T15:28:27.984 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_MOTION_WE >
[2018-07-30T15:28:27.987 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_SLEW_RATE >
[2018-07-30T15:28:27.987 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TARGET_EOD_COORD >
[2018-07-30T15:28:27.988 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TIME_UTC >
[2018-07-30T15:28:27.990 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < GEOGRAPHIC_COORD >
[2018-07-30T15:28:27.994 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_PARK >
[2018-07-30T15:28:27.994 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_PIER_SIDE >
[2018-07-30T15:28:27.996 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < SCOPE_CONFIG_NAME >
[2018-07-30T15:28:27.997 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < APPLY_SCOPE_CONFIG >
[2018-07-30T15:28:27.997 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < USEJOYSTICK >
[2018-07-30T15:28:27.997 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < Use Pulse Cmd >
[2018-07-30T15:28:27.999 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < Sites >
[2018-07-30T15:28:27.999 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < Site Name >
[2018-07-30T15:28:28.000 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_TIMED_GUIDE_NS >
[2018-07-30T15:28:28.003 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < TELESCOPE_TIMED_GUIDE_WE >
[2018-07-30T15:28:28.003 PDT INFO ][ org.kde.kstars.ekos] - "Guider port from Losmandy Gemini is ready."
[2018-07-30T15:28:28.005 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < FOCUS_MOTION >
[2018-07-30T15:28:28.005 PDT INFO ][ org.kde.kstars.ekos] - "Losmandy Gemini focuser is online."
[2018-07-30T15:28:28.011 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < FOCUS_TIMER >
[2018-07-30T15:28:28.016 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < FOCUS_MODE >
[2018-07-30T15:28:28.018 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:GR#> "
[2018-07-30T15:28:32.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] RES <> "
[2018-07-30T15:28:32.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] Coordinate format is high precision. "
[2018-07-30T15:28:32.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <getTimeFormat> "
[2018-07-30T15:28:32.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:Gc#> "
[2018-07-30T15:28:37.892 PDT INFO ][ org.kde.kstars.indi] - Losmandy Gemini : "[ERROR] Failed to retrieve time format from device. "
[2018-07-30T15:28:37.892 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <getSiteName> "
[2018-07-30T15:28:37.892 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:GM#> "
[2018-07-30T15:28:42.896 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] RES <> "
[2018-07-30T15:28:42.896 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] Site Name <> "
[2018-07-30T15:28:42.896 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <getSiteLatitude> "
[2018-07-30T15:28:42.896 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:Gt#> "
[2018-07-30T15:28:47.901 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] RES <> "
[2018-07-30T15:28:47.902 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] Unable to parse response "
[2018-07-30T15:28:47.903 PDT INFO ][ org.kde.kstars.indi] - Losmandy Gemini : "[WARNING] Failed to get site latitude from device. "
[2018-07-30T15:28:47.903 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:GG#> "
[2018-07-30T15:28:52.907 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:GL#> "
[2018-07-30T15:28:57.914 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <getCalendarDate> "
[2018-07-30T15:28:57.914 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:GC#> "
[2018-07-30T15:29:02.921 PDT INFO ][ org.kde.kstars.indi] - Losmandy Gemini : "[WARNING] Could not process mount date and time: hT "
[2018-07-30T15:29:02.921 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < PARK_SETTINGS >
[2018-07-30T15:29:02.923 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] CMD: <<120:u#> "
[2018-07-30T15:29:02.923 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <800x> "
[2018-07-30T15:29:02.923 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < MANUAL_SLEWING_SPEED >
[2018-07-30T15:29:02.924 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] CMD: <<140:s#> "
[2018-07-30T15:29:02.925 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <800x> "
[2018-07-30T15:29:02.925 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < GOTO_SLEWING_SPEED >
[2018-07-30T15:29:02.925 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] CMD: <<145:v#> "
[2018-07-30T15:29:02.925 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <100q> "
[2018-07-30T15:29:02.925 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < MOVE_SLEWING_SPEED >
[2018-07-30T15:29:02.926 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] CMD: <<150:r#> "
[2018-07-30T15:29:02.926 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <0.5k> "
[2018-07-30T15:29:02.926 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < GUIDING_SLEWING_SPEED >
[2018-07-30T15:29:02.927 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] CMD: <<170:p#> "
[2018-07-30T15:29:02.927 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <20B> "
[2018-07-30T15:29:02.927 PDT DEBG ][ org.kde.kstars.indi] - < Losmandy Gemini >: < CENTERING_SLEWING_SPEED >
[2018-07-30T15:29:02.927 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] CMD: <:h?#> "
[2018-07-30T15:29:02.928 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <1> "
[2018-07-30T15:29:02.928 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] CMD: <:Gv#> "
[2018-07-30T15:29:02.930 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] RES: <N> "
[2018-07-30T15:29:02.930 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:GR#> "
[2018-07-30T15:29:07.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "Error reading RA/DEC. "
[2018-07-30T15:29:07.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] New JD is 2458330.44 "
[2018-07-30T15:29:07.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <setUTCOffset> "
[2018-07-30T15:29:07.938 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:SG +07#> "
[2018-07-30T15:29:07.945 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:SG +07#> successful. "
[2018-07-30T15:29:07.945 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:SL 15:28:26#> "
[2018-07-30T15:29:07.945 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:SL 15:28:26#> successful. "
[2018-07-30T15:29:07.945 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <setCalenderDate> "
[2018-07-30T15:29:07.945 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:SC 07/30/18#> "
[2018-07-30T15:29:17.952 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] Unable to parse response "
[2018-07-30T15:29:17.953 PDT INFO ][ org.kde.kstars.indi] - Losmandy Gemini : "[ERROR] Error setting local date. "
[2018-07-30T15:29:17.953 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <setSiteLongitude> "
[2018-07-30T15:29:17.953 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:Sg122:55#> "
[2018-07-30T15:29:17.956 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:Sg122:55#> successful. "
[2018-07-30T15:29:17.956 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] <setSiteLatitude> "
[2018-07-30T15:29:17.956 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:St+48:03:48#> "
[2018-07-30T15:29:17.956 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[SCOPE] CMD <:St+48:03:48#> successful. "
[2018-07-30T15:29:17.957 PDT INFO ][ org.kde.kstars.indi] - Losmandy Gemini : "[INFO] Site location updated to Lat 48:03:48 - Long 237:04:01 "
[2018-07-30T15:29:17.957 PDT DEBG ][ org.kde.kstars.indi] - Losmandy Gemini : "[DEBUG] Configuration successfully saved for GEOGRAPHIC_COORD. "

Read More...

Thanks! Mystery solved. Had a feeling it was something like that.

Read More...

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!