×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Recent update - 3 steps forward, 2 steps back!

  • Posts: 237
  • Thank you received: 25
I just carried out an 'update and full-upgrade' of Astroberry for my SW AZ-GTi installation, and was pleased to find that now included are KStars 3.4.4 and PHD2.6.10 (multi-star). It was the latter I was particularly keen to use, but I find that it will not connect to my mount which I use with an EQdirect cable. In the earlier version (KStars 3.4.3 and PHD2.6.9v4) the connection made to the Indi mount for guiding was labelled Indi Mount (EQMOD). This option no longer appears in the drop down list and I can no longer establish a connection from PHD2 to the Ekos. Any solutions?
Currently running KStars/Ekos/Indi on two Raspberry Pi 4Bs 4GByte under Raspberry Pi OS thanks to Astroberry
Two mounts, two Fracs, a Newt and a Mak and a couple of OSC cameras.
Last edit: 1 year 4 months ago by Avocette.
1 year 4 months ago #73685

Please Log in or Create an account to join the conversation.

  • Posts: 237
  • Thank you received: 25
Glad to read that there is a known problem with getting PHD2.6.10 to talk to Ekos that has been reported elsewhere, and Radek recommends winding back to PHD2.6dev4 (not PHD2.6dev5 which suffers the same lack of connection with Ekos).
Currently running KStars/Ekos/Indi on two Raspberry Pi 4Bs 4GByte under Raspberry Pi OS thanks to Astroberry
Two mounts, two Fracs, a Newt and a Mak and a couple of OSC cameras.
1 year 4 months ago #73820

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 13
Hi,

you could use the cmake directive -DUSE_SYSTEM_LIBINDI=1 like this :

cmake -DCMAKE_INSTALL_PREFIX=/usr/local -DCMAKE_BUILD_TYPE=Release -DOPENSOURCE_ONLY=1 -DUSE_SYSTEM_CFITSIO=1 -DUSE_SYSTEM_LIBUSB=1 -DUSE_SYSTEM_EIGEN3=1 -DUSE_SYSTEM_LIBINDI=1 ..

Make sure you have define in LDFLAGS the complet path to the libindi (ex : export LDFLAGS="-L/usr/local/lib").

I just tested, and that work fine (i only tested with indi simulator).

Kris
C8 lightbridge, Orion Atlas mount, EOS 1000D modified and ASI120MM for guiding.
The following user(s) said Thank You: Avocette
1 year 4 months ago #73831

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.205 seconds