×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

I killed gpsd somehow

  • Posts: 166
  • Thank you received: 3
Facepalm - it would appear that while all the instructions I read say to disable gpsd.socket, none say to reenable it. Maybe under different circumstances it's not needed, but it *seems* to have worked for me. 

I followed this video: 


One thing still unclear is why changing the ip from 127.0.0.1 to 0.0.0.0 in /lib/systemd/system/gpsd.socket. In my case, doesn't seem to matter.

Anyway, I put all this on the top to spare others some reading. ;)

Apologies if this is a duplicate - I thought I'd asked this last night but didn't see it listed under "My Topics"

Somehow, in troubleshooting my second Pi4 w/AB203, I have changed something on my primary Pi4 w/AB203 so that gpsd no longer comes up at boot. This is my primary Pi4 w/UART gps. It had an issue whereby it would sometimes show the wrong location, but I was told this was due to vgps running. Maybe when I disabled that I somehow disabled something else?

I have followed this page: askubuntu.com/questions/1120881/how-can-...unch-gpsd-on-startup. I had been able to manually start it, but now even that doesn't work.

BTW, the "problem" Pi4 is working fine, but it uses a USB dongle for GPS. 

What can I check? Thanks.

 
Last edit: 1 year 4 months ago by Paul Nixon. Reason: additional info
1 year 4 months ago #74111

Please Log in or Create an account to join the conversation.

  • Posts: 166
  • Thank you received: 3

Replied by Paul Nixon on topic I killed gpsd somehow

As a followup - 

I flashed a new AB203 sd card. It came up fine.

I followed the instructions here: maker.pro/raspberry-pi/tutorial/how-to-u...-with-raspberry-pi-4

When I ran sudo cgps -s, I got the wrong gps coordinates. 

I ran sudo systemctl disable virtualgps.service

Repeated the instructions above

This time, sudo cgps -s returned the correct coordinates.

Rebooted

sudo -cgps -s returns: cgps: no gpsd running or network error: -6, can't connect to host/port pair

But running: sudo gpsd /dev/serial0 -F /var/run/gpsd.sock makes it all work again - until I reboot.

What am I missing?
 
Last edit: 1 year 4 months ago by Paul Nixon. Reason: additional info
1 year 4 months ago #74124

Please Log in or Create an account to join the conversation.

  • Posts: 53
  • Thank you received: 8

Replied by Will Gauvin on topic I killed gpsd somehow

I use the gpsd.socket, you can disable it but then you must enable and start the gpsd.service to be launched all the time. The use of a .socket in systemd allows for the creation of the socket so other services or processes see that it's up but the process itself isn't running.

I did have fun trying to get gpsd to work though. This page helped: gpsd.gitlab.io/gpsd/troubleshooting.html (Check the Troubleshooting Start at Boot).
RPI 4 B (4Gb) running Manjaro ARM
Kstars/Ekos
SkyWatcher Esprit 80ED
SkyWatcher EQ6-Pro
ZWO ASI1600MM Pro
ZWO ASI290MM-Mini
ZWO EFW
PrimaLuceLab Sesto Senso 2
Pegasus UPBv2
1 year 4 months ago #74128

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.487 seconds