×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astroberry: DSLRs won't work (Astroberry on RPi4)

  • Posts: 1
  • Thank you received: 0
I'm trying to get my RPi running and am having troubles with both my DSLRs. I just don't know where to look anymore. I've completely reinstalled Astroberry and did the first
apt update && apt dist-upgrade

Is lsusb, both are present:
Bus 001 Device 017: ID 04b0:042f Nikon Corp.
Bus 001 Device 016: ID 04a9:3145 Canon, Inc. EOS 450D

Automount is off (so no cameras as drives)

Both are on manual. Both also seem to get loaded correctly in Astroberry (even though I noticed, I didn't load the Nikon drivers this time. Also tried with drivers on,but same result)


From indi_getprop, I get the following: www.codepile.net/pile/rok5VKWE

Both preview and a general capture fail, for Canon. Nikon doesn't even want to connect anymore.

I really don't know where to look next. Any help is very much appreciated.
1 year 3 months ago #76511

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
I had problems getting my Canon DSLR recognised initially. I found the instructions in the following discussion allowed me to get the connection recognised. freeklijten.nl/2011/06/04/Mounting-a-Can...hoto2#wl-comment-672

Hopefully it's useful for you to.

Alistair
11 months 1 day ago #80909

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.524 seconds