×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Internal and phd2 guider problem

  • Posts: 105
  • Thank you received: 5
Hi,
Now I got in problem once again.It's the auto guiding I don't get to work. After couples of minutes the internal guider stopped working.

First:
I tried to get the internal guider to work again. I click the Capture button, but it don't show any image, after a while I get the error message: Exposure timeout.

Second:
Then I tried the PHD2 guider, that one didn't work either. I get the error message: Failed to read image libusb_bulk_transfer() failed.I think it's the same error for both guiders.

Anyone who have some idea what's wrong ?

Include two screendumps

/Lars 

 

TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 1 week ago #78653
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 782
  • Thank you received: 66
Hi
Did you try 8 bit?
kubuntu 20.04
700d, eq6, t7m
5 months 5 days ago #78676

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 5
Hi,
Tonight I got another clear sky and can do some more test.

When I start Ekos and use the internal guider it works, but when changing to PHD2 guider I get the above problem that the camera don't connect. It's the old QHY5. When changing back to internal guider it doesn't work anymore, get timeout when starting the guide camera to take photos. I restart the Raspberry and after that it works again. It must be PHD2 that do something that mess it up.

I need the PHD2 to polar aling my mount, can't see the polar star from my balcony. Earlier Internal guider had some help with polar aligne, but never got it to work. Now with the mew Astroberry ver 2.0.4 there is no support for polar aligne.

So I need the PHD2 to working agian, last time 6 months ago there was no problem. I used an earlier version of Astroberry then. Have something changed with the ver 2.0.4 that is related to PHD2 ?

ps.
I got an info about 8-bit, where to change ?

/Lars

 
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 3 days ago #78732

Please Log in or Create an account to join the conversation.

  • Posts: 796
  • Thank you received: 373
I don't have any ideas about the camera connection issues, but you can polar align with ekos without seeing the pole star, so you don't have to use PHD2 to do this.
See this video on how to use it: 

You can start pointing to most parts of the sky. Just make sure the direction you select doesn't cause you to cross the meridian and hit your tripod.
Also, make sure the slew speed you set is pretty fast.
Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Lars
5 months 3 days ago #78735

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 5
Hi Hy,
Thanks for the video. But that option isn't implemented in the new Astroberry I installed, ver 2.04. Have a look at the xcreendumps I had in the first post, it's not there !

But I tried it in the earlier version but never got it to work, then I start using PHD2 and everything was okey until now.

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 3 days ago #78736

Please Log in or Create an account to join the conversation.

  • Posts: 796
  • Thank you received: 373
Lars,

Your screenshots show the Guide Tab. Polar Alignment is in the Align tab (the one that looks like a target / bullseye, just to the left of the Guide Tab in your screenshots). Perhaps that's why you can't find it?

Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Lars
5 months 3 days ago #78737

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 5
I took a new look at the problem.

Here is how it looks once again:

 

PHD2 connect to the camera as it should. But when I click on the looping camera button it does get the image files and give the message:

"Failed to read image libusb_bulk_transfer()"

I can't figure out what's wrong. When I google on that error message I get some answer, but not direct related to this.

It's the PHD2 ver 2.6.10dev2. As a Windows man I'm and know nothing, how do I update the PHD2 ?

I have updated Astroberry, did the PHD2 updated at the same time ?

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 2 days ago #78738
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 5
Ah... I'm so used from PHD2 to have the polar aligne in the guider function that I forgot that. Great, I see that it's also little bit different from earlier, I test it tomorrow if I have a clear sky.

Many thanks Hy !

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 2 days ago #78739

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 5
Hi Hy,
Tonight we got one more clear sky. I tested the polar align in Ekos where it use the main camera instead of the guide camera, it worked like a charm. No problem to get the polar align better than 1'.

Thanks a lot for the help !

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 2 days ago #78767

Please Log in or Create an account to join the conversation.

  • Posts: 1220
  • Thank you received: 212
Instead of using the PHD2 built-in guide camera driver, create a profile with the INDI camera driver.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
4 months 3 weeks ago #78995

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 5
Hi,
I tested that to, but still I get the error message: Failed to read image libusb_bulk_transfer() failed.

Maybe I missed some setting. But I'm satisfaid with the internal guider now. Very handsome.

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
4 months 2 weeks ago #79136

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.630 seconds