×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

16 bit historgram or how to transfer files from Raspberry to PC Windows

  • Posts: 711
  • Thank you received: 68
I noticed that something has changed with the histogram view several months ago.
I started to largely ignore the histogram and just mouse over the fits image viewer to see what the intensities are.
That's with 16bit astro camera.

Last couple of days I've been playing with a DSLR (Nikon D5500) as an imaging camera for the first time in more that a year.
Both histogram and fits viewer are totally inconsistent and wrong now (was OK a year ago I believe).
Especially when the format is set to Native (NEF in my case).
When the format is set to FITS things get better but still are a bit strange.
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
5 months 2 weeks ago #79258

Please Log in or Create an account to join the conversation.

  • Posts: 107
  • Thank you received: 5
I'm not sure if I understand, do you mean you get a histogram with Fits data, 1-65550 ? My histogram is always 0-255, Canon 6D raw, CR2 files.

How to setup Fits/Histogram to that ?

See screendump:

 

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 2 weeks ago #79267
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 711
  • Thank you received: 68
Sorry, I was confused and didn't understand what's going on...
Yes, for both FITS and NATIVE the histogram is not linear and 0-255.
With NATIVE both histogram and fits viewer are wrong
With FITS, histogram is wrong but the fits viewer shows correct intensities (14bit in my case. 0-16384).
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
5 months 2 weeks ago #79282

Please Log in or Create an account to join the conversation.

  • Posts: 107
  • Thank you received: 5
Okay, then I understand better.

I save my Canon files as Native, but temporarly they must be in fits format. So what I see in the Fitsviewer is converted native files because Fitsviewer can only display fits files, or ?

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 1 week ago #79300

Please Log in or Create an account to join the conversation.

  • Posts: 173
  • Thank you received: 20
With the caveat that I'm using StellarMate, not Astroberry, I certainly never see a 256-bit histogram. In the camera tab on the INDI Control Panel, is there an option for 8-bit vs. 16-bit images? For a long time my Pi kept defaulting to 8-bit and my images suffered terribly because of that! Dunno how the CR2 and FITS work together but the FITS off my ASI183, a 14-bit camera, are always 16-bit.
5 months 1 week ago #79305

Please Log in or Create an account to join the conversation.

  • Posts: 711
  • Thank you received: 68
With a dedicated astro-camera there's no problem with histogram/fits viewer.
With a DSLR there is a problem.
When it is set to NATIVE (at least in my case with D5500 and NEF format), the histogram is 8-bit and stretched all the way and is the same for say 1 sec and 10 sec exposure. Fits viewer also shows wrong intensities I believe.
When it is set to FITS things do get better. Fits viewer shows right intensities but the histogram sometimes is wrong. Sometimes it is OK.
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
iOptron CEM40G
5 months 1 week ago #79308

Please Log in or Create an account to join the conversation.

  • Posts: 107
  • Thank you received: 5
Maybe something that Ekos put into the FITS header when it transform the raw file temporarly to FITS. Something that mekae FITS Viewer to handle it different.

I haven't find any setting for 8/16 bit either for FITS Viewer.

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
5 months 1 week ago #79314

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.219 seconds