×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Solved! GUI in PHD2 shows glitches after update from 2.6.9 to 2.6.11

  • Posts: 25
  • Thank you received: 1
Hi, after updating my entire astroberry, I have UI glitches on PHD2. The -/+ buttons on the graph window of PHD2 are only partially visible (red circles in the attachment "screenshot-new") and also the background color shows black background where some text is displayed (red arrow) . While the background color is a nuisance, the barely visible + button is quite annoying. Also, the old version 2.6.9 showed +/- above one another (see "screenshot-old"), the new version has them next to each other, wasting valuable space (in particular on small screens).Any help on what is going on and what I could do is appreciated.
cheers
Stephan

Solved! I had to rebuild phd2 from source. By doing so, the GTK3 wxWidgets were properly installed. I have learned, that PHD2 is using GTK3 now, and those widgets were (apparently) not available when the included binary of PHD2 was built.
Rebuilding from source solved the issue by installing the appropriate dependencies (I believe libwxgtk3.0-gtk3-dev did the trick) .

For reference, I followed the outlined process:

## Step 1: Build Dependencies ##
### Debian-based systems (Ubuntu, Raspbian, ...) ###
* Install dependencies (tested on Ubuntu 14.04 to 20.04 and tested on Raspbian Buster)
```
sudo apt-get install build-essential git cmake pkg-config libwxgtk3.0-gtk3-dev \
wx-common wx3.0-i18n libindi-dev libnova-dev gettext zlib1g-dev libx11-dev \
libcurl4-gnutls-dev

```
## Step 2: Build PHD2 ##
* Get the PHD2 sources
```
git clone github.com/OpenPHDGuiding/phd2.git
cd phd2

```
* Generate the Makefiles
```
mkdir -p tmp
cd tmp
cmake ..

```
* Build PHD2
```
make
```
Once PHD2 is built, you can either run PHD2 from the local build directory
```
./phd2
```

or install PHD2 onto the system

```
sudo make install
```
Last edit: 4 months 1 week ago by Stephan. Reason: Added the solution
4 months 1 week ago #84547
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
Hi Stephen,

I have the same glitch, but when I try to install the dependencies you have kindly noted, it says can’t find files/location.

Do you know if anything has changed regards this?

Cheers

Mark
1 week 6 days ago #88314

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.197 seconds