×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

kstars config fails looking for newer version of ECM

  • Posts: 98
  • Thank you received: 3
I got a compile error for kstars today:
CMake Error at CMakeLists.txt:70 (find_package):
  Could not find a configuration file for package "ECM" that is compatible
  with requested version "5.68.0".
 
  The following configuration files were considered but not accepted:
 
    /usr/share/ECM/cmake/ECMConfig.cmake, version: 5.54.0
 

This is after doing a
apt update && sudo apt upgrade && sudo apt dist-upgrade

Jamie
2 months 1 week ago #86685

Please Log in or Create an account to join the conversation.

  • Posts: 98
  • Thank you received: 3
OK -- so I installed the latest from the git repo, and now I get this:
CMake Error at CMakeLists.txt:108 (find_package):
  Could not find a configuration file for package "Qt5" that is compatible
  with requested version "5.12.8".
 
  The following configuration files were considered but not accepted:
 
    /usr/lib/arm-linux-gnueabihf/cmake/Qt5/Qt5Config.cmake, version: 5.11.3

Looks like an extensive update is coming to astroberry. Any way to easily get these latest packages? A ppa perhaps?
2 months 1 week ago #86688

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.192 seconds