×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Astroberry Server

  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

Let me clarify this. NTP service is autostarted on Astroberry Server with -g option. According to NTPD manual:
-g     Normally, ntpd exits with a message to the system log if the offset exceeds the panic threshold, which is 1000 s by default.  This option allows the time to be set to any value without restriction; however,  this can happen only once.  If the threshold is exceeded after that, ntpd will exit with a message to the system log.

There is a NTPD helper called ntpdate, which can reset initial offset to a reasonable value. However I don't use it in Astroberry Server. The reason is ntpdate is considered obsolete by ubuntu team and for some unknown reason NTPD is treated as secondary choice solution for time syncing. All modern ubuntu releases use timedatectl and time-sync. This disables NTPD by default. Astroberry Server is built to use not only GPS NMEA location and time data but also PPS signal. As the result Astroberry Server uses NTPD instead timedatectl and time-sync. PPS does not provide full time data, but sets precise beginning of each second specified by NMEA. This way you can hit clock precision in nanoseconds. If you don't need this level of accuracy you can revert to timedatectl and time-sync. This will overrule autostarting NTPD but will also remove any offset constraints related to NTPD. Just run "sudo systemctl enable prefer-timesyncd.service" and reboot.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You: dragonlost
Last edit: 2 years 1 month ago by Kaczorek.
2 years 1 month ago #17504
The topic has been locked.
  • Posts: 60
  • Thank you received: 2

Replied by dragonlost on topic Astroberry Server

Thank you for this explanation I understand better now.

Thanks for the python script GPSTime that works very well with my raspberry!

I begin to understand better how the time setting in astroberry.

I added to my raspberry on Ubunutu Mate 16.04 a NEMA USB GPS recently. I have owned this installation for some time (since more than 2 years) and I would like to add an automatic time setting to startup as on Astroberry-server.

Could you explain to me how to activate this as you did with astroberry-server?
2 years 1 month ago #17518
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

Hi Radek,

As previously suggested, I downloaded the astroberry server image file, and it is just perfect for people like myself, with only very basic Ubuntu or programming skills. For sure, it is all looking very nice, very well thought-through and using is extremely convenient. Thank you for also making programs like oaCapture available, which I was also struggling / failing to install on my Raspberry - now it is all just there!

If I may ask, the original Astroberry driver "rpi-focuser" are you planning to include, or have I overlooked? I found the piface version in the drop down menu, when assigning the drivers to the devices applied (in Ekos), only.

Best, Helge
2 years 1 month ago #17540
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

HelgeMK wrote: Hi Radek,If I may ask, the original Astroberry driver "rpi-focuser" are you planning to include, or have I overlooked? I found the piface version in the drop down menu, when assigning the drivers to the devices applied (in Ekos), only.


I'm glad you find Astroberry Server useful. Original astroberry drivers are not included. I will add them to the distribution on the next release.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
2 years 1 month ago #17549
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

Hi Radek,

I am not sure how I managed to get here: I tried to establish wlan01 network connection amending the NetworkManager.conf file, by setting "managed" = true (not sure if that made sense - but how can I use WLAN connection, Ethernet works ok). Following restart, nothing worked, unable to reboot. So I reinstalled everything again, flashing the SD card with a new astroberry image. However, I lost the nice GUI, back to standard Ubuntu Mate, without ability to access the menu bar. After hours of trying to recover, would be great if you could give me a hint, where I got it wrong.

Best, Helge
2 years 1 month ago #17552
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

I'm not sure what you have really done. There's no need to touch NetworkManager.conf file at all to use Astroberry Server network connection. As soon as you start your raspberry pi with flashed microSD card everything works out of the box. If your customize too much I'm not really able to help you out. The image is prepared for easy flashing and using without any need for custom tuning and tweaking. If you got to some unstable state after customizing your system I can only advise to reflash and use it without unnecessary changes.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You: HelgeMK
2 years 1 month ago #17553
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

Hi Radek,

Eventually, I managed to recover the astroberry server. Reflashing the sd card required a thorough reformatting (I used SD formatted) to make effective, took quite a while to get back on track.

Still not clear to me how I can access my network "wirelessly" (Ethernet works fine). I set up the wifi connection under the menu "network connection", but then how can I access/activate? When I click on the network-icon at the panel, the option wlan-configuration comes up, I enter the password, then supposed to type the network name - but cannot activate the field, can only enter the password.

On the PiFace digital 2 with the stepper 28byj48 (unipolar) I connected as follows, applying piface focuser 2 - and it works!!

Orange to Output 7
Pink to Output 6
Yellow to Output 5
Blue to Output 4
Red to 5V

Best, Helge
Last edit: 2 years 1 month ago by HelgeMK.
2 years 1 month ago #17573
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

HelgeMK wrote: Still not clear to me how I can access my network "wirelessly" (Ethernet works fine). I set up the wifi connection under the menu "network connection", but then how can I access/activate? When I click on the network-icon at the panel, the option wlan-configuration comes up, I enter the password, then supposed to type the network name - but cannot activate the field, can only enter the password.


That's a great news that astroberry piface driver works well with Piface Digital 2!
Regarding wireless connection to Astroberry Server. As stated in the readme file Astroberry Server is also a Virtual Access Point (VAP) allowing to access the system without external wireless network. This means that Astroberry Server creates new wireless network (access point / hot spot) which you can connect to with your PC or mobile device. Just search for a wireless network named "astroberry" on your PC. Connect to it and then open your browser and go to astroberry.local or 192.168.10.1.
What wlan configuration does is connecting your Astroberry Server to your home wireless network so you can access the Internet from the raspberry (for updates, online astrometry etc.). It scans for available wireless networks so you can select your home network you want to connect to. If there's no networks on the list and you are sure that the list shouldn't be empty you can configure your home network connection from terminal by running "sudo wlanconf".
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You: HelgeMK, tkottary
2 years 1 month ago #17581
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

Brilliant, connected to WLAN via terminal, as suggested.

Have already been using VAP - it is great, do all the things via laptop, no more need to occupy the Raspberry's USB ports with mouse & keyboard...
2 years 1 month ago #17584
The topic has been locked.
  • Posts: 353
  • Karma: 2
  • Thank you received: 25

Replied by maudy on topic Astroberry Server

Kaczorek wrote: Version 1.0.4 of Astroberry Server is available! No need to download full system image. Just run astroberry-update and then astroberry-upgrade.

...

NOTE: You should not upgrade if you customized your system. In such case you need to wait for the next full release.


Hi,

I thought this was answered before and could not find it, sorry if I am asking for you to repeat.

What are considered "if you customized your system"?

- extra apps?
- time zones?
- users?
- passwords?
- wifi SD?

Thank you
2 years 1 month ago #17596
The topic has been locked.
  • Posts: 40
  • Thank you received: 7

Replied by Psamathe on topic Astroberry Server

Excellent idea. Downloaded and tried and a few issues I found (meant I could not stick with it)

Seems to be some monitor issue. Using TV connected to HDMI port. The startup/console texts are assuming a wider display i.e. left part of text is off left edge of screen and once start-up complete the GUI display area is larger than the display screen (i.e. top of display is off top of screen and left truncated off left edge - like a need a bigger display screen). If I load a new Ubuntu Mate installation on the same hardware all is fine display wise (i.e. it's an Astroberry issue rather than an Ubuntu Mate issue); also same hardware works fine with Raspbian. If I struggle with the mouse off-screen I can see the bottom parts of the menu and can get into Preferences/Displays and see that it has an "unrecognised monitor" and I can't change any of the settings; detect displays does nothing.

Related to the display, quality is bad. Lots of ghosting. Something Ubuntu Mate new install does not seem to suffer from (I guess it's down to the monitor again)

Unable to get client Wi-Fi to work. WLAN configuration seems to have no option to enter a network name (just a square'ish blank box, no input control, and just asks for a network password and entering any of the passwords just rejects (i.e. astroberry - rejected, network password - rejected). Tried creating a client network on wlan0 and had to ifconfig wlan0 up to get anything but could not get a connection going (used wlan0 as it looked like hostapd was on wlan1).

If you need more details, do ask (though I've re-loaded Ubuntu Mate onto my SD card to progress with that one for the moment).
2 years 1 month ago #17603
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

maudy wrote: What are considered "if you customized your system"?

- extra apps?
- time zones?
- users?
- passwords?
- wifi SD?


Most of these are just configuration changes so you should be fine with upgrading your system with astroberry-upgrade. Adding new apps is also safe, removing existing ones might introduce errors at upgrade. I'm not sure what you mean by 'wifi SD' but reconfiguring wifi is fine anyway.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
2 years 1 month ago #17623
The topic has been locked.
Moderators: Kaczorek
Time to create page: 0.914 seconds