×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Cannot Connect to Astroberry VAP

  • Posts: 12
  • Thank you received: 0
I thought I generated a post for this last night, but for some reason it didn't get posted so I'll give it another shot...

I want to use my tablet to control my Raspberry Pi 4 running Astroberry. It seems like the easiest way to achieve this is to connect the tablet to the Astroberry VAP network, but I cannot get it to work so I'm hoping someone can help me out.

My RPI4 is running the Astroberry server image and I can see the "astroberry" Wi-Fi network from my tablet (Samsung Galaxy Tab S2) and my cell phone (Samsung Galaxy S9), but neither can connect. In both cases, they display, "Authenticating...", then "Connecting...", then it fails. After a few seconds, it shows "Connecting...", fails again, and repeats this cycle forever. I know the password is being entered correctly because if I enter a bogus password, it fails the authentication step and generates an error stating that the password is invalid.

Does anyone know what's wrong?
1 year 9 months ago #47631

Please Log in or Create an account to join the conversation.

  • Posts: 966
  • Thank you received: 367
Make sure you are using HTTPS for accessing the system. If not you need use only 8 characters of the password (astrober) - it is real VNC limitation.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
1 year 9 months ago #47694

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
The failure occurs when trying to connect to the VAP Wi-Fi network. I'm not even getting to the point where I can use VNC.
1 year 9 months ago #47701

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
When trying to connect my phone or tablet to the astroberry VAP, I enter the default password of "astroberry" and the Android devices will authenticate the password, then cycle between these two states forever (see JPGs).
1 year 9 months ago #47705
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 3
Is the WIFI password 'astroberry' or 'astroberry)' ?
RPi 4B (4gb) running Stellarmate OS
Skywatcher Quattro 250 with f4 coma corrector
Skywatcher Evostar 80ED with 0.85 reducer/flattener
Skywatcher AZ-EQ6,
ASI1600MM Pro with ZWO 8x1.25" EFW,
Guide scope 50x190mm, Guide camera ASI290MM
ZWO EAF focuser
1 year 9 months ago #47706

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
It's just "astroberry". I know I have the right password because I get an authentication error if I enter anything else.
1 year 9 months ago #47707

Please Log in or Create an account to join the conversation.

  • Posts: 966
  • Thank you received: 367
Have you tried using other devices (PC, laptop)?
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
1 year 9 months ago #47726

Please Log in or Create an account to join the conversation.

  • Posts: 407
  • Thank you received: 74
It sounds like a security protocol issue - WPA etc - being out of date with latest wpa/wpa2 spec. Although I do not have a Samsung Tab this sort of behaviour occurs on other kit - i,e, can see network ,password correct but fails to connect. Alternatively it could be your browser!

So

1. Try www.samsung.com/au/support/mobile-device...ect-to-wifi-network/

2. If (1) fails to solve the problem try switching off security WPA etc altogether and see if that connects ok.

3. if (3) fails try connecting RPI4 to your local WiFi network as client then Web Browser from Samsung Tab S2

Good Luck
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
1 year 9 months ago #47732

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
OK, I was able to connect to the VAP using my PC and my iPad, but it still fails with both of my Android devices (Tab S2 and S9). I suppose I could use my iPad in the field, but I'd really prefer to use my tablet as it has a larger and higher resolution display.

Last Friday, I reset my cell phone to factory defaults and went through the painful process of reloading and reconfiguring all the apps. That didn't help. I've used my cell phone and tablet in literally dozens of different locations all around the world and never had a problem connecting either of them to Wi-Fi, so this really has me perplexed.
1 year 9 months ago #47740

Please Log in or Create an account to join the conversation.

  • Posts: 966
  • Thank you received: 367
Raspberry Pi 4 is very new hardware, the same for raspbian operating system. You can probably play with Hot Spot configuration so it matches your devices' needs.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
1 year 9 months ago #47745

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
I'm not sure what you mean by that. I'm fairly sure this isn't a hardware issue since my PC (Windows) and my iPad (iOS) can both connect to the astroberry VAP. But neither of my Android devices can even though they have never had a problem connecting to any other Wi-Fi network (and there have been dozens of them). That smacks of a software or configuration issue with the astroberry implementation. I just don't know where to even begin looking.
1 year 9 months ago #47746

Please Log in or Create an account to join the conversation.

  • Posts: 966
  • Thank you received: 367
The way WiFi and BT work on Raspberry Pi is dependent on the chipset that Raspberry Foundation has chosen and firmware they provide with Raspbian system. There can be bugs in either of these components, including drop of WiFi transfer rates if you use 4K resolution over HDMI.
What you can do is to play with configuration of the Astroberry Hot Spot so maybe you can find the way your android devices connect with the hot spot (BTW, I use google pixel with vanilla android system and have no issues with connecting to it).
Righ-click WiFi icon on your top taskbar and select Edit Connections, then double-click Astroberry Hot Spot - you can play with settings on Wi-Fi (band, channel) and/or Wi-Fi Security tabs. Note that you should make changes while connected to screen and keyboard. Otherwise you can loose you connection.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
1 year 9 months ago #47747

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.242 seconds