×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Cannot Connect to Astroberry VAP

  • Posts: 12
  • Thank you received: 0
Thanks for the advice. Interestingly, after disabling security it connects immediately. But if I enable any type of security (WEP or WPA), it fails to connect. I suppose I could run with it open but I'm not very comfortable with that since I plan to start using an astronomy site that will have a lot of other people nearby who are also going to be using telescopes and astrophotography rigs - it wouldn't be very good if someone connected (either accidentally or on purpose) and messed with my RPI.

So the problem is definitely related to Wi-Fi security and Android, I just don't know how to sort that out.
4 years 4 months ago #47749

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
I run into the same problem. I cannot join the WiFi from my Samsung Note 8. My windows PC and an old Asus Android tablet can connect, but that Asus tablet have such an old Android version that I cannot install Kstars Lite on it.
4 years 2 months ago #50756

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 3
Hi All,

I have the same issue with my Galaxy S9 +
My Iphone, iPad Air, Sony Xperia X3 and my Oneplus connect without any Problem. It seams to be related to Samsung.

CS
Reiner
4 years 2 months ago #50773

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
> It seams to be related to Samsung.

Agreed, but I wouldn't go so far as to say that it's a Samsung issue since all of my Samsung devices (and I have several of them) have no problem connecting to any other Wi-Fi access point - just the Astroberry software.
4 years 2 months ago #50774

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
I've found this:
raspberrypi.stackexchange.com/questions/...o-raspi-access-point

According to that it is a problem in the WPA Supplicant code on the RPI.
4 years 2 months ago #50778

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
But is there a fix? I read through that entire string and only understand about 1/3 of it.
4 years 2 months ago #50798

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
In the last answer it says compiling wpa suplicant V2.9 from source helped.
So I'm afraid no easy solution here.
4 years 2 months ago #50815

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
I just don't know how to build a new Astroberry image with the v2.9 supplicant. It's odd that the folks who manage Astroberry haven't done this already. Samsung devices are very popular and the Wi-Fi hotspot needs to work with those devices.
4 years 2 months ago #50822

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420
Astroberry depends on the Raspbian Buster Linux distribution and it is that distribution that determines the versions of the software available on it. It is far from easy to update any core software on a distribution since there are a LOT of dependencies that need to be satisfied.
Note that connecting with a mobile phone to the wifi of a Raspberry Pi is not a very common thing to do so from that persopective it makes sense that this latest version isn't available in Raspbian yet.
4 years 2 months ago #50825

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
That's why I've said that no easy solution.
Note, that Astroberry is just a package over the Raspbian distribution, and wpa supplicant is part of Raspbian, not Astroberry.
The best we can hope that Raspbian will be upgraded soon.
4 years 2 months ago #50832

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375

Official Raspbian Buster system from Raspberry Foundation (see www.raspberrypi.org/downloads/raspbian/) provides wpa_supplicant version 2.7. This means that the issue impacts all Raspberry Pi users who use official system, not just Astroberry users.
Astroberry is built on top of Raspbian Buster so we are impacted as well. The only solution is to manually upgrade version of wpa_supplicant to the latest 2.9.
However version 2.9 is marked unstable/experimental so it is not available in stable repositories yet. It must be compiled from sources located on the official site w1.fi/releases/wpa_supplicant-2.9.tar.gz

This will take some time wpa_supplicant is promoted to stable. As soon as it is you will receive it with regular updates and the issue will be solved for you and all the other users.

In the meantime, can anybody compile and package version 2.9 from the sources?
4 years 2 months ago #50889

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12

Rendering Error in layout Message/Item: array_keys(): Argument #1 ($array) must be of type array, null given. Please enable debug mode for more information.

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.653 seconds