×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Cannot Connect to Astroberry VAP

  • Posts: 12
  • Thank you received: 0
OK, I was able to connect to the VAP using my PC and my iPad, but it still fails with both of my Android devices (Tab S2 and S9). I suppose I could use my iPad in the field, but I'd really prefer to use my tablet as it has a larger and higher resolution display.

Last Friday, I reset my cell phone to factory defaults and went through the painful process of reloading and reconfiguring all the apps. That didn't help. I've used my cell phone and tablet in literally dozens of different locations all around the world and never had a problem connecting either of them to Wi-Fi, so this really has me perplexed.
2 years 11 months ago #47740

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
Raspberry Pi 4 is very new hardware, the same for raspbian operating system. You can probably play with Hot Spot configuration so it matches your devices' needs.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 11 months ago #47745

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
I'm not sure what you mean by that. I'm fairly sure this isn't a hardware issue since my PC (Windows) and my iPad (iOS) can both connect to the astroberry VAP. But neither of my Android devices can even though they have never had a problem connecting to any other Wi-Fi network (and there have been dozens of them). That smacks of a software or configuration issue with the astroberry implementation. I just don't know where to even begin looking.
2 years 11 months ago #47746

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
The way WiFi and BT work on Raspberry Pi is dependent on the chipset that Raspberry Foundation has chosen and firmware they provide with Raspbian system. There can be bugs in either of these components, including drop of WiFi transfer rates if you use 4K resolution over HDMI.
What you can do is to play with configuration of the Astroberry Hot Spot so maybe you can find the way your android devices connect with the hot spot (BTW, I use google pixel with vanilla android system and have no issues with connecting to it).
Righ-click WiFi icon on your top taskbar and select Edit Connections, then double-click Astroberry Hot Spot - you can play with settings on Wi-Fi (band, channel) and/or Wi-Fi Security tabs. Note that you should make changes while connected to screen and keyboard. Otherwise you can loose you connection.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 11 months ago #47747

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
Thanks for the advice. Interestingly, after disabling security it connects immediately. But if I enable any type of security (WEP or WPA), it fails to connect. I suppose I could run with it open but I'm not very comfortable with that since I plan to start using an astronomy site that will have a lot of other people nearby who are also going to be using telescopes and astrophotography rigs - it wouldn't be very good if someone connected (either accidentally or on purpose) and messed with my RPI.

So the problem is definitely related to Wi-Fi security and Android, I just don't know how to sort that out.
2 years 11 months ago #47749

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
I run into the same problem. I cannot join the WiFi from my Samsung Note 8. My windows PC and an old Asus Android tablet can connect, but that Asus tablet have such an old Android version that I cannot install Kstars Lite on it.
2 years 8 months ago #50756

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 3
Hi All,

I have the same issue with my Galaxy S9 +
My Iphone, iPad Air, Sony Xperia X3 and my Oneplus connect without any Problem. It seams to be related to Samsung.

CS
Reiner
2 years 8 months ago #50773

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
> It seams to be related to Samsung.

Agreed, but I wouldn't go so far as to say that it's a Samsung issue since all of my Samsung devices (and I have several of them) have no problem connecting to any other Wi-Fi access point - just the Astroberry software.
2 years 8 months ago #50774

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
I've found this:
raspberrypi.stackexchange.com/questions/...o-raspi-access-point

According to that it is a problem in the WPA Supplicant code on the RPI.
2 years 8 months ago #50778

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
But is there a fix? I read through that entire string and only understand about 1/3 of it.
2 years 8 months ago #50798

Please Log in or Create an account to join the conversation.

  • Posts: 90
  • Thank you received: 12
In the last answer it says compiling wpa suplicant V2.9 from source helped.
So I'm afraid no easy solution here.
2 years 8 months ago #50815

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
I just don't know how to build a new Astroberry image with the v2.9 supplicant. It's odd that the folks who manage Astroberry haven't done this already. Samsung devices are very popular and the Wi-Fi hotspot needs to work with those devices.
2 years 8 months ago #50822

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.818 seconds