×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Astoberry and the SkyWatcher AZ-GTi is awkward!

4 weeks 9 hours ago
jeffry7
Fresh Boarder
Fresh Boarder
Posts: 4
More
Topic Author
Astoberry and the SkyWatcher AZ-GTi is awkward! #48751
Hi folks!

I sat down last night to get a Raspberry Pi 3 running Astroberry to talk to my AZ-GTi. This was all indoors as I am still trying to figure out things.

I finally managed to get them to talk. I had to connect to Astroberry from my computer on Ethernet so I could set the WiFi to the GTi hotspot.

After that I had to wrangle the EQMOD settings, which require knowing the IP address of the GTi. In hotspot mode this is always 192.168.4.1, which is one reason to use hotspot mode.

After that, things went pretty well. But I can't imagine doing this outside, or worse in the field somewhere. Part of the reason to use the PI was so I didn't have to lug a computer along, but you need a computer to change settings in the PI. (I would like to use KStars Lite on my tablet.)

I figure I am doing this wrong. Or there is an easier way. How do you usually set up a Skywatcher AZ-GTi with Astroberry?

Thanks!

Please Log in or Create an account to join the conversation.

4 weeks 4 hours ago
maxthebuilder
Gold Boarder
Gold Boarder
Posts: 294
More
Astoberry and the SkyWatcher AZ-GTi is awkward! #48759
Hello,
See my instructions here: www.indilib.org/forum/mounts/3482-skywat...-ekos.html?start=144

Basically, first you connect your phone/tablet to SynScan wifi. Set SynScan to auto-connect to Astroberry/Stellarmate hotspot.
Hopefully, SynScan will be connected to Astroberry/Stellarmate. IP will be 192.168.4.1 but you don't need that.
Kill SynScan.

Now connect your phone/tablet to Astroberry/Stellarmate wifi.
Open SynScan. Connect and note the IP! This IP is the one you need.

HTH

jeffry7 wrote: Hi folks!

I sat down last night to get a Raspberry Pi 3 running Astroberry to talk to my AZ-GTi. This was all indoors as I am still trying to figure out things.

I finally managed to get them to talk. I had to connect to Astroberry from my computer on Ethernet so I could set the WiFi to the GTi hotspot.

After that I had to wrangle the EQMOD settings, which require knowing the IP address of the GTi. In hotspot mode this is always 192.168.4.1, which is one reason to use hotspot mode.

After that, things went pretty well. But I can't imagine doing this outside, or worse in the field somewhere. Part of the reason to use the PI was so I didn't have to lug a computer along, but you need a computer to change settings in the PI. (I would like to use KStars Lite on my tablet.)

I figure I am doing this wrong. Or there is an easier way. How do you usually set up a Skywatcher AZ-GTi with Astroberry?

Thanks!


Max S.
RPI 3 B+ and RPI 4 B (4Gb) with Stellarmate OS.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8.
AT72EDII refractor. ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi mount in EQ mode.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

3 weeks 2 days ago 3 weeks 2 days ago by astromyr. Reason: Correcting f value of spacecat
astromyr
Fresh Boarder
Fresh Boarder
Posts: 9
More
Astoberry and the SkyWatcher AZ-GTi is awkward! #49023
Hi,
I run Astroberry on a RPi4 with AZ-GTi, ASI294mc for imaging, and asi120mm mini for guiding. I leave everything outside and connect to the RPI4 from Kstars on Windows indoors. Works very well!
The RPI4 wifi doesn't have the longest reach (as the AZ-GTi). Also, I have issues with the AZ-GTi outside due to the massive amount of wifi routers nearby.
So I ended up using a EQDIR cable (made one from a FTDI 3.3V uart cable) from the RPi to the AZ-GTi. Rosck solid. I also run Ethernet cable from the RPi to the windows computer or the house Wifi accesspoint.

I'm not using the synscan app anymore, except for configuring the Wifi.
I polar align with the ekos polar alignment tool, and then pick about 3 points around in the sky, that ekos plate solves and syncs. To gotos get pretty good from that.

If you connect by wifi, you can do this a number of ways:
1) Connect the RPi, AZ-GTi, and synscan app device/computer to your house access point.
2) Connect the AZ-GTi and synscan app device/computer to your RPi
3) Connect the synscan app device/computer and RPi to the AZ-GTi accespoint.

You can create a prioritized list of wifi configurations in the astroberry so it will connect to the house wifi first, connect to the AZ-GTi second, or create an accespoint third, if the two other fails.

I love this rig! I'm up and imaging in 25 minutes including polar alignment. I guess part of the success is that I'm using a 250 mm f4.9 spacecat for imaging, thus it's fairly forgiving about accuracy :-)

Please Log in or Create an account to join the conversation.

2 days 13 hours ago
majormojo
Fresh Boarder
Fresh Boarder
Posts: 3
More
Astoberry and the SkyWatcher AZ-GTi is awkward! #50122
I'm trying something similar, I use astroberry as the hotspot and then use the SynScan app to configure the AZ-GTi to connect to that network. The thing is, I have to reconfigure this every time the mount starts up - it doesn't remember the previous setting. This means the steps for every use are:

1. power up the mount
2. change phone to SynScan_xxxx network
3. open SynScan app and connect to mount
4. change mount wifi settings (and they only "stick" about 1 in 5 tries so, I have to keep repeating the process till it works)
5. close the app
6. switch the phone back to the other network
7. re-open SynScan app and connect to mount
8. continue with setup in app or alignment with ekos

And if step 7 fails because the mount hasn't connected to the astroberry network, which it does often, then go back to step 2 and start over. Is this the same for others? Doesn't it seem reasonable that the mount should remember the last used network settings and fall back to its own network only if that fails?

At least once it does attach to the astroberry network, it gets the same IP each time so I don't have to reconfigure EQMOD driver each time.

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 0.526 seconds