×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astroberry Server 2.0.1 is available now!

  • Posts: 154
  • Thank you received: 22
Yes, I cannot connect to my QHY163M anymore. just in the last update, it worked fine before.

-Sonny
The following user(s) said Thank You: Tom
2 years 7 months ago #49636

Please Log in or Create an account to join the conversation.

  • Posts: 238
  • Thank you received: 15

So confirmed QHYCCD now having issue with Raspbian OS. :(

Jasem found out Fxload in debian is very old. So, he updated the fxload on his SM OS 1.5.0 and qhyccd works now. Maybe he does other things as well, we do not know.

Thanks.
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
The following user(s) said Thank You: Sonny Cavazos
2 years 7 months ago #49637

Please Log in or Create an account to join the conversation.

  • Posts: 154
  • Thank you received: 22
Thank you.

SM is stellarmate I assume. and Yes QHY works on SM, but not on astroberry.
2 years 7 months ago #49647

Please Log in or Create an account to join the conversation.

  • Posts: 238
  • Thank you received: 15
Yes. SM is Stellarmate. Not only that, AstroPi3 script also having this issue as well. Meaning that update from the github also faile to bring qhy camera up.
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
2 years 7 months ago #49648

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
It is related to last update of libqhy... Please downgrade the library by running:
wget https://www.astroberry.io/repo/pool/main/libq/libqhy/libqhy_6.0.5-2_armhf.deb
sudo dpkg -i libqhy_6.0.5-2_armhf.deb
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
The following user(s) said Thank You: AstroNerd, Sonny Cavazos
2 years 7 months ago #49686

Please Log in or Create an account to join the conversation.

  • Posts: 154
  • Thank you received: 22
Thanks, that works great!
2 years 7 months ago #49695

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
For all QHY users. You can safely update your system. The latest QHY drivers work without problem now.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
The following user(s) said Thank You: Giles
2 years 6 months ago #50104

Please Log in or Create an account to join the conversation.

  • Posts: 344
  • Thank you received: 68

I think this breaks oacapture, even for non-QHY users though.
__
I blog my progress: www.coochey.net
2 years 6 months ago #50105

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
Yes, it is. New version of oacapture will be released soon.
If you need to use it right away, this is a workaround:
sudo ln -s /usr/lib/arm-linux-gnueabihf/libqhyccd.so /usr/lib/arm-linux-gnueabihf/libqhyccd.so.6
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
The following user(s) said Thank You: Giles
2 years 6 months ago #50108

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 3
I just did apt update now and after reboot INDI won't start. The syslog is full of the following failures:
systemd[1]: Started INDI Web Manager.
indi-web[2689]: Traceback (most recent call last):
indi-web[2689]:   File "/usr/local/bin/indi-web", line 10, in <module>
indi-web[2689]:     sys.exit(main())
indi-web[2689]:   File "/usr/local/lib/python3.7/dist-packages/indiweb/main.py", line 315, in main
indi-web[2689]:     start_profile(profile['name'])
indi-web[2689]:   File "/usr/local/lib/python3.7/dist-packages/indiweb/main.py", line 99, in start_profile
indi-web[2689]:     indi_server.start(info['port'], all_drivers)
indi-web[2689]:   File "/usr/local/lib/python3.7/dist-packages/indiweb/indi_server.py", line 74, in start
indi-web[2689]:     self.start_driver(driver)
indi-web[2689]:   File "/usr/local/lib/python3.7/dist-packages/indiweb/indi_server.py", line 37, in start_driver
indi-web[2689]:     cmd = 'start %s' % driver.binary
indi-web[2689]: AttributeError: 'NoneType' object has no attribute 'binary'
systemd[1]: indiwebmanager.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: indiwebmanager.service: Failed with result 'exit-code'.
indiwebmanager.log contains repeated failures
WARNING: terminating indiserver failed code 1
2 years 5 months ago #51340

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 3
Oh, it looks like the problematic update was indi-astroberry-diy 2.5. The indi web manager wasn't able to change the profile, but after I manually removed the "Astroberry Board" driver from .indi/profiles.db, everything seems to work again.
2 years 5 months ago #51341

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 1
Hello !.
I'm trying to connect my QHY367C to an astroberry.

Astroberry server 2.0.1 just installed on RPI 3B+
I have made an upgrade (apt-get upgrade). Always the same error with Ekos: "No QHY camera connected. Power on ? "
My QHY367C is well powered and connected with the original cable to the RPI (The camera is new, never used).
Is it normal? Have you an idea ?
Thank you !
Regards,
Jonathan
2 years 5 months ago #51369

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.064 seconds