×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Help - Unable to connect Zwo ASI 1600MM

  • Posts: 46
  • Thank you received: 1
Hi,

This is my first post on this forum and I hope you can help[ me.

I'm new to RPI and Astroberry but I am trying to get everything set up so I can once again automate my telescope and imaging rig.

My new Raspberry PI 4 arrived today and I have been trying to set it up all day using mainly the beginners guide by Ian(X6gas) over on Stargazers Lounge.

I have managed to get the Astroberry software onto my Micro SD card and I loaded this into the RPI4 and turned it on. I am trying to set everything up without a monitor, keyboard or mouse using my laptop. When I turned the RPI 4 on I was able to find the Astroberry hotspot and when I signed into this I got the following which I hope is correct.



I then went to the start-up page and connected to Astroberry. Once on Astroberry I went to set up my wireless internet connection. I entered my SSID details and password and once I had done this I was asked to re-boot the RPI. I re-booted the RPI as requested and this is where my troubles began.

It appears as if my RPI/software is crashing. It does not reload Astroberry, the network settings don't show on my computer, hotspot and wireless connection missing and I cannot get the software to work. I end up having to re-format the micros SD card and and start again.

I've tried about 5 times and have now given up or I'll end up kicking the RPI across the room :(. I've ordered a HDMI cable and I'm going to give it a go using a monitor, keyboard, mouse etc when it arrives which will take about a week due to the lockdown. If this doesn't work I don't know what I'll do, this has been a terrible first day.

Can anyone offer me any advice or direct me to any videos/detailed instructions on what I need to do when I first turn on my RPI, locate the hotspot and go into Astroberry as everything I've tried to do following the instructions as best I could has not worked.

I have a basic understanding of computers and software but I've never used a RPI , I am good at following instructions and learning.

Thanks

Doug
2 years 7 months ago #52463
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 346
  • Thank you received: 69

Replied by Giles on topic Help - New to Astoberry

Your case is interesting, because you've explained everything reasonably well, and yet you are encountering this issue.

The HDMI cable will certainly help, as it will show you why the Pi is not rebooting with your Wifi enabled. But if you cannot wait for its arrival, and you have a Cat5 or Cat6 ethernet cable available, it might be worth connecting that and trying to get stable connectivity going with that and then trying to get the Wireless working.

This may allow you to keep connectivity to the Pi when the problem happens.

If you can't do this, then you might still be able to mount the SD card on another computer and peruse the logs in /var/log to get an indication of what might be going wrong after your reboot.
__
I blog my progress: www.coochey.net
2 years 7 months ago #52508

Please Log in or Create an account to join the conversation.

  • Posts: 384
  • Thank you received: 115

Replied by Doug S on topic Help - New to Astoberry

You might want to read this post that deals with RF interference between Pi4 (specifically USB3) and wireless using 2.4Ghz: www.indilib.org/forum/general/6576-pi4-u...erference.html#50509. The first response about using an ethernet cable is good advice to begin eliminating potential sources. A second thing to make sure of is that your power supply is good enough. Pi4 takes more power than Pi3 for sure. You shouldn't try to use the USB3 ports on the Pi4 (they require 2x power delivery that the Pi really doesn't have to give). A first good test is to only use your USB2 ports. If the Pi4 is stable, it means the OS installation you did is likely fine, and it's HW that's not stable. Once you eliminate power and USB3 / 2.4Ghz wireless as sources of problems, you'll be on to 2nd order effects. Good luck....
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
Last edit: 2 years 7 months ago by Doug S.
2 years 7 months ago #52522

Please Log in or Create an account to join the conversation.

  • Posts: 346
  • Thank you received: 69

Replied by Giles on topic Help - New to Astoberry

Might also add, as I don't know whether this is installed automatically with the image or not, but in any case, for the Pi4 you'll want to install the rpi-eeprom package as ensure that your Pi is completely updated (requires Internet access, so an ethernet cable is again, probably a must to start with):

$ sudo apt update
$ sudo apt upgrade
$ sudo apt install rpi-eeprom
$ sudo rpi-eeprom-update

The EEPROM updates fix several power consumption and heat issues with the Pi4, and I would expect there will be quite a few software updates to the Raspbian base of Astroberry since the image, which might resolve your issues.

rpi-eeprom-update runs at boot, but requires Internet access to check whether a new EEPROM image has been released, so if that isn't present you won't be updating.

If this resolve or helps to resolve your Wireless issues then subsequently you'll be able to get new updates over your WiFi Internet.
__
I blog my progress: www.coochey.net
2 years 7 months ago #52550

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 137

Replied by AstroNerd on topic Help - New to Astoberry

I am a little confused...
So when you are logged Onto the Astroberry via the hotspot as shown above, then you can access the unit, so why do you need to add more wifi details, you don’t need too as you are using the hotspot, but if you then change from the hotspot so the pi connects to your home Wi-Fi, then you make sure your PC is connected to that same Wi-Fi.... ??
I don’t see your problem...
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 7 months ago #52556

Please Log in or Create an account to join the conversation.

  • Posts: 346
  • Thank you received: 69

Replied by Giles on topic Help - New to Astoberry


I was assuming that after setting his Astroberry to connect to his Wifi Network and rebooting the Astroberry Pi was crashing or, at least, not joining his Wifi Network.
__
I blog my progress: www.coochey.net
2 years 7 months ago #52558

Please Log in or Create an account to join the conversation.

  • Posts: 46
  • Thank you received: 1
Hi,

Thanks for all the replies most of which I understand.

From a power point of view everything I'm using is official RPI.

I have read about the wireless using 2.4ghz but their is nothing I can do to my router to alter this, my router is a BT home hub 2 and you cannot split the 2.4ghz from the 5ghz.

I may be going about this the wrong way, as stated this is a steep learning curve for me and I'm stupid :).

What I am trying to achieve is to be able to operate my telescope mount and hopefully all the imaging equipment from my laptop whilst I am sat in my house with the telescope etc at the bottom of my garden. My idea was to set up my RPI 4 with Astroberry and have this in a weatherproof box at my mount. On my mount I have a powered USB 3.0 hub and I was going to run one USB 3.0 cable back to the RPI4 and then run a Cat 6 cable from the RPI back to may laptop in the house. I could then sit in my house and control everything. This is what a I currently do using a 5m active USB 3.0 cable but the new distance is 20+ metres is the reason I thought using an RPI and Cat 6 cable would work.

The problems I am having is that the RPI4 hotspot does not appear to be stable, I have so far tried 3 times this morning to power up my RPI4 and to get it to show the Astroberry hotspot without success, other times it will show up straight away. Once I've got into the RPI 4 using the hotspot it was my intention to set up the wireless internet so it can connect to my home internet and then I can get updates as the hotspot does not have internet access. I enter all the information - Country Code - GB, then my SSID and Password and when I click OK it states I must re-boot. I then hit the re-boot button and instead of re-booting as I would expect like windows does, it appears to turn itself off and then I'm unable to get back into Astroberry as the hotspot has disappeared and the wireless internet does not work. I then end up having to re-format my SD card so I can connect to try again.

If I get the RPI running on the Astroberry hotspot and this is at the bottom of my garden how do I control it via an ethernet cable, if I plug the ethernet cable into the RPI 4 and my laptop, nothing happens, I'm sure I need to set it up correctly and if I'm not mistaken this will mean finding port details etc and networking them together.

I'm going to have to do some more reading / research into this so I can try and understand it all a bit better.

Thanks again for all the replies.

Doug
2 years 7 months ago #52561

Please Log in or Create an account to join the conversation.

  • Posts: 346
  • Thank you received: 69

Replied by Giles on topic Help - New to Astoberry

OK. Let us focus on the Ethernet side of things.

In order for hosts to communicate over the Ethernet they both need to have IP addresses and be on the same network or subnet.

By default the way of obtaining the IP address on the Raspberry Pi is via a process called DHCP.

In your basic home network, the BT hub is usually the DHCP server, and it leases correct IP address information on your network to other hosts.

The best way to get everything working would be to run the Ethernet cable from the Raspberry Pi to the the BT hub (it should have a number of LAN ethernet ports at the back). You can then access the Pi from your Laptop while both will have Internet access at the same time.

I fear what you might say to us now is that the Ethernet cable you have will not reach to your BT hub....

Fear not - you can set both your laptop and the Pi to have a static IP address, settings like the following:

Pi IP Address 10.0.0.1
Pi Subnet Mask 255.255.255.0
Laptop IP Address 10.0.0.2
Laptop Subnet Mask 255.255.255.0

If your laptop is going to be connected to your Wifi so you can browse the Internet while operating the Telescope then don't set a Default Gateway on either device.

After setting those values up, you should be able to access astroberry via the Ethernet cable via http://10.0.0.1 and you should be able to ssh into the Pi from your laptop to inspect other settings (For ssh use something like Putty if you are using Windows on the laptop).
__
I blog my progress: www.coochey.net
2 years 7 months ago #52563

Please Log in or Create an account to join the conversation.

  • Posts: 384
  • Thank you received: 115

Replied by Doug S on topic Help - New to Astoberry

As an alternative, you can run an ethernet cable directly from PI to your PC. I run this way and it works fine. I use the "view network connections" and share the PC's internet connection (assumes you're using a window's PC). You will need to assign an IP address on the PI that can be seen by the PC's local shared network.

I still recommend you start by avoiding using the USB3 ports (temporarily). Plug your USB3 cable from the HUB into one of the USB2 ports on the PI. This will allow the hotspot to function reliably so you can configure the system as you want it (while you learn how to share your internet connection from the PC). It will be slower, but it should function. You'll have a working unit until you get the ethernet address assigned and internet shared.... FYI, I progressed along the same path. I didn't have a choice to go 5 Ghz. It all will work.....just need the patience to work through the config stuff. Once you no longer need to burn SD cards to constantly recover, it will go faster/easier.
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
2 years 7 months ago #52566

Please Log in or Create an account to join the conversation.

  • Posts: 46
  • Thank you received: 1
Hi,

Thanks again for the detailed replies.

I've just got my 20m Cat 6 ethernet cable and have plugged it into the back of my router and then I plugged the other end into my RPI and started it up. The red light came on as did the green light, the green light flashed on and off a number of times as usual and then I ended up with just the solid red light.

On checking the network connections I saw my normal wireless network and the Astroberry hotspot.




I then clicked on the Astroberry secured network and once connected I went to 10.42.0.1 and clicked connect and inserted my password and this took me to the Astroberry site and I was able to do an internet search so this would appear to be working correctly. Whilst doing this from my laptop it would appear that I still have my normal internet wireless connection.



Can you please confirm that I have done this correctly so I can move on to learning something new.

Thanks

Doug
Last edit: 2 years 7 months ago by Douglas Mason.
2 years 7 months ago #52578
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 46
  • Thank you received: 1
Hi,

I think I may be having a slightly better day today.

Having got access to the internet I decided to have a go at doing the updates as recommended by gilescp.

I started what appears to be the PI update as per the below image.






This then finished and it appears to me that it did what it was meant to do, could someone please check that the update has been done properly.





I then ran the eeprom install and update, this appear to be installed and up to date, please see below.








Having done this, can you please confirm that you need to check for updates manually as I have just done today using 'sudo apt update', sudo apt install'. Is it also recommended to check for updates and install them for the eeprom.

Thanks for all the help.

Doug
Last edit: 2 years 7 months ago by Douglas Mason.
2 years 7 months ago #52580
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 346
  • Thank you received: 69

Replied by Giles on topic Help - New to Astoberry

Sorry, been away a bit, just upgraded my system to Ubuntu 20.04, and having trouble with my Google Chrome and all the passwords I have saved in it... really need to clean up my online accounts...

All in all it looks like there were quite a few updates, and you do have something working.

For the rpi-eeprom stuff, that is done, and it will only need to kick in should there be a new update appear on the EEPROM git site.

If you have the ethernet connected to the BT Hub, and this is good for you on a permanent basis I would leave it at that, the Ethernet cable is always going to be faster and more reliable than a Wireless connection.

In order to keep your system up to date, you should just have to:

sudo apt update
sudo apt upgrade

There is also "sudo apt full-upgrade" and "sudo apt dist-upgrade" not sure exactly what the difference is, but sometimes updates appear that only get installed when you run those.

It only needs to be relatively up to date, sometimes too many changes and you get yourself in a situation where you are updating even when things are working, and then something breaks...

If you don't want to permanently use the wired connection (despite it almost certainly being faster and more reliable), then at least you are now in a position to tinker around and try to get the Wireless side up and running, but having the wired side to fall back on will hopefully mean that you don't need to re-flash your SD card if you take a wrong turn.

Good luck.
__
I blog my progress: www.coochey.net
The following user(s) said Thank You: Douglas Mason
2 years 7 months ago #52581

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.774 seconds