×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astroberry - purge and reinstall KStars and INDI

  • Posts: 21
  • Thank you received: 0
I'm trying to replace the kstars and INDI versions that come with Astroberry 2.0.1 with the stable build of Jasem, which contains update of 4 QHY related files (as you may notice I have been struggling to fix the QHY cameras USB connection problems):

launchpad.net/~mutlaqja/+archive/ubuntu/...5&memo=150&start=150
indi-qhy 2.6~202004201859~ubuntu18.04.1 Jasem Mutlaq (2020-04-20)
indi-qhy 2.6~202004201859~ubuntu16.04.1 Jasem Mutlaq (2020-04-20)
indi-qhy 2.6~202004201858~ubuntu20.04.1 Jasem Mutlaq (2020-04-20)
indi-qhy 2.6~202004201857~ubuntu19.10.1 Jasem Mutlaq (2020-04-20)

I executed the following commands but it seems both kstars and indi are not affected after the "purge" commands, I can still open them up. Any Linux guru know what the problem is?

sudo aptitude purge indi-bin libindi-data libindi1 libindidriver1
sudo aptitude purge kstars kstars-data

sudo apt-add-repository ppa:mutlaqja/ppa
sudo aptitude update

sudo aptitude install indi-full kstars-bleeding

baheyeldin.com/astronomy/installing-late...ary-ubuntu-1604.html
2 years 7 months ago #52484

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
To supplement, no error returned after each command. The "add-repository" command took 3 seconds to complete, the rest basically took no time, seems nothing actually happened.
Last edit: 2 years 7 months ago by Sundewaholic.
2 years 7 months ago #52485

Please Log in or Create an account to join the conversation.

  • Posts: 85
  • Thank you received: 18
Hmm, 'aptitude' isn't even installed in the image of 2.0.1 that I have running.

I've always used 'apt-get' instead so you could try 'apt-get' everywhere you've got 'aptitude' above.
2 years 7 months ago #52528

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
Thanks Aurneth. I did a bit of research to understand aptitude and apt-get... its true that aptitude doesn't come with the 2.0.1.

I executed the following revised commands but again, nothing happened. Kstars and INDI server can still be run! Any clue?

sudo apt-get purge indi-bin libindi-data libindi1 libindidriver1
sudo apt-get purge kstars kstars-data
sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt-get update
sudo apt-get install indi-full kstars-bleeding
Last edit: 2 years 7 months ago by Sundewaholic.
2 years 7 months ago #52577

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
It's not gonna work or it can bring lots of problems to your system.
ppa:mutlaqja/ppa reporitory is for Ubuntu whereas Astroberry is based on Raspbian (official raspberry pi system from raspberry foundation). That's why it has it's own repository
Astroberry provides official drivers compiled from the same sources so there should be no difference in how QHY driver works on Ubuntu and Raspbian. What is the problem that you are facing?
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 7 months ago #52589

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
Thanks for your reply Kaczorek. I thought astroberry is based on Ubuntu mate, would you please share me a link saying it is based on Raspbian?

The problems are related USB connections to QHY cameras, I can’t get all connected to Kstars/ INDI at the same time (qhy168c, qhy5l-ii-m, polemaster)
2 years 7 months ago #52649

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
The following 2 links said it runs on Raspbian Buster Desktop
github.com/rkaczorek/astroberry-server/blob/master/README.md
www.astroberry.io/

But this link said its on Ubuntu Mate 16.04 Desktop
indilib.org/devices/rasbperry-pi/astroberry-server.html

I'm confuse!


Are they actually the same?
2 years 7 months ago #52659

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
I guess it is a typo in the indi website as the changelog in github does said it is based on Raspbian Buster Desktop
indilib.org/devices/rasbperry-pi/astroberry-server.html

github.com/rkaczorek/astroberry-server/blob/master/Changelog
Last edit: 2 years 7 months ago by Sundewaholic.
2 years 7 months ago #52660

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
Version 2.0 is build on top of Raspbian Buster. Version 1.0 used to be based on Ubuntu Mate.

BTW. INDI website description at indilib.org/devices/rasbperry-pi/astroberry-server.html has been updated. Thanks for catching this! I forgot to update it after launching Astroberry version 2.0 ;-)
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 7 months ago #52667

Please Log in or Create an account to join the conversation.

  • Posts: 85
  • Thank you received: 18
A little off-topic, but it might be useful to include the following instructions on flashing from
github.com/rkaczorek/astroberry-server#how-to-start

at both
indilib.org/devices/rasbperry-pi/astroberry-server.html
and
www.astroberry.io/

I knew how to flash, but the bytesize I needed to get from your github page, so might as well just include it on the download pages.
The following user(s) said Thank You: Radek Kaczorek
2 years 7 months ago #52671

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
Ah, I'm quite new to astroberry/ raspberry, didn't know you are the author of astroberry, and thanks for the info!

The problem I have is that I never be able to connect all my 3 QHY cameras (QHY168C, QHY5L-ii-m and PoleMaster) in Astroberry's Ekos/ Indi, could be related to the USB connections or the drivers (or something else!). I'm advised to try purging KStars and INDI and install the code from Jasem Mutlaq in Launchpad, perhaps the advisor uses Ubuntu Mate, I'm not sure, but it seems to be working in his case.

I think I have slightly further narrowed down the problem I have. I reinstalled astroberry (the 5th times, and without the polemaster installed), PHD2 seems work fine with QHY5-ii-m, but whenever I start running the Kstars and INDI server, PHD2 can't get any more frames from QHY5L-ii-m, the screen stuck. Is the QHY168C tried to compete with the USB port numbers?

See screen dump for the dmesg when I start the KStars/ INDI server . How often the INDI libs are updated for the astroberry (Raspbian) version? Jasem does have 4 updated QHY libs files, not sure what they are used for but when someone like me really struggling with the problem for quite a period I don't really mind to replace astroberry with Ubuntu Mate. What's your advice?

2 years 7 months ago #52726
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
Of course PHD2 can't get any more frames from QHY5L-ii-m after you start Ekos!
As you see on INDI panel this camera is shown as INDI device, whereas it is already used by PHD2. So there is a conflict between INDI and PHD2 both trying to access the same device. I guess it is the same case for Polemaster.
You can solve this by:
1) make sure that only main camera is selected in your Ekos profile (guiding cam should be left empty!)
2) select PH2 as an external guider in Ekos profile and select proper guiding camera in PHD2 profile
3) start KStars / Ekos first and if guiding camera is detected by INDI and connected - disconnect it before running PHD2 (same for polemaster)
4) run PHD2
5) enjoy!

In summary, make sure that other cameras ARE NOT connected (and locked) as INDI devices before accessing them from PHD2, Polemaster, FIrecapture, Oacapture... you name it.

PS. QHY provided by Astroberry use the latest QHY SDK / libs
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 7 months ago #52730

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.894 seconds