×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astroberry - purge and reinstall KStars and INDI

  • Posts: 21
  • Thank you received: 0
Thanks Kaczorek, following your guidelines the connections work now. It was really a frustration as I thought the problem was due to a combination of various problems - USB3.0 / 2.4G wifi interference, QHY5L-ii-m driver bugs/ not up to date, etc.. those sort of things that need some complicated Linux configurations to fix it, and it seems many people has similar experience, lucky me my problem can be fixed as it is due to wrong profile configuration/ connection sequence only.

Ref to your guidelines, here are the exact steps that made my equipment work (mostly):

0) Plug in the main camera (QHY168C) and guide camera (QHY5L-ii-m) only to the pi, USB 2.0 or 3.0 or via a USB hub doesn't really matter! Unplug the QHY PoleMaster.
1) Open Ekos, set the Guiding field as PHD2 and Guider field as "BLANK" in the profile.
2) Start INDI server.
3) Disconnect the guide camera (QHY5L-ii-m) in the INDI Control Panel.
4) Open PHD2, set Camera as QHY Camera.
5) In the KStars guide module, click the "Connect" button.
6) Open a terminal, start PoleMaster (sudo PoleMaster).
7) Happy days? Not yet - GetQHYCCDSingleFrame error (-1)

Sorry I have the below questions also, appreciate you can let me know too:

- Following your guidelines, everything can be connected, so I tried to test the main camera by taking an exposure (the camera icon - Capture a Preview), but I get this error -> GetQHYCCDSingleFrame, re the screen shot, any clue about it?
- I've also come across some instruction that we can set the Guilder field as the guide camera (QHY CCD) in the Ekos profile, and in the PHD2, select "INDI camera"... once started PHD2 it will connect to the guide camera. I've also tried this configurations, it did attempt to connect but failed at the end. Any reason this is not suggested/ not working?

Last edit: 2 years 7 months ago by Sundewaholic.
2 years 7 months ago #52780
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 983
  • Thank you received: 375
I'm glad there is some progress on your side.
Regarding your questions...
1) Please try the main camera capture without connecting other cameras. Also make sure that you select proper camera i Ekos CCD tab when other cameras are connected.
2) You can go both ways i.e. connecting camera as INDI driver and use INDI CCD in PHD2 or connect camera directly in PHD2. The former should work, but it's not that effective because INDI is engaged in capturing and transferring images to PHD2, which in turn communicates with KStars/Ekos with guiding corrections. This approach makes sense for cameras that are not supported by PHD2 but are supported by INDI. Otherwise use direct PHD2 connection.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 7 months ago #52789

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0

Thanks Kzczorek.
I can capture images and store them in the target directory, but once I execute my step 3) "Disconnect the guide camera (QHY5L-ii-m) in the INDI Control Panel.", which is essential for letting PHD2 to have the guide cam, it also disconnected the image transfer of the main camera. Re the screen dump below, clicking the "Yes" seems can't enable the image transfer. No preview showed on screen and no image are stored in the target directory.
I have also tried to disconnect and connect the main camera to see if the image transfer has returned back to normal, unfortunately not! Any idea, many thanks!

Last edit: 2 years 7 months ago by Sundewaholic.
2 years 7 months ago #52824
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.397 seconds