×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astroberry 2.0.1 Hotspot vs Win10 - connection problem

  • Posts: 46
  • Thank you received: 1
Hi,

I'm no expert having only recently set up my RPI4 with a lot of help from here and SGL.

I had a similar issue when I was setting up and was unable to connect to the hotspot from my Win10 Laptop.

It was then explained to me that their is a hierarchy with regards to the internet ( Ethernet - Wireless - Hotspot ).

So once set up if a wireless network is detected then this will be used before a hotspot.

From your description it would appear that you've set up the wireless connection and your RPI is picking this up which is why you cannot connect to the hotspot.

Turn off the wifi on your laptop and then go to the RPI and the hotspot should show up on the laptop in the network connections and you should be able to connect to it however I'd always use the wireless wifi if you can.

I'm sure this is right, but I could ge wrong as it's all new to me

Doug

P.s. I've not been able to sort out the GPS location yet
Last edit: 2 years 6 months ago by Douglas Mason.
2 years 6 months ago #53702

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Thanks Doug,

The problem was similar as you advised, but a bit more complicated... :)

I am almost certain it is due to wifi repeater "Comfast CF-WR302S V2.0" I use to make wifi signal more stable in my backgarden.
Without the extender, I still have quite strong signal from the main Router, but it is not stable, sometimes it becomes very weak for no reason.
and I guess, sometimes Laptop connects to the main router, but rPi to the repeater, - they both have the same SSID name, but for some reason are treated as different networks :(
I am not sure how to fix it....
So if I switch off the repeater, - I have no problem.

However, in my case I mostly have:
1) The wifi repeater on;
2) Initially I am connected to the rPi hotspot (for my tests);
3) Once done, at the end I command astroberry to turn off the Hotspot;
4) I presume, it should Look for the wifi on the Connection list and connect to it if it is available;
5) I guess, it connects to the repeater (or main router sometimes);
And from here problems start
6) if my win10 is not on the same device connection, I obviously do not know about it, I try and fail to connect to rPi using noVNC option.
And at this point Win10 adds up more confusion
7) Win10 usually still shows Asrtoberry Hotsport on the "wifi list" and obviously I try to connect back to it and Win10 fails.
Not sure what are Win10 wifi list re-fresh timings, but I think it is around 2-3 minutes or so....

Solutions I see:
1) Set up the repeater to work properly... - not sure how to do it... would be nice to get advice... but this one is very simple, it has no options as I recall..
2) get another repeater.... Question: which one will do the job properly????
3) Cat6 cable???? - not and option as I went rPi way to reduce the amount of the cables.
4) Get the main router closer to the backgarden? - sadly no option for that also :(
5) Else? VNC??? - will need more tests as it was very slow/laggy initially and I am not sure why.... (p.s. I previously used VNC to control win10 laptop left outside for imaging without any lag issues and on the same network).
6) else?


Observation:
Once I am logged via rPI hotspot (without any internet connection), - I do see the time and date is wrong, it shows the one from last session as rPi has no internal battery to keep clock ticking...
do you guys all use
sudo date --set='2020-05-12 20:51:03'
Or maybe there is another way?


P.S.
Warsaw...
During the initial set up, - we have to add our own location details, - why not to use that out of the box?
Last edit: 2 years 6 months ago by Roland.Kol.
2 years 6 months ago #53720

Please Log in or Create an account to join the conversation.

  • Posts: 407
  • Thank you received: 74
"So if I switch off the repeater, - I have no problem". - Answered your own question really !
You didn't say which Wireless freq you are using 2.4 or 5ghz but if the Comfast is 2.4gz it will be suspecible to quite common interference (BT broadband provides lots as they use your home device to give a boost their WiFi availability) - even from your Home Wireless Router which as you say is stable but weak. 5ghz is,at the moment and due to shorter range of 5ghz,better/faster

I suspect the Comfast is 2.4ghz and you dont say how you are using it - has 3 modes of working i beieve !

Doug is correct the Astroberry set up allows for a priority for Wireless connections ( I will ignore wired) so as long as you give the HOTSPOT a lower priority than the Comfast the Comfast should connect first - so long as there are no problems. There is no point in having the HOTSPOT running at home when you have a strong Wireless signal its just Radek has tried (and succeded) it making this as painless as possible so if you do go "into the field" the Hotspot will be there automatically.

I am led to believe that the Comfast can act in "Repeater MODE" where the Comfast can connect by wire to the RPI but repeats (i.e. increases the signal strength) your home WiFi repeat signal as its "beam" is stronger than the PI and overlaps your Home Router WiFi beam. You could try this as an experiement to see if your problems go away.

BUT note if the strength of the Home Router WiFi signal varies this could also be causing the Comfast to loose its connection to the Home Router WiFi - which has a knock on effect.

The other alternative would be to run a wire connection to the Comfast and position this nearer to where ever you PI is located.

Alternatively you will have to play with Wifi Channels to see if 2.4ghz interference is the problem - which I suspect it is. Wireless Channels are also most likely the reason for your change in Signal strength with regards to you Home Router problems.

Also do not put the Comfast too close (3-5m min) to the PI as this can also give rise to problems !

As for the date thingy - yes I have used that method when no Internet is present - your alternative is to get an GPS or Realtime add on.

If you get a GPS to solve the time problem then the location problem disappears.

Myaybe in a future enhancement it will ask for your default location on first load until then follow the instructions on the Astroberry NEW web site - very fancy @RADEK LOL-
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
The following user(s) said Thank You: Roland.Kol
2 years 6 months ago #53723

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Thanks a lot Stash,

And yes, that Comfast is 2.4ghz only, and yes my Virgin Media router had auto-channel management switched ON initially, which I have turned off some time ago, however, signal is not reliable in the back-garden anyway, - router is simply way too far...
I am even amazed I can catch a signal without a repeater at all.
Will have to think how to extend the 5ghz signal probably...

As per GPS,
I do have VK172 G-MOUSE USB GPS/GLONASS USB GPS Receiver (the cheap one from ebay).
Which I failed to use on Win10 ....
not sure it will have any use on rPi...
Last edit: 2 years 6 months ago by Roland.Kol.
2 years 6 months ago #53731

Please Log in or Create an account to join the conversation.

  • Posts: 407
  • Thank you received: 74
I have used one these with Astroberry/indi www.ebay.co.uk/i/114068740729?chn=ps - there is a good Astroberry thread on the subject :-)
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
The following user(s) said Thank You: Roland.Kol
2 years 6 months ago #53735

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
2 years 6 months ago #53775

Please Log in or Create an account to join the conversation.

  • Posts: 407
  • Thank you received: 74
The device I use is refered too by Ublox (mine is a Ublox 7 - quite old but works) - plugs into USB port.

Should just plug and go LOL

However here are some pointers when using Astroberry

1. VirtualGPS needs to be disabled (think its still applies - and I just tried it - it worked - see screen prints) github.com/rkaczorek/astroberry-server/issues/47

2. I find that sometimes it does not work on boot but unplugging and pluiing in the Ublox 7 makes it work - but be patient GPS fix takes time and it doesn't work indoors - so next to a window and wait if testing.
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
Last edit: 2 years 6 months ago by Clive Stachon.
2 years 6 months ago #53839
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Thanks a lot,
I have not managed to find any info about the virtual PGS initially, however, my tests show the same results (without and without Virtual GPS disabled) as per printscreen in the attachment.

I do receive some kind of data stream via gpsmon... but no actual fix, and cgps -s does not show any data movement at all (kStars also)...
Maybe my back-garden is like a <em><strong>bomb shelter</strong></em> and I need to get that usb stick somewhere higher.... not sure yet...

I had to make steps listed below to get that, - before, I had no response on gpsmon at all... cgps -s waa the same, just the seconds ticking waiting for any data..
steps:
1) got USB port of the GPS device by: ls /dev (checked the list without the device and with device plugged In). result: /dev/ttyACM0
2) amended /etc/default/gpsd to: DEVICES="/dev/ttyACM0"
3) sudo systemctl stop gpsd.socket
4) sudo systemctl disable gpsd.socket
5) sudo gpsd /dev/ttyACM0 -F /var/run/gpsd.sock
reboot

once On, - some data is coming in via gpsmon.... not sure what it means at all

Last edit: 2 years 6 months ago by Roland.Kol.
2 years 6 months ago #53847
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1117
  • Thank you received: 182
I don't use Hotspot mode at home. It makes little sense to me. I also use an extender, but on the 5 GHz band, not 2.4 GHz. The latter is just too slow for VNC control.
Have the Pi4 connect to the extender only by giving the extender its own fixed IP address and a different name from your main router. Then set up the Pi so it connects to the extender, not the home network. Your Pi4 will still be on your home network, but routed through the extender now exclusively. You may have to raise the priority level of the extender in the network manager on the Pi4, I moved mine to 100 while keeping the main router network at 0. That way, the Pi will always prefer the extender over the home router. But when the extender is off, the Pi4 will still connect to my home network inside the house for maintenance.
I also use VNC. Although the Pi4 is about 15 m away from the extender, I get pretty high transfer rates which make for almost no lagginess.
Jo
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You: Roland.Kol
2 years 6 months ago #53863

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0

Agree, - unless you want to test the system before you pack out to the fields...

And thanks a lot for the static IP suggestion, as I actually had the similar issue, my rPI did not want to connect to DeVolo (Powerline - wifi extender) which was placed quite close, - rPi connection was always declined, - will test your suggestions. Thanks a lot again.
2 years 6 months ago #53868

Please Log in or Create an account to join the conversation.

  • Posts: 407
  • Thank you received: 74
Why did you change the GPSD files ? - if you are using Astroberry there is no need and the device you used is "standard" for GPS USB devices - just the virtualgps needs stopping as per the instructions .

Plus after the reboot did you unplug and replug in the GPS - as there are Udev rules which allow for "hot plugging the GPS device" which seem to wake up GPSD.

If the device didn't work on Windows (my did after installing all the software and drivers - a pain) then how do we know the device works at all - does the green light(?) flash ?

Before Astroberry I simply used an Zeo as a Network source for GPSD that worked everytime - not sure I still have the instructions but if I remember it was from the Internet just cant remember where and I have cleared out my browser history.

In the end you can of course just input the date ,time and location manually - its normally needed once per night / locations and its works everytime :-)

The alternative is to use a phone with inbuilt GPS and connect Kstars GPS module to that www.indilib.org/devices/auxiliary/gps-nmea.html
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
2 years 6 months ago #53873

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Thanks again,

Will try all that from scratch...

And why did I changed GPSD at all?
All of them I did before you wrote me :( as initially it was not working at all, gpsmon was simply empty, - now it shows something (at least!) :) and all these steps I wrote, were offered on Indi for astroberry or other sites for rPi.

P.S.
On windows, I was able to get data coming via its own software, but was not able to link it to EQMOD or SGP.

Anyway, - nice to know it should work almost out of the box
Last edit: 2 years 6 months ago by Roland.Kol.
2 years 6 months ago #53874

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.622 seconds