×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

How Update Kstars on Astroberry RPi4

  • Posts: 388
  • Thank you received: 15
Hello,

Yes. These two repositories were what I add. The Raspbian was specifically for BIOS and Firmware. I noticed several needed updating before Raspbian and AstroBerry were at peace with each other.
1 year 5 months ago #66183

Please Log in or Create an account to join the conversation.

  • Posts: 87
  • Thank you received: 9
do you have the name of the raspbian repository I have to add? Sorry, but I'm more familiar with opensuse ;-)
1 year 5 months ago #66184

Please Log in or Create an account to join the conversation.

  • Posts: 87
  • Thank you received: 9
those repos are in astroberry anyway:
1 year 5 months ago #66185
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 69
  • Thank you received: 5
Running kstars 3.5.2 on my RPi4 with Raspbian Buster.

Tried upgrading to the latest version Kstars3.5.3 and compiled the source tarball. Compiled OK but there is no Ekos tab on the menubar. So had to resort back to 3.5.2.

Anyone got 3.5.3 working on RPi
David
RPi4 4GB mem running Raspbian (PiOS), Indi/Kstars
Skywatcher AZ-EQ6, Esprit 100ED, Celestron HD925, ZWO1600MM, ZWO EFW,
Last edit: 1 year 1 month ago by David Thompson. Reason: Typo
1 year 1 month ago #71221

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 39
Any news about 3.5.3 on Astroberry?

Thanks ;)
Last edit: 1 year 1 month ago by Rafa Barberá. Reason: Politeness :)
1 year 1 month ago #71270

Please Log in or Create an account to join the conversation.

  • Posts: 981
  • Thank you received: 374
Coming soon ;-)
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
The following user(s) said Thank You: Rafa Barberá, Jon_G, Jordi Sesé, Osvaldo Paez
1 year 1 month ago #71277

Please Log in or Create an account to join the conversation.

  • Posts: 683
  • Thank you received: 82
Great! Still waiting for 3.5.3. Any news on a date yet?

Thanks!

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
Last edit: 1 year 3 weeks ago by Peter Kennett.
1 year 4 weeks ago #71751

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 3
I'm in a bit of a pickle. 

I just read on CN that Kstars 3.5.3 has "real time" vectoring for polar alignment - very exciting. So, I fired up my Astroberry Pi4 and attempted to sudo apt-get update && apt-get upgrade. Unfortunately, I can't seem to remember the root password! 

Forget for a moment I read moments ago here that 3.5.3 has not yet been released for Astroberry, am I SOL on the password? Do I have to do a complete reinstall? I'm currently connected via VNC, if that matters.

Thanks.

Well, well, well - it turns out there apparently was no root password set. I used sudo passwd root and was able to fix things. Wow, I am shocked I didn't set this already.
 
Last edit: 1 year 4 weeks ago by Paul Nixon. Reason: additional info
1 year 4 weeks ago #71755

Please Log in or Create an account to join the conversation.

  • Posts: 683
  • Thank you received: 82
astroberry

iOptron CEM120 EC2 and CEM25P
Celestron C11 EdgeHD
William Optics Star71
ASI 1600Mm Pro, ASI 462MC
Moonlight motorfocus & Esatto focuser
LodeStar X2 and ZWO OAG
DewBuster
NANO PC-T4
1 year 4 weeks ago #71757

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 3
Thanks for the reply, but it turns out there was no root password. Sudo passwd root took care of it.

Hmm...not so fast. I just tried to do an update using sudo and got this-

sudo apt-get update && apt-get upgrade
Hit:1 archive.raspberrypi.org/debian buster InRelease
Get:2 raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]      
Hit:4 www.astroberry.io/repo buster InRelease                          
Hit:3 vega.ap-i.net/apt unstable InRelease
Fetched 15.0 kB in 3s (5,002 B/s)
Reading package lists... Done
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

I am rusty.
Last edit: 1 year 4 weeks ago by Paul Nixon.
1 year 4 weeks ago #71760

Please Log in or Create an account to join the conversation.

  • Posts: 110
  • Thank you received: 17
Run two separate commands. Mine does not like using the && either.
The following user(s) said Thank You: Paul Nixon
1 year 4 weeks ago #71761

Please Log in or Create an account to join the conversation.

  • Posts: 158
  • Thank you received: 3
I did use two commands and it got a lot further/did much more, but it still failed (too many errors).

Unfortunately, it appears my Pi has locked up.

Hard reboot (power cycle) but it doesn't come up. I get a solid red LED, and the green LED flashes 4 times.

I think my installation is fubar. Argh...
1 year 4 weeks ago #71763

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.227 seconds