×

INDI Library v2.0.6 is Released (02 Feb 2024)

Bi-monthly release with minor bug fixes and improvements

GPS switches to Warsaw every other second

  • Posts: 11
  • Thank you received: 0
I am experiencing very odd behavior after configuring my Adafruit Ultimate GPS HAT for Raspberry Pi.

After editing /etc/default/gpsd to disable "USBAUTO" and correct the device to "/Dev/ttyS0" I get very odd behavior when running gpsmon.

gpsmon shows the correct location, but then switches to a location in Poland and alternates back to the correct location every second.

Any idea what's causing this?

When I do a "sudo killall gpsd" it corrects itself and only shows my current location.

However when I remove the service with a "systemctl disable gpsd" and reboot, I don't get the correct location (I get something like /tmp/gps something)

I think there is a script somewhere telling gpsd to default to Poland, but I can't find it. It's not in the /etc/default/gpsd or in /etc/rc.local

Any idea what's going on?

Also, how do I get the system time to update to the correct gps time?

Thanks!
3 years 5 months ago #59555

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 41
Hi

Make sure that you have disabled virtual GPS service by running
sudo systemctl stop virtualgps && systemctl disable virtualgps
in your terminal just in case it is trying to pull data from two sources.

Mike
3 years 5 months ago #59560

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
That was it, thanks!
3 years 5 months ago #59583

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.738 seconds