×
INDI Library v1.8.8 Released (09 Jan 2021)

Here are the changes from v1.8.7 to v1.8.8

HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0)

3 years 11 months ago 3 years 11 months ago by maudy.
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #13997
Hello:

How can the ASIGetExpStatus failed be resolved on RPI3 using Ekos?

I have been using Ekos successfully with a Canon T6i, on my RPI3. It does not matter if the indiserver is running remote on RPI3 - 127.0.0.1 - or local.

Running local though, the ASI1600 hub does not allow the ASI EFW to be found. Running remote, the ASI EFW is found.

Now using a new ASI1600MM-C v3 I am unable to get a single frame, whether it is a preview or scheduled.

Debug is turned on the ASI1600 and an excerpt is of the log follows.


Excerpt:

INFO 5.202128 sec : Session log file /home/pi/.indi/logs/2017-01-21/indi_asi_ccd/indi_asi_ccd_22:18:$
INFO 5.202262 sec : Upload settings set to client only.
DEBUG 5.202442 sec : Requested CCD Frame is ( 0, 0) (4656 x 3520)
DEBUG 5.202492 sec : UpdateCCDFrame ASISetROIFormat (4656x3520, bin 1, type 0)
DEBUG 5.255528 sec : Setting frame buffer size to 16389120 bytes.
DEBUG 5.255730 sec : UpdateCCDFrame ASISetROIFormat (4656x3520, bin 1, type 0)
DEBUG 5.246331 sec : Setting frame buffer size to 16389120 bytes.
DEBUG 5.246526 sec : UpdateCCDFrame ASISetROIFormat (4656x3520, bin 1, type 0)
DEBUG 5.299397 sec : Setting frame buffer size to 16389120 bytes.
DEBUG 5.299629 sec : UpdateCCDFrame ASISetROIFormat (4656x3520, bin 1, type 2)
DEBUG 5.290327 sec : Setting frame buffer size to 16389120 bytes.
DEBUG 5.290556 sec : UpdateCCDFrame ASISetROIFormat (4656x3520, bin 1, type 2)
DEBUG 5.390950 sec : Setting frame buffer size to 32778240 bytes.
WARNING 5.391542 sec : 16 bit bayer format GRBG it not supported by the SER recorder.
DEBUG 5.391898 sec : Configuration successfully loaded.
DEBUG 5.384632 sec : Setting frame buffer size to 32778240 bytes.
WARNING 5.384728 sec : 16 bit bayer format GRBG it not supported by the SER recorder.
DEBUG 5.384918 sec : Configuration successfully loaded.
WARNING 6.432385 sec : World Coordinate System is enabled. CCD rotation must be set either manually or $
WARNING 6.455092 sec : World Coordinate System is enabled. CCD rotation must be set either manually or $
DEBUG 41.941423 sec : StartExposure->setexp : 10.000s
DEBUG 41.920465 sec : StartExposure->setexp : 10.000s
INFO 41.948078 sec : Taking a 10 seconds frame...
INFO 42.101601 sec : Taking a 10 seconds frame...
DEBUG 52.371764 sec : ASIGetExpStatus failed (0). Restarting exposure...
DEBUG 52.472024 sec : StartExposure->setexp : 10.000s
INFO 52.472308 sec : Taking a 10 seconds frame...
DEBUG 52.685237 sec : ASIGetExpStatus failed (0). Restarting exposure...
DEBUG 52.785550 sec : StartExposure->setexp : 10.000s
INFO 52.785859 sec : Taking a 10 seconds frame...
DEBUG 62.765265 sec : ASIGetExpStatus failed (0). Restarting exposure...
DEBUG 62.865561 sec : StartExposure->setexp : 10.000s
INFO 62.865829 sec : Taking a 10 seconds frame...
DEBUG 66.170600 sec : ASIGetExpStatus failed (0). Restarting exposure...
DEBUG 66.270935 sec : StartExposure->setexp : 10.000s
INFO 66.271203 sec : Taking a 10 seconds frame...
ERROR 73.122929 sec : Exposure failed after 3 attempts.

Please Log in or Create an account to join the conversation.

3 years 11 months ago
knro
Administrator
Administrator
Posts: 8720
Karma: 51
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14005
Update the camera's firmware to the *-compatible version

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 years 11 months ago
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14016
Thank you. I will contact ZWO/Sam too to ask.

It is not clear if I should continue though..

The ZWO site has a FWTool here: astronomy-imaging-camera.com/software/ on the SDK & Upgrade Tool.

There is no firmware for the ASI1600mm-c, only:
- ASI120MM-compatible.iic
- ASI130MM-compatible.iic

And these are dated over Dec 2013.

Is this a confirmed successful approach?

Regards,
Stephen

Please Log in or Create an account to join the conversation.

3 years 11 months ago
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14019
A quick update - no RPI3 progress yet; it seems beyond me.

A quick test with a Mac version suggests that things can work: indilib.org/forum/ekos/525-ekos-on-mac-o...tml?start=1212#13945

The setup is one cable from ASI1600MM-c (imaging) to Mac, then using the ASI1600 hub the ASI EFW and ASI224MM-c (guider) is connected. This setup seems to allow images to save to the mac.

KStars on the Mac is connecting to the CloudMakers Indi Server. The indi_asi.xml needed to be copied from the IndiServer into the Kstar package, and all came up. Unfortunately this setup does not work in real use for me; it at least confirms the new hardware does work.

I will check another setup tonight on the RPI3 and report back. There is clearly a difference if the using the servermanager.py on the RPI3 instead of the indiserver within Ekos. In some cases the images seem to appearing the preview, some cases they do not, and in others they do not save to the RPI3 - they appear in the directory and disappear :(

Regards,
Stephen

Please Log in or Create an account to join the conversation.

3 years 11 months ago
knro
Administrator
Administrator
Posts: 8720
Karma: 51
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14053
How did you install the software on RPI3? Can you post /usr/share/indi/indi_asi.xml file in RPI3?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 years 11 months ago
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14060
Everything on the RPI3 was installed via apt-get per the tutorials.

Jan 18th I was able to connect my ASI224mc-c as a guide camera using Ekos local Indi server on RPI3. Now the camera will not connect at all. Jan 18th was first night with ASI1600mm-c. I thought I was just my in experience new camera.

To confirm all equipment (two cameras and EFW) works, I setup/connected all the equipment directly to my Mac using Kstars and Ekos. Everything worked.

So last night on RPI3 all indi-full and kstars was removed and reinstalled using apt-get hoping It may have corrected something. It did not.

I have now tried connecting only the previously working ASI224mc-c directly to RPI3 and it will not connect at all give error (5). The ASI1600mm-c connects with Ekos remotely/local but only local allows for a preview image.

Below is the indi_asi.xml at the location you mentioned.

<?xml version="1.0" encoding="UTF-8"?>
<driversList>
<devGroup group="CCDs">
<device label="ZWO CCD" mdpd="true">
<driver name="ZWO CCD">indi_asi_ccd</driver>
<version>0.5</version>
</device>
</devGroup>
<devGroup group="Filter Wheels">
<device label="ASI Wheel">
<driver name="ASI Wheel">indi_asi_wheel</driver>
<version>0.5</version>
</device>
</devGroup>
</driversList>

Please Log in or Create an account to join the conversation.

3 years 11 months ago
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14072
Hi,

The indi release tonight helped sort of...

The ASI1600mm-c is now capturing its image and saving the files. This is great.

The ZWP EFW is also working.

However, the ASI224mc-c will no longer connect: "Error connecting to the CCD (5)"

The specific log entry:
INFO 50.206727 sec : [ZWO CCD ASI224MC-Cool] Debug is enabled.
DEBUG 62.953859 sec : [ZWO CCD ASI224MC-Cool] Attempting to open ZWO CCD ASI224MC-Cool...
ERROR 62.955346 sec : [ZWO CCD ASI224MC-Cool] Error connecting to the CCD (5)

If there is more information I can provide let me know.

The ASI224 connected prior to Jan 19, as I used it as a guide camera the first night with ASI1600 when I found out images did not work, and in December with my canon DSLR.

Please Log in or Create an account to join the conversation.

3 years 11 months ago 3 years 11 months ago by knro.
knro
Administrator
Administrator
Posts: 8720
Karma: 51
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14075
If you connect one-camera-at-a-time to the USB port with nothing else connected, does it work?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 years 11 months ago
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14078
No, but there is a change.

- ASI1600 will now take an image
- ASI224 gets the new Error connecting mentioned above.

Please Log in or Create an account to join the conversation.

3 years 11 months ago
knro
Administrator
Administrator
Posts: 8720
Karma: 51
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14090
I contacted ZWO to see if they can help in this.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 years 11 months ago
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14093
Hi,

I explored with ZWO too: zwoug.org/viewtopic.php?f=21&t=6785&p=12098#p12098

You helped greatly with the Jan 23rd INDI updated - ASI1600 worked today.

ZWO helped as well with the ASI224. The said to make the indiserver run as root, and it corrected it. Although, I would prefer running as pi. Having everything work now was the goal!

I will create a test run tonight with the whole setup - ccd, guide, efw - to confirm all is good.

Aside, I will be testing running Ekos in a web browser off the RPI3. I can post the setup if it is of interest. My goal is to have everything running to be controlled from browser, so I can monitor from PC, iPad, phone... :)

Thank you so much for the great project and support.

Cheers!
Stephen

Please Log in or Create an account to join the conversation.

3 years 11 months ago
maudy
Elite Member
Elite Member
Posts: 353
Karma: 2
More
Topic Author
HELP - RPI3 - ASI1600 - ASIGetExpStatus failed (0) #14096
Hi,

Just an update for anyone attempting this.

The INDI settings for the two ZWO cameras will not work if one is CCD and one is Guider.

The only way I can get this to work so far is to have both ZWO224 and ASI1600 as CCD.

I cannot test the guider for really this way. Everything does seem to work though.

Still testing to confirm all is good.

Regards,
Stephen

Please Log in or Create an account to join the conversation.

Time to create page: 0.825 seconds