×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7)

1 year 4 months ago
fmozza
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #27885
I cannot capture anything with QHY9 camera after upgrading to the latest bits. Errors from the logs are:
ERROR 452.057906 sec : [QHY CCD QHY9S-M-0101020] Cannot take exposure while streaming/recording is active.
ERROR 452.065258 sec : [QHY CCD QHY9S-M-0101020] Cannot take exposure while streaming/recording is active.
ERROR 452.115171 sec : [QHY CCD QHY9S-M-0101020] Cannot take exposure while streaming/recording is active.

Streaming is turned off in the indi panel so if the system thinks its active, how can I turn it off. I'm willing to help, but I need some direction as to what to change/test/etc.

Failing that, what's the best way roll back to Kstars 2.9.6? (I'm on ubuntu 16.04 for my desktop and indiserver is running on Raspberry PI in the obs - I can revert back to 1.7.2 easily)

Please Log in or Create an account to join the conversation.

1 year 4 months ago
knro
Administrator
Administrator
Posts: 7405
Karma: 51
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #27889
I cannot reproduce this here with QHY168C and QHY5L on both x86_64 and StellarMate. Are you sure everything is up to date? sudo apt-get -y dist-upgrade

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 year 4 months ago
knro
Administrator
Administrator
Posts: 7405
Karma: 51
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #27890
Try also removing the QHY config files under ~/indi

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You fmozza

Please Log in or Create an account to join the conversation.

1 year 3 months ago
fmozza
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #29269
Thought I had replied to this ... obviously not. Removing the config files worked.

Please Log in or Create an account to join the conversation.

1 year 2 months ago 1 year 2 months ago by fmozza.
fmozza
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #29645
Well,I'm back to where I can't capture from my QHY9 camera anymore. As I did before, I removed the QHY XML files from the .indi directory, and that no longer works. I get the same error - somehow something is setting the QHY9 to streaming and I can't turn it off, and I'm at a loss as to where to look. I don't fully understand the relationship between EKOS, indi and the devices drivers as to who owns what and which system is authoritative in terms of configuration settings.

Here is the log output from the .indi log directory for the QHY driver:

INFO 57.245319 sec : [QHY CCD QHY9S-M-0101010] Session log file /home/jmh/.indi/logs/2018-09-19/indi_qhy_ccd/indi_qhy_ccd_03:13:27.log
INFO 57.824753 sec : [QHY CCD QHY9S-M-0101010] Session log file /home/jmh/.indi/logs/2018-09-19/indi_qhy_ccd/indi_qhy_ccd_03:13:27.log
DEBUG 58.745050 sec : [QHY CCD QHY9S-M-0101010] Toggle Logging Level -- Driver Debug
DEBUG 59.695067 sec : [QHY CCD QHY9S-M-0101010] Toggle Logging Level -- Alignment Subsystem
DEBUG 61.787558 sec : [QHY CCD QHY9S-M-0101010] Configuration successfully saved.
DEBUG 76.507758 sec : [QHY CCD QHY5LII-M-6097d] Configuration successfully saved.
DEBUG 121.194503 sec : [QHY CCD QHY9S-M-0101010] SetTemperature -20
ERROR 133.270224 sec : [QHY CCD QHY9S-M-0101010] Cannot take exposure while streaming/recording is active.
ERROR 133.354477 sec : [QHY CCD QHY9S-M-0101010] Cannot take exposure while streaming/recording is active.
ERROR 133.404456 sec : [QHY CCD QHY9S-M-0101010] Cannot take exposure while streaming/recording is active.
INFO 186.025653 sec : [QHY CCD QHY5LII-M-6097d] CCD is offline.
DEBUG 186.254197 sec : [QHY CCD QHY5LII-M-6097d] Exposure. Min: 0 Max: 0 Step 0
INFO 186.255911 sec : [QHY CCD QHY9S-M-0101010] CCD is offline.
DEBUG 186.484288 sec : [QHY CCD QHY9S-M-0101010] Exposure. Min: 0 Max: 0 Step 0

The bits below are from EKOS log files (no real info as far as I can see, but included for completeness...)

[2018-09-18T22:15:40.316 CDT DEBG ][ org.kde.kstars.ekos.capture] - Preparing capture job "/export/home/jmh/EKOS/Light" for execution.
[2018-09-18T22:15:40.318 CDT INFO ][ org.kde.kstars.ekos.capture] - "Capturing 5-second Red image..."
[2018-09-18T22:15:40.371 CDT INFO ][ org.kde.kstars.ekos.capture] - "Capture failed. Check INDI Control Panel for details."
[2018-09-18T22:15:40.372 CDT INFO ][ org.kde.kstars.ekos.capture] - "Restarting capture attempt #1"
[2018-09-18T22:15:40.373 CDT INFO ][ org.kde.kstars.ekos.capture] - "Capturing 5-second Red image..."
[2018-09-18T22:15:40.418 CDT INFO ][ org.kde.kstars.ekos.capture] - "Capture failed. Check INDI Control Panel for details."
[2018-09-18T22:15:40.421 CDT INFO ][ org.kde.kstars.ekos.capture] - "Restarting capture attempt #2"
[2018-09-18T22:15:40.422 CDT INFO ][ org.kde.kstars.ekos.capture] - "Capturing 5-second Red image..."
[2018-09-18T22:15:40.468 CDT INFO ][ org.kde.kstars.ekos.capture] - "Capture failed. Check INDI Control Panel for details."
[2018-09-18T22:15:40.469 CDT INFO ][ org.kde.kstars.ekos.capture] - "CCD capture aborted"
[2018-09-18T22:16:33.038 CDT DEBG ][ org.kde.kstars.ekos] - Disconnecting QHY CCD QHY5LII-M-6097d
[2018-09-18T22:16:33.038 CDT DEBG ][ org.kde.kstars.ekos] - Disconnecting QHY CCD QHY9S-M-0101010
[2018-09-18T22:16:33.038 CDT DEBG ][ org.kde.kstars.ekos] - Disconnecting IEQ
[2018-09-18T22:16:33.038 CDT INFO ][ org.kde.kstars.ekos] - "Disconnecting INDI devices..."
[2018-09-18T22:16:33.091 CDT DEBG ][ org.kde.kstars.ekos] - IEQ is disconnected.
[2018-09-18T22:16:33.091 CDT INFO ][ org.kde.kstars.ekos] - "IEQ is disconnected."
[2018-09-18T22:16:33.098 CDT DEBG ][ org.kde.kstars.ekos.guide] - PHD2: event: "{\"Event\":\"Alert\",\"Timestamp\":1537326993.094,\"Host\":\"chopin\",\"Inst\":1,\"Msg\":\"INDI mount was disconnected\",\"Type\":\"warning\"}\r\n"
[2018-09-18T22:16:33.101 CDT INFO ][ org.kde.kstars.ekos.guide] - "PHD2 warning: INDI mount was disconnected"
[2018-09-18T22:16:33.318 CDT DEBG ][ org.kde.kstars.ekos] - QHY CCD QHY5LII-M-6097d is disconnected.
[2018-09-18T22:16:33.318 CDT INFO ][ org.kde.kstars.ekos] - "QHY CCD QHY5LII-M-6097d is disconnected."
[2018-09-18T22:16:33.334 CDT DEBG ][ org.kde.kstars.ekos.guide] - PHD2: event: "{\"Event\":\"Alert\",\"Timestamp\":1537326993.333,\"Host\":\"chopin\",\"Inst\":1,\"Msg\":\"INDI camera disconnected\\nThe camera has been disconnected. Please resolve the problem and re-connect the camera.\",\"Type\":\"warning\"}\r\n"
[2018-09-18T22:16:33.334 CDT INFO ][ org.kde.kstars.ekos.guide] - "PHD2 warning: INDI camera disconnected\nThe camera has been disconnected. Please resolve the problem and re-connect the camera."
[2018-09-18T22:16:33.548 CDT DEBG ][ org.kde.kstars.ekos] - QHY CCD QHY9S-M-0101010 is disconnected.
[2018-09-18T22:16:33.548 CDT INFO ][ org.kde.kstars.ekos] - "QHY CCD QHY9S-M-0101010 is disconnected."
[2018-09-18T22:16:34.156 CDT DEBG ][ org.kde.kstars.indi] - Removing managed driver "Ekos Remote Host"
[2018-09-18T22:16:34.157 CDT DEBG ][ org.kde.kstars.indi] - INDIListener: Removing device QHY CCD QHY5LII-M-6097d with unique label ""
[2018-09-18T22:16:34.161 CDT DEBG ][ org.kde.kstars.indi] - INDIListener: Removing device QHY CCD QHY9S-M-0101010 with unique label ""
[2018-09-18T22:16:34.165 CDT DEBG ][ org.kde.kstars.indi] - INDIListener: Removing device IEQ with unique label ""
[2018-09-18T22:16:34.170 CDT DEBG ][ org.kde.kstars.indi] - INDI server disconnected. Exit code: 0
[2018-09-18T22:16:34.171 CDT DEBG ][ org.kde.kstars.indi] - INDI server disconnected. Exit code: 0

Any help is appreciated,

Please Log in or Create an account to join the conversation.

1 year 2 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1112
Karma: 6
More
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #29647
I am experiencing problems with a QHY9 camera as well, though in my case the problems are with the filter wheel. See

www.indilib.org/forum/ccds-dslrs/3872-qh...x-mac-ok-though.html

I haven't found a soliution yet and will keep an eye on this thread just in case...

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

1 year 2 months ago
fmozza
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #29656
I have verified that my QHY9 is in good working order, testing it using Nebulosity 4 under Windows, using the same cables. Camera, cooler and filter works well.

I also ran qhy_ccd_test and no issues there - output below:

QHY Test CCD using SingleFrameMode, Version: 1.00
SDK resources initialized.
Number of QHYCCD cameras found: 2
Application connected to the following camera from the list: Index: 1, cameraID = QHY9S-M-0101010304XXXXXX
Open QHYCCD success.
SetQHYCCDStreamMode set to: 0, success.
InitQHYCCD success.
GetQHYCCDOverScanArea:
Overscan Area startX x startY : 3486 x 30
Overscan Area sizeX x sizeY : 30 x 2450
GetQHYCCDEffectiveArea:
Effective Area startX x startY: 3486 x 30
Effective Area sizeX x sizeY : 30 x 2450
GetQHYCCDChipInfo:
Effective Area startX x startY: 3486 x 30
Chip size width x height : 17.960 x 13.520 [mm]
Pixel size width x height : 5.400 x 5.400 [um]
Image size width x height : 3584 x 2574
This is a mono camera.
SetQHYCCDParam CONTROL_GAIN set to: 10, success
SetQHYCCDParam CONTROL_GAIN set to: 140, success.
SetQHYCCDParam CONTROL_EXPOSURE set to: 20000, success.
SetQHYCCDResolution roiStartX x roiStartY: 0 x 0
SetQHYCCDResolution roiSizeX x roiSizeY : 3584 x 2574
SetQHYCCDBinMode set to: binX: 1, binY: 1, success.
ExpQHYCCDSingleFrame(pCamHandle) - start...
ExpQHYCCDSingleFrame(pCamHandle) - end...
ExpQHYCCDSingleFrame success (0).
Allocated memory for frame: 19702032 [uchar].
GetQHYCCDSingleFrame: 3584 x 2574, bpp: 16, channels: 1, success.
CancelQHYCCDExposingAndReadout success.
Close QHYCCD success.
SDK resources released.

There is some interaction between EKOS, indi, and the driver that makes the system think streaming is turned on. qhy_test_ccd seems to indicate the camera is fine, and I presume uses the driver to communicate to the camera. I've removed the xml files, rebooted the Raspberry Pi (where indi runs) and verified cabling and USB hub. I'm at a loss as to what else I can do or check.

Ideas?

jmh

Please Log in or Create an account to join the conversation.

1 year 2 months ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 521
Karma: 3
More
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #29695

fmozza wrote: I don't fully understand the relationship between EKOS, indi and the devices drivers as to who owns what and which system is authoritative in terms of configuration settings.


Another hint where to direct future development efforts at. I think Ekos/Indi would profit massively from a major overhaul that would simplifying the configuration and have everything one place.
The following user(s) said Thank You astronomerc

Please Log in or Create an account to join the conversation.

1 year 2 months ago
mpfjr
Senior Boarder
Senior Boarder
Posts: 66
More
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #30166
I've been off these forums and not using the software for a while now hoping that QHY issues would have been resolved by now. Poked my head in the door to see what was new and found this thread.

I will wait several more months.

Please Log in or Create an account to join the conversation.

1 year 2 months ago
knro
Administrator
Administrator
Posts: 7405
Karma: 51
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #30167
There has been a new QHY SDK and QHY driver release since then in INDI Nightly PPA. Please test that.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You wvreeven

Please Log in or Create an account to join the conversation.

1 year 2 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1112
Karma: 6
More
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #30168
Will do, thanks!

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

1 year 2 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1112
Karma: 6
More
QHY broken with new release (indi-1.7.4), kstars/ekos (2.9.7) #30181
I gave it a try tonight. First I added the nightly ppa, then i updated KStars and INDI. Next I connected the QHY9 but as soon as I started the INDI server via Ekos it reported that the qhy driver had crashed. Here are the logs.


- Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.831 seconds