×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

ZWO 1600mm 16bit

9 months 3 weeks ago
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #43117
OH, I was wrong. I only get the error when trying to do a sequence of flats. I am still getting this error:

2019-09-09T11:21:22 Flat calibration failed. Captured image is only 8-bit while requested ADU is 12000.00.

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #43118
OK, I found this thread where the user has similar issues with the image timer looping:
indilib.org/forum/ccds-dslrs/1326-zwo-as...tested.html?start=36

I'm wondering if it's an issue with the firmware on the camera. I noticed that the version on the ZWO website is quite a bit higher that the one in the camera: 1,14,0315 vs v1.14.0715

I think that I'm going to try and update the firmware...

Jamie

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #43119
OK, so it looks like I had an error in my build scripts. I was not pulling indi-asi amongst other things. I'm going to rebuild and try again...

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #43121
I've pulled r1.8.1 and rebuilt. The indi_asi_ccd driver now shows SDK version: 1,14,0715 which is the latest. Given the same settings I'm still getting the endless loop. So I tried a suggestion from another thread. I reduced the image size, and now it works in 16bit raw. This is at 3264x2464. The native resolution is 4656x3520. So this is not a very good solution, but it at least seems to be pointing in some direction... I may need to try different PC hardware, or try and tweak some settings.

Jamie

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
Ihoujin
Platinum Boarder
Platinum Boarder
Posts: 897
Karma: 3
More
ZWO 1600mm 16bit #43122
Images captured in 12 or 14 bit are saved in a 16bit files as a standard. You don't magically gain additional bits of information this way as the extra bits are all zeroes. Advantage is 16 bit has to room to faithfully store the full 12 or 14 bit information. On the other hand 8 bit containers do not, and thus will not record all the information the hardware is capable of.

INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8087
Karma: 51
ZWO 1600mm 16bit #43123

amendolajamie wrote: I've pulled r1.8.1 and rebuilt. The indi_asi_ccd driver now shows SDK version: 1,14,0715 which is the latest. Given the same settings I'm still getting the endless loop. So I tried a suggestion from another thread. I reduced the image size, and now it works in 16bit raw. This is at 3264x2464. The native resolution is 4656x3520. So this is not a very good solution, but it at least seems to be pointing in some direction... I may need to try different PC hardware, or try and tweak some settings.

Jamie


I'm curious if changing the usbfs_memory_mb could help edit? Edit the 99-asi.rules
sudoedit /lib/udev/rules.d/99-asi.rules

Change the 256 in the first line to something like, maybe 512?

Though I think long term solution might involve ZWO breaking down the usb bulk transfer into more manageable chunks.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #43124
Yep. Not expecting bits that aren't there, but I would like the ones that are:)

So digging deeper it looks like the usb connection should be good @5000M (below).
I wonder what else I might be able to try?


T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 6 Spd=5000 MxCh= 0
D: Ver= 3.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 9 #Cfgs= 1
P: Vendor=03c3 ProdID=1604 Rev=00.00
S: Manufacturer=ZWO
S: Product=ASI1600MM Pro
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=512mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago 9 months 3 weeks ago by amendolajamie.
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #43125
Woot! That did it. I did not have that rule installed. Was this supposed to be installed with indi, or is it a tweak that someone just found.

I used this that I found here: github.com/indilib/indi/blob/master/3rdp...-common/99-asi.rules

ACTION=="add", ATTR{idVendor}=="03c3", RUN+="/bin/sh -c '/bin/echo 256 >/sys/module/usbcore/parameters/usbfs_memory_mb'"
# All ASI Cameras and filter wheels
SUBSYSTEMS=="usb", ATTR{idVendor}=="03c3", MODE="0666"


Thanks!
The following user(s) said Thank You feilimb

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8087
Karma: 51
ZWO 1600mm 16bit #43130
This rule is installed when you install the PPA along with other rules per camera manufacturer.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You amendolajamie

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #43131
I see. Makes sense. Just compiling from source so that's why I didn't get it. Anyway it's working now. Can't wait to try it out and see all of the bits!

Jamie

Please Log in or Create an account to join the conversation.

9 months 1 week ago
feilimb
Junior Boarder
Junior Boarder
Posts: 30
More
ZWO 1600mm 16bit #43764
I think I might (possibly) be experiencing the same type of problem with my ASI294MC-Pro. In my case, when capturing darks the first 300 second dark downloads OK, but subsequent dark downloads are corrupt/incomplete (either with a filesize of 0MB, or ~5MB - expected filesize would be ~23MB).

I also built from source.

Can you guide me on how to apply the rule you posted above? Are these commands to be entered from bash?

Please Log in or Create an account to join the conversation.

7 months 2 weeks ago
amendolajamie
Junior Boarder
Junior Boarder
Posts: 34
More
Topic Author
ZWO 1600mm 16bit #46062
Sorry, I didn't get a notification about your post..

If you still need it, or if anyone else does. Just search for the rule file, and put it into your system rules. Something like this:
pi@raspberrypi:/usr/local/indi$ find . | grep asi.rule | grep asi
./indi-3rdparty/asi-common/99-asi.rules
./indi-3rdparty/debian/indi-asi/rules
./3rdparty/asi-common/99-asi.rules
./debian/indi-asi/rules


cp ./3rdparty/asi-common/99-asi.rules /etc/udev/rules.d/

Please Log in or Create an account to join the conversation.

Time to create page: 0.261 seconds