×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Plate Solving Issues

2 months 5 days ago 2 months 5 days ago by rankinstudio.
rankinstudio
Expert Boarder
Expert Boarder
Posts: 89
More
Topic Author
Plate Solving Issues #44435
This has really been an issue since I started using Kstars / Ekos / INDI. Getting the plate solving working reliably seems impossible at times.

It would be nice if there were more than one option, SGP supports Platesolve2 from planewave that smokes ansvr in every way. planewave.com/downloads/software/

All Sky Plate Solver, which also uses astrometry.net, solves it in a few seconds no issues. I see a discrepancy between the two.





As you can see, the "calculated" image scale is way different in Kstars than it is after being solved in Allksy Solver. Unchecking "auto update" and setting it manually doesn't help. It reverts back to using the scale calculated in the software, which is way off.

1.19 to 2.4 is way above the actual values of 1.1.

I'd suggest at some point adding support for platesolve2, as it is just better in every way.

Any suggestions as to what may be causing this issue?

Using latest everything, Ekos, Kstars, Indi, Win10. Canon 6D.

Thanks!
Attachments:
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

2 months 5 days ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2031
Karma: 19
More
Plate Solving Issues #44436
I believe that Platesolve2 is a closed-source windows-only program, correct? That might be kind of an issue for KStars which is an open-source Linux program that has been ported/adapted so that it will run on Windows and MacOS. I wouldn't be against adding support for other programs, but the program won't even run on my computer unless I use wine, which isn't really the best plan for this purpose I don't think. Personally I really like Astrometry.net, it does a great job for my system, solves in about 1-2 seconds most of the time and its accurate enough to get it going really quick.

Based on your screenshot, I don't think that the astrometry.net solution is that far off from the other one you posted. One says the pixel scale is 1.09 and the other says 1.11, one says that the field of view is 101' x 67'. and the other says 101' x 67.7'.

The solver options in the KStars options box for the scale that you posted say 1.99 to 2.44. Those numbers should be coming from the astrometry solution, but they aren't directly reported by astrometry.net, they are calculated by KStars based on the information it has, which includes the astrometric solution. So if they are incorrect, that is some KStars code that we will need to look at. But that isn't straight from astrometry.net.

Please Log in or Create an account to join the conversation.

2 months 5 days ago 2 months 5 days ago by rankinstudio.
rankinstudio
Expert Boarder
Expert Boarder
Posts: 89
More
Topic Author
Plate Solving Issues #44438
That all makes sense. Platesolve 2 is closed and windows based.

I'm not sure why I've had such a hard time getting it to work, especially when All Sky works great every time. I had these issues with the QHY163M as well. Any time I got anywhere close to the milky way, it would not solve.

I played with the settings for a few hours in Kstars / Ekos and couldn't get it to solve. If it's reading the mount position and the position is way off, is there a way to just do a completely blind solve?

"The solver options in the KStars options box for the scale that you posted say 1.99 to 2.44." - I figured these were being calculated from the pixel size, focal length, ect?

"Based on your screenshot, I don't think that the astrometry.net solution is that far off from the other one you posted. "It is close because of a previous solve I think. Of the 20 or 30 attempts I made, only about 2 worked.

Thanks for the help.

Please Log in or Create an account to join the conversation.

2 months 5 days ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2031
Karma: 19
More
Plate Solving Issues #44439
Ah, I was looking at the screenshot at the top left for the last successful solve and the solution parameters. I assume it must have solved at some point or that would be blank.

KStars will tell astrometry do a partly blind solve to start. The first time it runs, the scale is set to zero, so that makes it ignore the scale. After that, it should use the previous solve to refine the scale so it takes less time to solve subsequent images. So yes, if it had a good solve, that updated those boxes, and I do think those solves were accurate based on the comparison you showed.. That should have also update the settings in the astrometry options. Yes I believe they are calculated from the pixel size, focal length etc. I'm pretty sure that the astrometry solution factors into that calculation, but it could also be largely based on other entries in KStars as well. That might be worth investigating if those aren't right. If you want to, you can uncheck the boxes, and take the scale out of the parameters it uses to solve, then see if it solves. Also I saw you were using bpp for the units, I don't have experience with that setting. I usually use aw, or arc second width. Did you try that? Astrometry.net takes a little bit to configure but it is incredibly powerful and once you get it configured well, it works like a charm. There are reasons for why it is used as the engine behind a wide range of plate solving front ends. It works well and works on many systems.

Please Log in or Create an account to join the conversation.

2 months 4 days ago
knro
Administrator
Administrator
Posts: 7418
Karma: 51
Plate Solving Issues #44442
What are the options sent to astrometry.net? I only see a portion of them. Paste the complete generated options.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 4 days ago
rankinstudio
Expert Boarder
Expert Boarder
Posts: 89
More
Topic Author
Plate Solving Issues #44445
The setting in Kstars are correct. Again, no idea what is causing it to constantly fail solves.

Please Log in or Create an account to join the conversation.

2 months 4 days ago
knro
Administrator
Administrator
Posts: 7418
Karma: 51
Plate Solving Issues #44446
Turn on verbose logging and check "Alignment" in the logs. What does it say?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 4 days ago 2 months 4 days ago by universalmaster.
universalmaster
Expert Boarder
Expert Boarder
Posts: 128
More
Plate Solving Issues #44472
I'm having a similar issue. No matter what I set scales to, the command run by ekos when doing an off-line plate solve uses the wrong scales. If I run the same command manually in a shell but with the correct scales, the solve works fine. The "options" shown under "solver options" are the correct options, but ekos still runs the command with the wrong scale (according to the long). Not even the units are the same as set in options (I choose aw, log says -u app).
This is with the CCD and telescope simulators, btw.

Please Log in or Create an account to join the conversation.

2 months 4 days ago
knro
Administrator
Administrator
Posts: 7418
Karma: 51
Plate Solving Issues #44473
logs?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

2 months 4 days ago
rankinstudio
Expert Boarder
Expert Boarder
Posts: 89
More
Topic Author
Plate Solving Issues #44475
I agree, the user should be able to just override these settings if they know the scale.

Krno:

I haven't had a chance to setup again. I'm trying to do a load & solve using the CCD simulator with the same setting as my DSLR. I'll see if I can get it to work.

Please Log in or Create an account to join the conversation.

2 months 4 days ago 2 months 4 days ago by rankinstudio.
rankinstudio
Expert Boarder
Expert Boarder
Posts: 89
More
Topic Author
Plate Solving Issues #44476
Interestingly, using the simulators and "upload and solve" the images that were not solving night before last are now solving, sorta.

The positions are off, by over 1.5 arcmin in RA and DEC.

Attached is a screenshot showing the nova.astrometry.net solve, the All sky plate solver solve (astrometry.net) vs Kstars solve.

The pixel scale is also still off in Kstars.

I'm guessing this may have been an issue with the mount location being off. I don't think it was 30 degrees off. Not possible.

Attachments:

Please Log in or Create an account to join the conversation.

2 months 3 days ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Plate Solving Issues #44483
A few weeks ago I unticked Use Scale and ever since plate solving has been working very well. I had some plate solving issues where the wrong scale was used with a DSLR and that led to solving problems that could be solved with disabling Use Scale. I now have disabled this always, even with my ASI1600MM for which solving works fine when Use Scale is enabled as well.


HTH, Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

Time to create page: 0.607 seconds