×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Indi and QHY 183C [Solved]

7 months 3 weeks ago 7 months 1 week ago by rmor51.
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48582
Hi,

just a short question: Is the QHY 183C cam running with the Indi Qhy driver ? Thanks.

Robert

Please Log in or Create an account to join the conversation.

7 months 3 weeks ago
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48626
I receive it today and I test it with Kstars immediately. It seems that all is OK. I am expecting a good sky, for ages, in order to test with my telescope.

Please Log in or Create an account to join the conversation.

7 months 3 weeks ago 7 months 3 weeks ago by rmor51.
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48642
Oooops I speak to quick. The camera is running on my desktop but not on my laptop a Toshiba Portege R930. At the connection, I have a message in Kstars saying "No QHY camera detected power on ? (Indi)".
Very curious, my laptop is newer than my desktop ! HELP !

Firecapture doesn't detect the camera also.

Please Log in or Create an account to join the conversation.

7 months 3 weeks ago
wvreeven
Supernova Explorer
Supernova Explorer
Posts: 1624
Karma: 8
More
Indi and QHY 183C [Solved] #48650
What OS are you running on your laptop? Can you provide debug logs?

ASI6200 and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

7 months 3 weeks ago
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48652
I run Ubuntu-Mate 18.04.03 LTS, on the laptop and the desktop.

File Attachment:

File Name: log_13-29-35.txt
File Size:31 KB

I check the Portege has 2 USB 3.0.

The command lsusb gives:

robert@robert-PORTEGE:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b369 Chicony Electronics Co., Ltd
Bus 001 Device 004: ID 8087:07da Intel Corp.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 1618:c183
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
robert@robert-PORTEGE:~$
Attachments:

Please Log in or Create an account to join the conversation.

7 months 3 weeks ago
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48675
I think it is a problem with the laptop. It recognizes badly the camera, instead the 224C is correctly recognized.

robert@robert-PORTEGE:~$ lsusb -s 003:002 -v (ligne spécifique de la caméra)

Bus 003 Device 002: ID 1618:c183
Couldn't open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x1618
idProduct 0xc183
bcdDevice 1.00
iManufacturer 1
iProduct 2
iSerial 3
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 18
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 200mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 0
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 0
bInterfaceProtocol 0
iInterface 0
robert@robert-PORTEGE:~$

Please Log in or Create an account to join the conversation.

7 months 2 weeks ago
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48725
I think I find a solution either the solution. I launch a live Ubuntu 19.10. The camera is well recognized into a terminal. I am installing this version . And I'm keeping my fingers crossed.

Please Log in or Create an account to join the conversation.

7 months 2 weeks ago
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48728
No, it's not working. The camera is recognized but always with error:

robert@robert-PORTEGE:~lsusb -s 003:003 -v

Bus 003 Device 003: ID 1618:c183 Cypress WestBridge
Couldn't open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x1618
idProduct 0xc183
bcdDevice 1.00
iManufacturer 1
iProduct 2
iSerial 3
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 0x0012
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 200mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 0
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 0
bInterfaceProtocol 0
iInterface 0 lsusb -s 003:003 -v

Bus 003 Device 003: ID 1618:c183 Cypress WestBridge
Couldn't open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x1618
idProduct 0xc183
bcdDevice 1.00
iManufacturer 1
iProduct 2
iSerial 3
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 0x0012
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 200mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 0
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 0
bInterfaceProtocol 0
iInterface 0
robert@robert-PORTEGE:~$
robert@robert-PORTEGE:~$

Please Log in or Create an account to join the conversation.

7 months 2 weeks ago
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48786
I'm continuing my investigations. I installed a Win10 on my laptop, broadcast driver wdm, ascom driver and system driver.
EZCAP seems to runs.
Firecapture recognises the camera but do anything.
Sharpcap runs with the ascom driver, slowly.

It seems to be an OS problem of Ubuntu. I don't know how to do.

Please Log in or Create an account to join the conversation.

7 months 2 weeks ago
uri2020
Fresh Boarder
Fresh Boarder
Posts: 5
More
Indi and QHY 183C [Solved] #48817
Hi! Same problem here with a Polemaster and Astroberry Server. I finally tracked it to a permissions issue. When I run kstars as root, it connects to the camera.

I suspect it has something to do with the QHY SDK, as in the QHYCCD web they state that the Polemaster software for rpi has to run as root. That's what I have done to temporary patch this issue:

1- Go to /usr/bin and rename driver file indi_qhy_ccd to something else. In my case, indi_qhy_ccd_binary:

#cd /usr/bin
#sudo mv indi_qhy_ccd indi_qhy_ccd_binary

2- Edit a new shell script file named indi_qhy_ccd. I used vi, you can use a fancier editor if you like it more. I'm afraid I'm old school ;)

#sudo vi indi_qhy_ccd

with these contents:

#!/bin/bash
sudo indi_qhy_ccd_binary

3- Make it executable:

#sudo chmod 755 indi_qhy_ccd

4- Modify /etc/sudoers to not ask for password when executing the script. This has to be done using the "visudo" command. DO NOT use any other editor or you risk losing root access to the computer if file ends with syntax errors.

#sudo visudo

Best way to do this will depend on distro. But adding to the end of the file this should work in most, if not any of them:

ALL ALL = (root) NOPASSWD:/usr/bin/indi_qhy_ccd_binary

In my case, what I did is:

%sudo ALL = (root) NOPASSWD:/usr/bin/indi_qhy_ccd_binary

This means that members of group sudo can execute /usr/bin/indi_qhy_ccd_binary as root without being asked for password.

After that, I'm able to connect to my polemaster executing kstars as non-privileged user.

Please note that this approach has some problems/limitations. In first place, we will be calling the closed-source QHYSDK as root. If you have any problem with that and still want to go ahead, you should do it in a machine only used for imaging and disconnected from the Internet, or in a virtual machine or docker container. And secondly, the next indi_qhy_ccd update will overwrite the newly created shell script. It can solve the issue, or not. In case not, we always could rename it again and re-create the shell script (or keep a copy in our homedir)

Note for developers: First approach I tried was setting the setuid bit in indi_qhy_ccd. For some reason, it dit not work. But setting it in qhy_ccd_test did.

Please Log in or Create an account to join the conversation.

7 months 2 weeks ago
uri2020
Fresh Boarder
Fresh Boarder
Posts: 5
More
Indi and QHY 183C [Solved] #48818
Hi! Wrote a long and detailed answer and got lost when tried to send it... So I'll make it short this time...

Same problem with Polemaster and Astroberry server. Tracked down to permissions problem (probably within the QHY SDK?). One solution is to run kstars as root. A more elegant one is to run only indi_qhy_ccd as root. What I did is rename indi_qhy_ccd (i.e. indi_qhy_ccd_binary), create a shell script with this name that calls "sudo indi_qhy_ccd_binary", and add the script to the sudoers file with no password flags. Line could be something like this:

ALL = (root) NOPASSWD:/usr/bin/indi_qhy_ccd_binary
Please note that sudoers file should only be edited by using the "visudo" command, or you risk losing privileged access to the computer if you make any mistakes.

Then it works. It will be rewritten by next driver update, of course, and leaving indi_qhy_ccd_binary file. If the new driver works without issue, that's it, you can delete this file. If not you can still delete it, rename the new indi_qhy_ccd, and re-create the shell script.

As a note to developers, I also tried setting the setuid bit of indi_qhy_ccd, but that did not work. It worked setting it in qhy_ccd_test though...

Please Log in or Create an account to join the conversation.

7 months 2 weeks ago 7 months 2 weeks ago by rmor51.
rmor51
Expert Boarder
Expert Boarder
Posts: 102
More
Topic Author
Indi and QHY 183C [Solved] #48826
Finaly, the issue is caused by the power of the USB port not enought on this laptop and others. I try the camera with the laptop newer than mine and the result was the same.
So I bought this afternoon an usb3 hub powered 2A, and the camera becames a c184 type.
It runs well with Firecapture. With Kstars I have the connection. I can modify the parameter panel. But it fails to capture an image. The field "Exposition" into the panel Progression inits with the specified exposition, but does not move. And Ekos seems to circle until I stop the capture.
Not enought power ?

File Attachment:

File Name: log_17-10-07.txt
File Size:1,394 KB


One day later. Test on HP Pavilion DV7 with USB2, Ubuntu-Mate 18.04.3LTS. Kstars runs perfectely. I have to change my laptop ? But I would want to understand all these issues before.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 1.137 seconds