×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

[Debian 10] Issue on Atik driver compilation

3 months 4 weeks ago
vbo
Fresh Boarder
Fresh Boarder
Posts: 4
More
Topic Author
[Debian 10] Issue on Atik driver compilation #48955
Hi all,

I have a problem with an Atik 460EX camera I try to drive with Indi.

I have compiled with success an IndiServer on a Debian 10 OS (without any desktop application), using SSH command line. I have compiled ZWO Asi libray and driver too, without problem, and it works ; KStars/Ekos is installed on an other PC (with Ubuntu 16.04) and I can connect both KStars/Ekos and Indiserver. I got images.

I need to make the same thing with an Atik 460EX camera. So I tried the same way.
I compiled and installed the Atik library in /usr. But when I try to compile the Atik driver (with make -j4), I have an issue

[ 75%] Linking CXX executable indi_atik_wheel
/usr/bin/ld : escamotage incompatible /usr/lib/gcc/i686-linux-gnu/8/../../../i386-linux-gnu/libatikcameras.so lors de la recherche de -latikcameras
/usr/bin/ld : escamotage incompatible /lib/i386-linux-gnu/libatikcameras.so lors de la recherche de -latikcameras
/usr/bin/ld : escamotage incompatible /usr/lib/i386-linux-gnu/libatikcameras.so lors de la recherche de -latikcameras
/usr/bin/ld : escamotage incompatible //lib/i386-linux-gnu/libatikcameras.so lors de la recherche de -latikcameras
/usr/bin/ld : escamotage incompatible //usr/lib/i386-linux-gnu/libatikcameras.so lors de la recherche de -latikcameras
/usr/bin/ld : ne peut trouver -latikcameras
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/indi_atik_wheel.dir/build.make:88: indi_atik_wheel] Error 1
make[1]: *** [CMakeFiles/Makefile2:73: CMakeFiles/indi_atik_wheel.dir/all] Error 2
make[1]: *** Attente des tâches non terminées....

Sorry, error messages are in French language... I don't know what "Escamotage incompatible" means or lokks like in English language...
Those are errors for the filter wheels (indi_atik_wheel) but I have the same ones for cameras (indi_atik_ccd).

The CMake result is as follows :

vincent@telescope:~/Projects/build/indi-atik$ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug ~/Projects/indi-3rdparty/indi-atik
-- The CXX compiler identification is GNU 8.3.0
-- The C compiler identification is GNU 8.3.0
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Found CFITSIO 3.45: /usr/lib/i386-linux-gnu/libcfitsio.so
-- Found INDI: /usr/lib/i386-linux-gnu/libindidriver.so;/usr/lib/i386-linux-gnu/libindiAlignmentDriver.so (found version "1.8.4")
-- Found ZLIB: /usr/lib/i386-linux-gnu/libz.so (found version "1.2.11")
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29")
-- Found USB1: /usr/lib/i386-linux-gnu/libusb-1.0.so (found version "1.0.22")
-- Performing Test USB1_HAS_LIBUSB_ERROR_NAME
-- Performing Test USB1_HAS_LIBUSB_ERROR_NAME - Success
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Atik Library: /usr/lib/i386-linux-gnu/libatikcameras.so
-- Performing Test COMPATIBLE_FORTIFY_SOURCE
-- Performing Test COMPATIBLE_FORTIFY_SOURCE - Success
-- Configuring done
-- Generating done
-- Build files have been written to: /home/vincent/Projects/build/indi-atik

Is there any problem with GCC 8.xx or with the linker ?
Could I use the Jasem's PPA to install drivers on Debian 10 instead of compiling them ? (compile drivers is a good experience to well know this system).

Thank you
Vincent

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
jpaana
Gold Boarder
Gold Boarder
Posts: 246
Karma: 5
More
[Debian 10] Issue on Atik driver compilation #48963
Hm, it seems the previous update to libatik accidentally replaced 32-bit Intel libraries with 32-bit ARM libraries:

jpaana@thinkpad:~/src/indi-3rdparty/libatik/x86$ file *
libatikcameras.bin: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, BuildID[sha1]=23835ac1829d8136c39f67d5cd012ba9adc9e89e, with debug_info, not stripped
libflycapture.bin: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, BuildID[sha1]=184899e4365d2a46b33bc5b1a310e54e478b68f4, stripped

I guess no one has tried them for a while as this is the first report of that :) I'll let Jasem know but you could checkout indi-3rdparty repo at commit 6b9e9cf478e3a24b939cad1ac66c33763e85f2d8 which it the one before that update. There the files seem correct:

jpaana@thinkpad:~/src/indi-3rdparty/libatik/x86$ file *
libatikcameras.bin: ELF 32-bit LSB shared object, Intel 80386, version 1 (GNU/Linux), dynamically linked, BuildID[sha1]=e61fc8de20aa9a60ee60a1b522569ed4d8dbabfa, with debug_info, not stripped
libflycapture.bin: ELF 32-bit LSB shared object, Intel 80386, version 1 (GNU/Linux), dynamically linked, BuildID[sha1]=6497545c6f6aa6abfa32beb47e872e5d879c404d, stripped

Remote observatory running Ubuntu 19.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You vbo

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
vbo
Fresh Boarder
Fresh Boarder
Posts: 4
More
Topic Author
[Debian 10] Issue on Atik driver compilation #48966
Hi Jarno,

Thanks a lot !

I've checkout indi-3rdparty at this commit and all works fine now ! No problem with compilation.
I've tried the camera and it works.

Please ask Jasem to replace the original files.

Vincent

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago
pch
Gold Boarder
Gold Boarder
Posts: 185
Karma: 2
More
[Debian 10] Issue on Atik driver compilation #49126
I get this issue too on my i386 system.

I just make a PR with the fixed libraries.

Patrick

The following user(s) said Thank You jpaana

Please Log in or Create an account to join the conversation.

Time to create page: 0.497 seconds