×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Atik 460 not working

2 weeks 2 days ago
cherno
Junior Boarder
Junior Boarder
Posts: 30
More
Topic Author
Atik 460 not working #49033
After the last update from the stable ppa I get this messages on starting the indiserver:
:~$ indiserver indi_atik_ccd
2020-02-04T17:23:33: startup: indiserver indi_atik_ccd 
Child process 13070 died
2020-02-04T17:23:34: Driver indi_atik_ccd: stderr EOF
<delProperty device="Atik 460ex"/>
...
2020-02-04T17:23:45: Driver indi_atik_ccd: Terminated after #10 restarts.
2020-02-04T17:23:45: good bye

Cherno

Please Log in or Create an account to join the conversation.

2 weeks 1 day ago
cherno
Junior Boarder
Junior Boarder
Posts: 30
More
Topic Author
Atik 460 not working #49069
Ok .Meanwhile I did some more tests:
Ubuntu 19.10 see previous message
raspi buster works
artemis on windows works
guiding cam qhy works on ubuntu

This is no problem with cables.
What shall I do? Compile indilib for myself?

Help me Obi Wan
cherno

Please Log in or Create an account to join the conversation.

2 weeks 1 day ago
jpaana
Gold Boarder
Gold Boarder
Posts: 237
Karma: 5
More
Atik 460 not working #49085
That looks like a build error, usually caused by mismatch between base INDI library used to compile the driver and the version installed in the system as the driver crashes on startup before even connecting to device. If you are running on 32-bit x86, there is currently a known issue with libraries in the repository being for 32-bit ARM by accident. I run self compiled head versions of INDI and drivers on Ubuntu 19.10 on 64-bit x64 with 383L+ without problems so the driver itself should work. If you can compile INDI yourself, rebuilding with matching INDI and driver versions usually fixes things and if you run 32-bit x86, you should roll back the indi-3rdparty repo to commit 6b9e9cf478e3a24b939cad1ac66c33763e85f2d8 which is before the wrong libraries were commited and install libatik from that commit. Then you can compile indi-atik from the head for example.

Remote observatory running Ubuntu 19.10 x64 with ScopeDome 2M, Skywatcher EQ8 and HEQ5, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, USB_Focus V3, Gemini SnapCap, USB_DewPoint, KomaHub

Please Log in or Create an account to join the conversation.

1 week 5 days ago
cherno
Junior Boarder
Junior Boarder
Posts: 30
More
Topic Author
Atik 460 not working #49202
I found this message
x86 Replace wrong arm libraries in Intel x86 directory (#56) yesterday
here
https://github.com/indilib/indi-3rdparty/tree/master/libatik

Many Thanks to pchev

Please Log in or Create an account to join the conversation.

1 week 1 day ago
cherno
Junior Boarder
Junior Boarder
Posts: 30
More
Topic Author
Atik 460 not working #49398

Please Log in or Create an account to join the conversation.

Time to create page: 0.685 seconds