×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

> 30s exposures on canon 760D (T6s)

  • Posts: 32
  • Thank you received: 0
If I understand correctly exposures longer than 30s can be made via either a connection of some sort to the remote connector of the camera or internally via eosremoterelease property.
gphoto2 --list-allconfig confirms that the eos 760D has that property so I expect the infi_gphoto_ccd driver to be able to manage aver 30s exposures directly via USB.

But it does not work on my 760D. The indi panel shows a "shutter release port" which is green and set by default to 7624.
So on requesting an exposure longer than 30s, the driver tries to trigger/communicate on that non existent port and of course fails.
Everything predefined works well up to 30s.
Any idea what I am missing ?
(I have compiled a freshly pulled version of indi-gphoto-ccd)
--
fm
Last edit: 2 years 8 months ago by François Meyer. Reason: misspelling
2 years 8 months ago #54553

Please Log in or Create an account to join the conversation.

  • Posts: 858
  • Thank you received: 139
I have a 5DMk2 and use the "Canon" driver. The "shutter release port" field is being left empty here. Make sure mirror lock settings are the same in the camera and Indi. Either both ON or both OFF. For exposures >30s the Indi->CanonCamera->Options->FORCE BULB setting should be ON (I don't know wheter it will work with this set to OFF, too). Good luck!
2 years 8 months ago #54554

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 0
Thanks. I double checked all of these, tested that mirror lock is ok with a 1s setting. Checked forced bulb. Started well, the "shutter release port" field disappears, which sounds good.
Then tried a 1s exposure (with force bulb so should trigger what is needed) but ot no avail though it started well, invoking eosremoterelease, but it insists on communicating to that
damned shutter port :) :

18:17:57.897: [INFO] Starting 1 seconds exposure (+1 seconds mirror lock).
18:17:57.897: [DEBUG] Starting exposure (exptime: 1 secs, mirror lock: 1, force bulb: true, exposure index: 0)
18:17:57.897: [DEBUG] Mutex locked
18:17:57.897: [DEBUG] Setting exposure widget bulb index: 0
18:17:57.897: [DEBUG] Setting radio/menu widget shutterspeed: 0 (bulb)
18:17:57.897: [DEBUG] Setting new configuration OK.
18:17:57.897: [DEBUG] eosremoterelease Mirror Lock for 1 secs
18:17:57.897: [DEBUG] Setting radio/menu widget eosremoterelease: 2 (Press Full)
18:17:57.897: [DEBUG] Setting new configuration OK.
18:17:57.897: [DEBUG] Setting radio/menu widget eosremoterelease: 4 (Release Full)
18:17:57.897: [DEBUG] Setting new configuration OK.
18:17:57.897: [DEBUG] End of mirror lock timer
18:17:57.897: [DEBUG] Opening remote serial shutter port: 7623 ...
18:17:57.897: [ERROR] Failed to open serial port: 7623
18:17:57.897: [ERROR] Error starting exposure

(I just realized that the timings look wrong, if the driver is supposed to wait for 1 second for mirror lock it should show up in the debug timings)
Last edit: 2 years 8 months ago by François Meyer. Reason: misspelling
2 years 8 months ago #54557

Please Log in or Create an account to join the conversation.

  • Posts: 858
  • Thank you received: 139
OK, just to make sure this doesn't interfere with your efforts, I'd switch off mirror lock completely for now. With regard to serial shutter port, I have no idea where this is coming from. You selected "Canon DSLR" as your CCD: in the Profile Editor?

2 years 8 months ago #54559
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 0
Solved, sorry : invoking indi_gphoto_ccd is not equivalent to invoking indi_canon_ccd though the latter is a symlink to the former.

So if owning a canon, invoke indi_canon_ccd :)

Still, it might be worth mentioning in the faq, though I should have tried it.

Thanks again, the sky is clear, roof is opened, I will attempt my first simultaneous acquisitions (wide field on a T80/760D, narrow field on the C14/Atik 4000), target will be m101
Best.
--
fm
2 years 8 months ago #54561

Please Log in or Create an account to join the conversation.

Purge your config as it was probably saved there. You can also delete them from ~/.indi directory.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 8 months ago #54562

Please Log in or Create an account to join the conversation.

Time to create page: 0.212 seconds