×

INDI Library v1.9.8 Released (Yesterday)

Bi-monthly INDI Library released with new drivers and bug fixes.

How to use SPC900 LED long Exposure

  • Posts: 38
  • Thank you received: 2
Hello,

I find in a box, an old Philips SPC900. And I discover that Ekos can make long exposure with a command wiring on the LED.

Does someone have schematic to make this mod ?

And is there something to install, to make this works ? Because I try to active the LX Mode via SPC900_LED ratio, and I got the next message :

2015-04-26T10:12:01: Can not set Lx Mode to SPC900 LED
2015-04-26T10:12:01: ERROR: device does not support PWC ioctl

If someone can help me.

Best regards

Gaetan
7 years 5 months ago #4069

Please Log in or Create an account to join the conversation.

  • Posts: 157
  • Thank you received: 2
+1
Linux Mint 17.1 + Kubuntu 14.10 hybrid OS, using PPA for latest KStars-bleeding and INDI
7 years 5 months ago #4074

Please Log in or Create an account to join the conversation.

  • Posts: 226
  • Thank you received: 88
Hello,

The PWC ioctls are no longer supported in kernel > 3.2 (or 3.10, not sure anymore). These ioctls were used to control the led so it does not work for recent kernels. As you did not make the mod you may consider to use the serial mod instead. If you really want to use the LED mod, I added LED control to the current PWC driver through the V4L2_FLASH control. So you will need to build this new kernel module for your target architecture. All that stuff is explained here . The current V4L2 indi driver should detect the V4L2_FLASH control and then enable Long Exposure.

Best Regards,
Jean-Luc.
7 years 5 months ago #4075

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 2
Hello,
Thank's geehalel. I will try this as son as possible.

(J'ai l'impression qu'il y a quelques francophone ici.)
7 years 5 months ago #4077

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 2
hello,

I make some test, in a first time, I try to build the driver, and test in Ekos to set the LX mod via Led ... It doesn't work.

I follow the command on the website pwc-lxled ... but there is some warnings and error on the make
make: entrant dans le répertoire « /usr/src/linux-headers-3.13.0-49-generic »
  LD      /home/gaetan/Téléchargements/pwc-lxled/built-in.o
  CC [M]  /home/gaetan/Téléchargements/pwc-lxled/pwc-if.o
/home/gaetan/Téléchargements/pwc-lxled/pwc-if.c:723:2: warning: initialization from incompatible pointer type [enabled by default]
  .buf_finish  = buffer_finish,
  ^
/home/gaetan/Téléchargements/pwc-lxled/pwc-if.c:723:2: warning: (near initialization for ‘pwc_vb_queue_ops.buf_finish’) [enabled by default]
/home/gaetan/Téléchargements/pwc-lxled/pwc-if.c:727:2: warning: initialization from incompatible pointer type [enabled by default]
  .stop_streaming  = stop_streaming,
  ^
/home/gaetan/Téléchargements/pwc-lxled/pwc-if.c:727:2: warning: (near initialization for ‘pwc_vb_queue_ops.stop_streaming’) [enabled by default]
/home/gaetan/Téléchargements/pwc-lxled/pwc-if.c: In function ‘usb_pwc_probe’:
/home/gaetan/Téléchargements/pwc-lxled/pwc-if.c:1024:16: error: ‘struct vb2_queue’ has no member named ‘timestamp_flags’
  pdev->vb_queue.timestamp_flags = V4L2_BUF_FLAG_TIMESTAMP_MONOTONIC;
                ^
make[1]: *** [/home/gaetan/Téléchargements/pwc-lxled/pwc-if.o] Erreur 1
make: *** [_module_/home/gaetan/Téléchargements/pwc-lxled] Erreur 2
make: quittant le répertoire « /usr/src/linux-headers-3.13.0-49-generic »

I try to change in the pwc-if.c the line where the timestamp_flags is used, the make works, also if I stop the pwc module and reload with the option for led control, it doesn't work.

If someone already have the problem ? I take the advice.
7 years 4 months ago #4094

Please Log in or Create an account to join the conversation.

  • Posts: 226
  • Thank you received: 88
Hi,

This is due to some changes in the V4L2 API between 3.13 and 3.16 version on which I've tested it. I guess you use Ubuntu 14.04 so I attach a version for last kernel version 3.13.0-51 used in Ubuntu 14.04. I did not test it as I have to sync/recompile kstars and this ubuntu version is running on a small netbook. Will know in 1 or 2 hours. Forget to say that you should run 'sudo depmod' after installing the new module. Acually kstars-bleeding does not run anymore on 14.04, so using the standard ubuntu kstars version, I'm able to control the LED of the SPC900 (test with the Strobe/Stop Strobe switches in the V4L2 Options tab).
The following user(s) said Thank You: gaetan
Last edit: 7 years 4 months ago by Jean-Luc.
7 years 4 months ago #4106
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 2
Hi geehalel,

It's better. Now I can set the lxmod of my spc900 to LXLED.

Next step wiring a camera ... but it will be for next week.

But the first step is ok.

Thank's
7 years 4 months ago #4107

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 5
Hi,

I found this topic searching for how to configure my ubuntu 14.04 to recognize the SPC900 and then use it to guide with open phd2. Following the Jean-Luc (geehalel) steps I could finally compile the kernel module and load it. However, once the module is loaded, I do not see any new video device file in the /dev directory. I only see the /dev/video0 device file associated to the webcam from the notebook, nothing else. Should I expect such a device file appear? If not, how can I access the camera?

I tried the phd2 with indi but again the only camera I see is the notebook embedded webcam.

Any help would be very appreciated.
6 years 11 months ago #5308

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
Hello,

Sorry for posting in this old thread, but I’m also facing issues with the LX tab from V4L2 driver with my modded SPC900NC and Ubuntu Mate (Raspberry Pi).

My moddification is the standard RTS from yesyes.info.
It works fine on Windows with K3ccdtools and also with AstroVideo, but I can only get non-black frames on Linux if I power off the USB to Serial converter (tested with 2 different FTDIs and both are enabled as /dev/ttyUSB0 and LED flases if I echo a command using the serial port).
I tried to play the bit options available on the tab, but couldn’t get it to work.

Could you please advise me how to configure the LX tab?

Thank you very much in advance for your time.

Best,
Andre
3 years 10 months ago #31796

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 1
Hey! Thanks to this topic ubuntu recogized my Logitech C920 (first one here ). Thanks again. I also found this topic stargazerslounge.com/topic/92140-spc900-lx-mod-how-to-use/ Hope it will help
Last edit: 1 year 1 month ago by Ewan Poole. Reason: upd
1 year 1 month ago #74191

Please Log in or Create an account to join the conversation.

Time to create page: 1.532 seconds