×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Altair 183m Hypercam

  • Posts: 43
  • Thank you received: 0
I downloaded Kstars Ekos 3.4.3 a couple of days ago running on my Linux Mint 19 desktop. Suddenly my Altair 183M fan only driver crashes. It has worked fine the last year or so so this is new. Thanks
Lou Zyla
2 years 3 months ago #58060

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic Altair 183m Hypercam

You're on stable or nightly PPA? Does it crash on nightly as well?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 months ago #58068

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0

Replied by Lou Zyla on topic Altair 183m Hypercam

Stable build
2 years 3 months ago #58072

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0

Replied by Lou Zyla on topic Altair 183m Hypercam

Okay I just tested it with the nightly build and it also crashed. The Altair Hypercam 183M driver comes back with repeated error messages, “The Indi driver crashed. Restart? Auto restart in secs”
Not a very informative error message, but when I go through my equipment profile I find everything is there except the Altair camera. I will send my log shortly.
The error is undefined symbol in indi_altair_ccd ZN4INDI7CCDChip8setFrameEiiiii
Lou
2 years 3 months ago #58094

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0

Replied by Lou Zyla on topic Altair 183m Hypercam

My log file.

Lou Zyla
2 years 3 months ago #58102
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
Hi, any input more on this topic?
(Planned to use Altair 183c with ekos/kstars)
Regards
2 years 2 months ago #58949

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0

Replied by Lou Zyla on topic Altair 183m Hypercam

No one has commented. I did some additional experiments. I ran the Windows version of Kstars with a Indi server on a RPI4 running Astroberry. This worked just fine with Altair driver stable. I am of course running the mono version. My problems may be because I was running Linux Mint 19 which is not quite Ubuntu and Mint has its own update cycle.
Lou



with Altair
2 years 2 months ago #58950

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by DeepSkyPhoto on topic Altair 183m Hypercam

Hello,

I have the same problem as yours.
All runs fine on my Ubuntu 20.04 laptop but I can't make it run on my Nafabox (tinkerboard with ubuntu 18.04). When I run indiserver -v indi_altair_ccd I get:

2020-10-04T17:26:29: startup: indiserver -v indi_altair_ccd
2020-10-04T17:26:29: Driver indi_altair_ccd: pid=3540 rfd=3 wfd=6 efd=7
2020-10-04T17:26:29: listening to port 7624 on fd 4
2020-10-04T17:26:29: Driver indi_altair_ccd: indi_altair_ccd: symbol lookup error: indi_altair_ccd: undefined symbol: _ZN4INDI7CCDChip8setFrameEiiii
Child process 3540 died

and indiserver exits after 10 attempts.

I run the latest stable version of indilib with libaltaircam.so.1.47.0 installed in /usr/lib/arm-linux-gnueabihf.

Have you solved your issue since your last post?

Kind regards.
Altair Hypercam 183M
Samyang 135 f/2
Skywatcher EQ3.2
NAFABox (Tinkerboard)
Last edit: 2 years 1 month ago by DeepSkyPhoto.
2 years 1 month ago #61205

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0

Replied by DeepSkyPhoto on topic Altair 183m Hypercam

Hi!
Finally I solved the issue after a complete uninstall/reinstall ;-)

Clear skies.
Altair Hypercam 183M
Samyang 135 f/2
Skywatcher EQ3.2
NAFABox (Tinkerboard)
2 years 1 month ago #61432

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0

Replied by Lou Zyla on topic Altair 183m Hypercam

Sorry my forum access has been broken the last few weeks. Finally today I was able to login. I gave up on the Kstars/indi/Ekos version for Linux Mint. Something broke ans I could ever fix it. Linux Mint is based on some earlier version of Ubuntu but has its own update cycle. I switched to ASTROBERRY ON MY Raspberry Pi 4 for my Indi server and use Kstars Ekos on Windows. That worked right away.
Lou
2 years 1 month ago #61895

Please Log in or Create an account to join the conversation.

Time to create page: 0.955 seconds