×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

INDI DSLRs FAQ

Replied by Jasem Mutlaq on topic INDI DSLRs FAQ

Hello Robert,

The process is more involved than that. Edit line 1579 in gphoto_driver.cpp and change it to something like this:
index = gp_port_info_list_lookup_path(portinfolist, "ip:192.168.1.12");

or make that "ptpip:192.168.1.12" .. then compile and install. Then run the indi_gphoto_ccd driver and put a break point at that link (#1579) and press Connect in the driver. It should take you there. See if the rest of the code works fine or if returns any error.

If it is indeed as simple as this, then we can add an IP address property to the driver and if non-empty then we use it there.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 7 months ago #49054

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0

Replied by Norman on topic INDI DSLRs FAQ

Hello fellow community :)

I know this is an old thread, but I just landed here searching for my problem.

If anyone is having problems taking images with a Nikon Z-series, and restarting everything does not help, there is a nice little detail about the mirrorless Nikons. When you unplug the power while the camera is on, the camera closes the mechanical front curtain (I have an external power-supply instead of the battery). The front curtain stays closed after the next power-on until you manually press the release button on the camera. While the mechanical shutter is closed the camera will not take any pictures or open the front curtain from software commands. You only recognize this in EKOS from capture errors and permanent retries.

A nice side effect is, that you protect your sensor from dust when you unplug the power after an imaging session :)
Gear: GM2000, TEC APO 160 FL, ASI6200MM, ASI290MM, Nikon Z7, RPI4
1 year 3 months ago #54821

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 3

Replied by Ettore on topic INDI DSLRs FAQ

I have big problems with Indi-canon, when I connect the 1300D everything is fine, but the configuration of the bits and pixels is wrong.
Here's what comes out..
INDI/KStars on Raspberry Pi 4, 4gb
Astroberry
Tecnosky 70ED F 4.8
Iexos 100 Mount
Nikon D5300 Camera
ZWO ASI120mm @260mm Guide Scope
PHD2
Arduino focuser
1 year 3 months ago #54981
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 3

Replied by Ettore on topic INDI DSLRs FAQ

Now instead without doing anything, it has gone to 16 bits!!!
INDI/KStars on Raspberry Pi 4, 4gb
Astroberry
Tecnosky 70ED F 4.8
Iexos 100 Mount
Nikon D5300 Camera
ZWO ASI120mm @260mm Guide Scope
PHD2
Arduino focuser
1 year 3 months ago #54982
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
I control my DSLR D7000 with my Macbook
My macbook is at home
My telescope outside.
I use a Belkin Home Base F5L049ea to connect SUB over IP my devices (DSLR + Mount)
I telescope is a Celestron C8 AS-GT.
I tried to used Ekos to capture :
- it works when DSLR is directly connected on USB of my Mac.
But it doesn’t work when I used my BELKIN USB over IP.
I tried with Smart Shooter 4 (in Trial). It works well.
By the way, Ekos works fine to control my Celestron C8 AS-GT mount.

I don’t know why it is not working on Ekos.
Do you use USB over IP with DSLR ? do you have to choose a special configuration for DSLR when using a device USB over IP between computer and DSLR ?
1 year 2 weeks ago #59452

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 3

Replied by Mike on topic INDI DSLRs FAQ

<strong>Hi Robert, Jasem

I pulled the code for the libgphoto2 (lumix) library and indi gphoto driver a few months ago, and after some learning (!) and a few modifications to both, I now have ekos/indi working with my Lumix GF7.
I'm running indi on a raspberry pi 4, and I can stream the live view, capture images in both raw and jpeg with my camera connected to my wifi lan.

Thanks for a great effort in pulling all this together!

I still have a couple of bugs to iron out before I commit the code, but I thought I would let you know in case someone else is working on this too.

The changes will need to be in both libgphoto2 and indi gphoto driver for this to work, and this is the first time I've committed anything to either of these projects so please let me know if there's anything I should be aware of.

Thanks
Mike</strong>
The following user(s) said Thank You: Jasem Mutlaq, Alfred, Jim
Last edit: 11 months 3 weeks ago by Mike.
11 months 3 weeks ago #60794

Please Log in or Create an account to join the conversation.

Replied by Jasem Mutlaq on topic INDI DSLRs FAQ

That's great to hear! Looking forward to the PR!
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
11 months 3 weeks ago #60842

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0

Replied by Richard Neel on topic INDI DSLRs FAQ

Chiming in to attempt to learn/understand a bit better. I'm both a Nikon full frame and Panasonic owner. I have both a GH4 and GH5s. I've been experimenting with the GH4 directly attached to to a Pi running ekos using gphoto. Much of this works on the GH4 but all that functions on the GH5s is firing the shutter which I assume is a fairly generic bit of functionality. I see there has been some development work on getting the Panasonic cameras functioning over wifi which is where I'm a bit confused. Why wifi? Isn't it much more straightforward to connect the cameras via USB as apparently. Is there something specific about the functionality of the GH5s that prevents it being supported via USB in gphoto? Could someone possibly clear up my confusion here and set me straight? I'd really like to use my M4/3 cameras to get a little extra focal length on my widefield scopes. The Nikon full frames are great but I'd just like the extra flexibility of using both.
11 months 3 weeks ago #60910

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 3

Replied by Mike on topic INDI DSLRs FAQ

The Lumix GF series cameras don't support USB tethering, as far as I know. Later models have WiFI for use with a smartphone App and cloud services.
Sorry I can't help with your GH5s question.
11 months 2 weeks ago #61025

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0

Replied by Richard Neel on topic INDI DSLRs FAQ

Ah, wasn't aware of that - makes sense. Anyone wanna work together or seeing if we can get the GH5s working in gphoto? I have a coding background and would be happy to use my camera for testing/development.
11 months 2 weeks ago #61032

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0

Replied by Roberto P. on topic INDI DSLRs FAQ

Hi everyone, I'm trying to connect my canon 650d to ekos, using the canon dslr indi drivers (i try gphoto driver too), but the only thing I get is that the camera is recognized but the connection remains with the yellow icon. if I try to specify a port in the right box and apply, nothing is entered in the left box.
If I try to take a photo with gphoto2 from command line it does it without problems.
I tried changing cables, changing ports, updating everything, removing auto-mount from the OS, but nothing.
My OS version is Ubuntu 18.04.5 LTS installed in an eeepc 1000h

In the ekos log file the only lines that refer to the canon are these:
[2020-10-22T10:45:29.974 CEST DEBG ][           org.kde.kstars.indi] - Received new device Canon DSLR EOS 650D
[2020-10-22T10:45:30.010 CEST DEBG ][           org.kde.kstars.indi] - INDIListener: New device Canon DSLR EOS 650D
[2020-10-22T10:45:30.010 CEST INFO ][           org.kde.kstars.ekos] - Ekos received a new device:  Canon DSLR EOS 650D
[2020-10-22T10:45:30.018 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < CONNECTION >
[2020-10-22T10:45:30.052 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < DRIVER_INFO >
[2020-10-22T10:45:30.065 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < POLLING_PERIOD >
[2020-10-22T10:45:30.074 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < DEBUG >
[2020-10-22T10:45:30.078 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < SIMULATION >
[2020-10-22T10:45:30.081 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < CONFIG_PROCESS >
[2020-10-22T10:45:30.084 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < ACTIVE_DEVICES >
[2020-10-22T10:45:30.097 CEST DEBG ][           org.kde.kstars.indi] - < Canon DSLR EOS 650D >: < DEVICE_PORT >

Anyone have any suggestions? Thank you :)
11 months 11 hours ago #61999

Please Log in or Create an account to join the conversation.

Time to create page: 0.558 seconds