×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

INDI doesn't recognize the new QHY Alccd 294 Mono Pro

  • Posts: 15
  • Thank you received: 1
Hi everybody, first post here.
I'm using KStars/Ekos for about 2 years with all (most of) its whistles and bells and I like it very much. Many thanks for all your work on that great piece of software!

Until now I used a Nikon D5300 DSLR as the imaging cam with KStars/Ekos. Now I received the new QHY Alccd 294 Mono Pro and a QHY filterwheel.
While trying to connect the cam, Ekos states that there are no QHY cams recognized in the system. But the cam is connected by USB.
ASCOM/Windows connects and controls the cam, so it seems to be ok.

Is the cam too new and we simply have to wait or are there any necessary actions from me to control that cam with Ekos?

Kind regards
Stefan
1 year 2 weeks ago #62873

Please Log in or Create an account to join the conversation.

What's the VID:PID of this camera?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 2 weeks ago #62877

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 1
Hi Jasem, thanks for your answer.
The output of lsusb when the cam is plugged in is

Bus 004 Device 006: ID 1618:c296

Regards
Stefan
Last edit: 1 year 2 weeks ago by Stefan. Reason: spelling
1 year 2 weeks ago #62882

Please Log in or Create an account to join the conversation.

I see 85-qhyccd.rules already has this camera:
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="1618", ATTRS{idProduct}=="c296", RUN+="/sbin/fxload -t fx3 -I /lib/firmware/qhy/QHY294PRO.img -D $env{DEVNAME}"

So if the firmware upload was successful, you should probably see 1618:c297 I believe

Does Alccd have different firmware file?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 2 weeks ago #62883

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 1
as far as I can see there is no /lib/firmware/qhy/QHY294PRO.img (just a QHY294.img in that path).
They mention 294 pro support in Version 20.08.26 ( www.qhyccd.com/html/prepub/log_en.html#!log_en.md ).
1 year 2 weeks ago #62885

Please Log in or Create an account to join the conversation.

Then you can use INDI nightly as it has this firmware image.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 2 weeks ago #62887

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 1
Thank you Jasem.
I'll try to switch to INDI nightly.
And I'm going to give a feedback here, if the new 294m is already controllable by INDI.
1 year 2 weeks ago #62888

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 1
Unfortunately the switch to INDI nightly fails on my system.
"sudo apt-add-repository ppa:mutlaqja/indinightly" gives
.
.
Err:10 ppa.launchpad.net/mutlaqja/ppa/ubuntu hirsute Release 404 Not Found [IP: 91.189.95.83 80]
Hit:9 minio.k-space.ee/armbian/apt bionic InRelease Reading package lists... Done
E: The repository 'ppa.launchpad.net/mutlaqja/ppa/ubuntu hirsute Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I never changed to INDI nightly builds before and don't know, what i'm doing wrong.

Regards
Stefan
1 year 2 weeks ago #62894

Please Log in or Create an account to join the conversation.

  • Posts: 283
  • Thank you received: 39
I have a similar (perhaps) problem where I can't now add ppa:mutlaqja/ppa on my Odroid-N2

I don't know enough to decode the last part of the error... Is the the install that's looking for armhf (whereas this machine is currently arm64)?
sudo apt-add-repository ppa:mutlaqja/ppa
 Latest INDI Library and drivers!
 
This PPA is for stable Ekos & INDI drivers releases.
 More info: https://launchpad.net/~mutlaqja/+archive/ubuntu/ppa
Press [ENTER] to continue or Ctrl-c to cancel adding it.
 
Hit:1 http://deb.odroid.in/n2 focal InRelease
Hit:2 http://archive.canonical.com/ubuntu focal InRelease           
Hit:3 http://ppa.launchpad.net/hardkernel/ppa/ubuntu focal InRelease
Hit:4 http://ports.ubuntu.com/ubuntu-ports focal InRelease
Hit:5 http://ports.ubuntu.com/ubuntu-ports focal-updates InRelease
Hit:6 http://ppa.launchpad.net/linuxgndu/sqlitebrowser/ubuntu focal InRelease
Hit:7 http://ports.ubuntu.com/ubuntu-ports focal-backports InRelease
Hit:8 http://ports.ubuntu.com/ubuntu-ports focal-security InRelease      
Hit:9 http://ppa.launchpad.net/mutlaqja/indinightly/ubuntu focal InRelease
Hit:10 http://ppa.launchpad.net/mutlaqja/libgphoto2/ubuntu focal InRelease
Hit:11 http://ppa.launchpad.net/mutlaqja/ppa/ubuntu focal InRelease
Hit:12 http://ppa.launchpad.net/pch/phd2/ubuntu focal InRelease
Reading package lists... Done                      
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://deb.odroid.in/n2 focal InRelease' doesn't support architecture 'armhf'
I can install the source code
mkdir -p ~/Projects
cd ~/Projects
#
# To begin get everthing   **********
git clone https://github.com/rlancaste/stellarsolver
git clone https://invent.kde.org/education/kstars.git
# or
# To update, just do a git pull
# cd ~/kstars
# git pull
cd ~/Projects
mkdir -p stellarsolver-build
#
cd ~/Projects/stellarsolver-build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo ../stellarsolver
make -j3
sudo make install
#
cd ~/Projects
mkdir -p kstars-build
#
cd ~/Projects/kstars-build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo ../kstars
make -j3
sudo make install
and am able to compile/run under QtCreator without a problem.
cd ~/Projects/kstars
git pull origin master
120 MM Skywatcher Esprit on Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube v2
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um. Triad Ultra Quad NB Filter
1) Odroid-N2 Ubuntu-mate 20.04 2) StellarMate on RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
1 year 2 weeks ago #62902

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 1
After a system update the port to INDI nightly was successful without errors:
sudo apt-add-repository ppa:mutlaqja/indinightly
sudo apt-get update
sudo apt-get install indi-full kstars-bleeding gsc

But there still iis no "/lib/firmware/qhy/QHY294PRO.img".
Do I have to do something else to get this image?

Regards
Stefan
1 year 1 week ago #63151

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 1
...and there is no entry for the cam in "./lib/udev/rules.d/885-qhyccd.rules" (like in Jasems):

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="1618", ATTRS{idProduct}=="c296", RUN+="/sbin/fxload -t fx3 -I /lib/firmware/qhy/QHY294PRO.img -D $env{DEVNAME}"
1 year 1 week ago #63155

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 1
Still trying to get the newest indi drivers without success. Changed to INDI nightly and these are my versions:

stefan@nanopim4:~$ sudo lsb_release -a
[sudo] password for stefan:
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic
stefan@nanopim4:~$ sudo apt-get install indi-full kstars-bleeding gsc
Reading package lists... Done
Building dependency tree
Reading state information... Done
gsc is already the newest version (1.3~ubuntu18.04.1).
indi-full is already the newest version (1.8.6~202008211454~ubuntu18.04.1).
kstars-bleeding is already the newest version (6:3.5.0+202008282324~ubuntu18.04.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Think, that isn't the latest INDI ?

Regards
Stefan
1 year 1 week ago #63262

Please Log in or Create an account to join the conversation.

Time to create page: 0.882 seconds