×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

kstars crashes when downloading an image captured with DSLR

  • Posts: 17
  • Thank you received: 2
Sorry for the delay with the logs. Because of some of the earlier issues, I decided to reimage my system entirely. Once I had a fresh install in place, I changed to the Beta channel and ran all the updates I could find from Package Updater. I rebuild my Profile and have everything set up fresh. Still getting the driver crash notice I mentioned before when I start my profile in Ekos. Attached is the log. I have tried to run the DSLR test and it just fails.

File Attachment:

File Name: devicemanager.txt
File Size:4 KB
Christopher Miller

WO GT71 / ZWO 183MC Pro / ZWO EAF / WO Uniguide 50mm / ZWO 290MM Mini / EQ6-R Pro
Meade 8" LX90 / ZWO 224MC / RigelSystems wifi-nFocus / ZWO OAG / ZWO 290MM Mini / Meade EQWedge
AF-S Nikkor 70-300mm Lens / Nikon Z6 / ZWO 30F4 MiniScope / ZWO 120mm Mini / Star Adventurer 2i
2 months 2 weeks ago #67010
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 2
Here's an additional log file. Hope it is helpful!

File Attachment:

File Name: log_13-55-52.txt
File Size:55 KB


From this - it seems maybe the issue has to do with the follow from the log:
[2021-02-06T13:56:17.164 EST DEBG ][           org.kde.kstars.indi] - Adding managed driver "Nikon DSLR"
[2021-02-06T13:56:17.165 EST DEBG ][           org.kde.kstars.indi] - Starting INDI Driver  "indi_nikon_ccd"
[2021-02-06T13:56:17.191 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: start indi_nikon_ccd"
[2021-02-06T13:56:17.191 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: Starting driver indi_nikon_ccd"
[2021-02-06T13:56:17.192 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T18:56:17: Driver indi_nikon_ccd: pid=2453 rfd=10 wfd=24 efd=25"
[2021-02-06T13:56:17.193 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T18:56:17: Driver indi_nikon_ccd: indi_nikon_ccd: error while loading shared libraries: libraw.so.20: cannot open shared object file: No such file or directory"
[2021-02-06T13:56:17.193 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T18:56:17: Driver indi_nikon_ccd: stderr EOF"
[2021-02-06T13:56:17.194 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "Child process 2453 died"
[2021-02-06T13:56:17.195 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T18:56:17: Driver indi_nikon_ccd: Terminated after #0 restarts."
[2021-02-06T13:56:17.195 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2021-02-06T13:56:17.195 EST CRIT ][           org.kde.kstars.indi] - INDI driver  "indi_nikon_ccd"  crashed!
[2021-02-06T13:56:18.392 EST DEBG ][           org.kde.kstars.indi] - Removing managed driver "Nikon DSLR"
[2021-02-06T13:56:18.393 EST DEBG ][           org.kde.kstars.indi] - Stopping INDI Driver  "indi_nikon_ccd"

I ran the following command to determine what version I have installed based on some other searches on the forum:
stellarmate@stellarmate:~ $ find /usr | grep libraw
/usr/lib/arm-linux-gnueabihf/libraw_r.so.21
/usr/lib/arm-linux-gnueabihf/libraw.so.21
/usr/lib/arm-linux-gnueabihf/libraw_r.so.21.0.0
/usr/lib/arm-linux-gnueabihf/libraw1394.so.11.1.0
/usr/lib/arm-linux-gnueabihf/libraw.so.21.0.0
/usr/lib/arm-linux-gnueabihf/libraw1394.so.11
/usr/lib/arm-linux-gnueabihf/vlc/plugins/demux/librawaud_plugin.so
/usr/lib/arm-linux-gnueabihf/vlc/plugins/demux/librawvid_plugin.so
/usr/lib/arm-linux-gnueabihf/vlc/plugins/demux/librawdv_plugin.so
/usr/lib/arm-linux-gnueabihf/vlc/plugins/codec/librawvideo_plugin.so
/usr/share/doc/libraw20
/usr/share/doc/libraw20/changelog.Debian.gz
/usr/share/doc/libraw20/copyright
/usr/share/doc/libraw20/changelog.gz
/usr/share/doc/libraw1394-11
/usr/share/doc/libraw1394-11/changelog.Debian.gz
/usr/share/doc/libraw1394-11/copyright
/usr/share/doc/libraw1394-11/AUTHORS
/usr/share/doc/libraw1394-11/NEWS.gz
/usr/share/doc/libraw1394-11/README.Debian
/usr/share/doc/libraw1394-11/README
/usr/share/doc/libraw1394-11/changelog.Debian.armhf.gz
/usr/share/doc/libraw1394-11/changelog.gz
stellarmate@stellarmate:~ $

From that point - additional searches here on the forum lead me to run the following:
stellarmate@stellarmate:~ $ cd /usr/lib/arm-linux-gnueabihf/
stellarmate@stellarmate:/usr/lib/arm-linux-gnueabihf $ sudo ln -s libraw.so.21.0.0 libraw.so.20
stellarmate@stellarmate:/usr/lib/arm-linux-gnueabihf $ sudo ldconfig
ldconfig: file /usr/lib/arm-linux-gnueabihf/libmtpricoh.so.9 is truncated
 
ldconfig: file /usr/lib/arm-linux-gnueabihf/libRicohCameraSDKCpp.so.1.1.0 is truncated
 
ldconfig: file /usr/lib/arm-linux-gnueabihf/libRicohCameraSDKCpp.so is truncated
 
ldconfig: file /usr/lib/arm-linux-gnueabihf/libmtpricoh.so is truncated
 
ldconfig: file /usr/lib/arm-linux-gnueabihf/libmtpricoh.so.9.3.0 is truncated
 
ldconfig: file /usr/lib/arm-linux-gnueabihf/libRicohCameraSDKCpp.so.1 is truncated
 
stellarmate@stellarmate:/usr/lib/arm-linux-gnueabihf $ 

After running that, now the error that is being returned in the log is as follows:
[2021-02-06T14:22:26.156 EST DEBG ][           org.kde.kstars.indi] - Adding managed driver "Nikon DSLR"
[2021-02-06T14:22:26.156 EST DEBG ][           org.kde.kstars.indi] - Starting INDI Driver  "indi_nikon_ccd"
[2021-02-06T14:22:26.157 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: start indi_nikon_ccd"
[2021-02-06T14:22:26.158 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: Starting driver indi_nikon_ccd"
[2021-02-06T14:22:26.158 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2021-02-06T14:22:26.159 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T19:22:26: Driver indi_nikon_ccd: pid=2678 rfd=10 wfd=24 efd=25"
[2021-02-06T14:22:26.160 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2021-02-06T14:22:26.259 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T19:22:26: Driver indi_nikon_ccd: indi_nikon_ccd: symbol lookup error: indi_nikon_ccd: undefined symbol: _ZN6LibRaw9open_fileEPKcx"
[2021-02-06T14:22:26.260 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T19:22:26: Driver indi_nikon_ccd: stderr EOF"
[2021-02-06T14:22:26.260 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-02-06T19:22:26: Driver indi_nikon_ccd: Terminated after #0 restarts."
[2021-02-06T14:22:26.263 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  "Child process 2678 died"
[2021-02-06T14:22:26.264 EST DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2021-02-06T14:22:26.265 EST CRIT ][           org.kde.kstars.indi] - INDI driver  "indi_nikon_ccd"  crashed!
[2021-02-06T14:22:27.096 EST DEBG ][           org.kde.kstars.indi] - Removing managed driver "Nikon DSLR"
Christopher Miller

WO GT71 / ZWO 183MC Pro / ZWO EAF / WO Uniguide 50mm / ZWO 290MM Mini / EQ6-R Pro
Meade 8" LX90 / ZWO 224MC / RigelSystems wifi-nFocus / ZWO OAG / ZWO 290MM Mini / Meade EQWedge
AF-S Nikkor 70-300mm Lens / Nikon Z6 / ZWO 30F4 MiniScope / ZWO 120mm Mini / Star Adventurer 2i
Last edit: 2 months 2 weeks ago by cgmiller.
2 months 2 weeks ago #67012
Attachments:

Please Log in or Create an account to join the conversation.

Thanks, I found the issue with libraw. Apparently, v21 is now available and I'll switch the build to it. Beta should be updated later tonight.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: jiberjaber, cgmiller
2 months 2 weeks ago #67048

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 2

knro wrote: Thanks, I found the issue with libraw. Apparently, v21 is now available and I'll switch the build to it. Beta should be updated later tonight.


Thanks Jasem. I’ll update as soon as it’s available, test, and update with the outcome. Greatly appreciate the help and all the work on StellarMate. It’s a great tool!


Sent from my iPhone using Tapatalk
Christopher Miller

WO GT71 / ZWO 183MC Pro / ZWO EAF / WO Uniguide 50mm / ZWO 290MM Mini / EQ6-R Pro
Meade 8" LX90 / ZWO 224MC / RigelSystems wifi-nFocus / ZWO OAG / ZWO 290MM Mini / Meade EQWedge
AF-S Nikkor 70-300mm Lens / Nikon Z6 / ZWO 30F4 MiniScope / ZWO 120mm Mini / Star Adventurer 2i
2 months 2 weeks ago #67049

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 2
Here's the latest: I've run all the updates and now kstars won't launch. I've rebooted a few times, but it's refusing to launch. I get a spinning hourglass for a few seconds and then nothing.
stellarmate@stellarmate:~ $ kstars
kstars: error while loading shared libraries: libraw.so.21: cannot open shared object file: No such file or directory
stellarmate@stellarmate:~ $ 

And here's the info being reported on libraw after updates:
stellarmate@stellarmate:~ $ find /usr | grep libraw
/usr/lib/arm-linux-gnueabihf/libraw_r.so.20
/usr/lib/arm-linux-gnueabihf/libraw.so.20
/usr/lib/arm-linux-gnueabihf/libraw1394.so.11.1.0
/usr/lib/arm-linux-gnueabihf/libraw1394.so.11
/usr/lib/arm-linux-gnueabihf/libraw_r.so.20.0.0
/usr/lib/arm-linux-gnueabihf/libraw.so.20.0.0
/usr/lib/arm-linux-gnueabihf/vlc/plugins/demux/librawaud_plugin.so
/usr/lib/arm-linux-gnueabihf/vlc/plugins/demux/librawvid_plugin.so
/usr/lib/arm-linux-gnueabihf/vlc/plugins/demux/librawdv_plugin.so
/usr/lib/arm-linux-gnueabihf/vlc/plugins/codec/librawvideo_plugin.so
/usr/share/doc/libraw20
/usr/share/doc/libraw20/changelog.Debian.gz
/usr/share/doc/libraw20/copyright
/usr/share/doc/libraw20/changelog.gz
/usr/share/doc/libraw1394-11
/usr/share/doc/libraw1394-11/changelog.Debian.gz
/usr/share/doc/libraw1394-11/copyright
/usr/share/doc/libraw1394-11/AUTHORS
/usr/share/doc/libraw1394-11/NEWS.gz
/usr/share/doc/libraw1394-11/README.Debian
/usr/share/doc/libraw1394-11/README
/usr/share/doc/libraw1394-11/changelog.Debian.armhf.gz
/usr/share/doc/libraw1394-11/changelog.gz
stellarmate@stellarmate:~ $ 

I tried to run sudo apt-get install libraw21. That updates libraw, but that action removes kstars:
The following packages will be REMOVED:
  indi-full indi-gphoto indi-pentax kstars-bleeding kstars-bleeding-dbg libraw20
The following NEW packages will be installed:
  libraw21
.....
stellarmate@stellarmate:~ $ kstars
bash: /usr/bin/kstars: No such file or directory
stellarmate@stellarmate:~ $ 

If I reinstall kstars with sudo apt-get install indi-full kstars-bleeding I get the following notice during install:
The following packages will be REMOVED:
  libraw21
The following NEW packages will be installed:
  indi-full indi-gphoto indi-pentax kstars-bleeding kstars-bleeding-dbg
  libraw20

So it seems I'm stuck right now. I'll be the first to admit I may be missing something or not executing the proper commands - I'm very new to all this. Just know enough to be dangerous with google. :)
Christopher Miller

WO GT71 / ZWO 183MC Pro / ZWO EAF / WO Uniguide 50mm / ZWO 290MM Mini / EQ6-R Pro
Meade 8" LX90 / ZWO 224MC / RigelSystems wifi-nFocus / ZWO OAG / ZWO 290MM Mini / Meade EQWedge
AF-S Nikkor 70-300mm Lens / Nikon Z6 / ZWO 30F4 MiniScope / ZWO 120mm Mini / Star Adventurer 2i
Last edit: 2 months 2 weeks ago by cgmiller. Reason: Adding additional details
2 months 2 weeks ago #67076

Please Log in or Create an account to join the conversation.

I've reverted libraw21, and going to rebuild everything back on libraw20
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: cgmiller
2 months 2 weeks ago #67078

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 2
I've installed the update. Kstars is now loading again, but I'm right back to Ekos / kstars crashing every time I try to either loop frames or capture a preview in the Capture Module.

The last entry in the log files is either [ org.kde.kstars.ekos.capture] - "Starting framing..." or [ org.kde.kstars.ekos.capture] - Preparing capture job "/home/stellarmate/Pictures/Light" for execution.

I'll attach the log files for review.

File Attachment:

File Name: log_17-05-41.txt
File Size:775 KB

File Attachment:

File Name: log_17-03-35.txt
File Size:803 KB
Christopher Miller

WO GT71 / ZWO 183MC Pro / ZWO EAF / WO Uniguide 50mm / ZWO 290MM Mini / EQ6-R Pro
Meade 8" LX90 / ZWO 224MC / RigelSystems wifi-nFocus / ZWO OAG / ZWO 290MM Mini / Meade EQWedge
AF-S Nikkor 70-300mm Lens / Nikon Z6 / ZWO 30F4 MiniScope / ZWO 120mm Mini / Star Adventurer 2i
2 months 1 week ago #67091
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 2
I've been installing the nightly builds daily and re-testing each time. I'm still having the same issue of the program just crashing fully if I try to loop or capture a preview in the Capture Module. Looping & Preview work fine in the Focus module. Could this be an issue with the FITS viewer? It doesn't get invoked in Focus - the image appears in the built-in window. The error logs don't appear to provide any reason for the crash that I can see - but hopefully smarter minds will see the problem. At this point it has me unable to effectively use StellarMate with my Nikon Z6 setup. Any help toward resolution would be appreciated!

File Attachment:

File Name: indi_nikon....log.txt
File Size:16 KB

File Attachment:

File Name: log_08-37-10.txt
File Size:463 KB
Christopher Miller

WO GT71 / ZWO 183MC Pro / ZWO EAF / WO Uniguide 50mm / ZWO 290MM Mini / EQ6-R Pro
Meade 8" LX90 / ZWO 224MC / RigelSystems wifi-nFocus / ZWO OAG / ZWO 290MM Mini / Meade EQWedge
AF-S Nikkor 70-300mm Lens / Nikon Z6 / ZWO 30F4 MiniScope / ZWO 120mm Mini / Star Adventurer 2i
2 months 3 days ago #67555
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 247
  • Thank you received: 27
Hi,
Just checked my Z7 again. It still works when I ask for a FITS preview.
This is with FITS using Auto Stretch, Auto Debayer, Auto WCS and Auto Compute HFR.
I have 4G RAM and 2 G ZRAM.
Although I just tried it a 2nd time and had KStars crash (while I am compiling KStars from source at the same time). I'm pretty certain it just ran out of RAM. This compile is using -J2. With -J3 the compiler will eventually abort with what I believe are memory issues, even if KStars isn't running.
I noticed I don't get a nikon specific log file matching what you provided. I have Ekos INDI, Capture and the CCD driver logs enabled.

Cheers
120 MM Skywatcher Esprit on Celestron CGX, ZWO ASI 224MC guiding, Pegasus FocusCube v2
Nikon Z7 8256 x 5504, 35.9 x 23.9mm 4.34 um. Triad Ultra Quad NB Filter
1) Odroid-N2 Ubuntu-mate 20.04 2) StellarMate on RPI4 8G
The good, the bad, the ugly at sciencedowneast.no-ip.ca/zenphoto/
The following user(s) said Thank You: cgmiller
2 months 3 days ago #67560

Please Log in or Create an account to join the conversation.

cgmiller wrote: I've been installing the nightly builds daily and re-testing each time. I'm still having the same issue of the program just crashing fully if I try to loop or capture a preview in the Capture Module. Looping & Preview work fine in the Focus module. Could this be an issue with the FITS viewer? It doesn't get invoked in Focus - the image appears in the built-in window. The error logs don't appear to provide any reason for the crash that I can see - but hopefully smarter minds will see the problem. At this point it has me unable to effectively use StellarMate with my Nikon Z6 setup. Any help toward resolution would be appreciated!

File Attachment:

File Name: indi_nikon....log.txt
File Size:16 KB

File Attachment:

File Name: log_08-37-10.txt
File Size:463 KB


I still cannot reproduce such crashes. Please submit a ticket to StellarMate and prepare Teamviewer access.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 3 days ago #67561

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 2
I have TeamViewer access installed already.

Ticket Created: RPXS-001124
Christopher Miller

WO GT71 / ZWO 183MC Pro / ZWO EAF / WO Uniguide 50mm / ZWO 290MM Mini / EQ6-R Pro
Meade 8" LX90 / ZWO 224MC / RigelSystems wifi-nFocus / ZWO OAG / ZWO 290MM Mini / Meade EQWedge
AF-S Nikkor 70-300mm Lens / Nikon Z6 / ZWO 30F4 MiniScope / ZWO 120mm Mini / Star Adventurer 2i
Last edit: 2 months 3 days ago by cgmiller.
2 months 3 days ago #67562

Please Log in or Create an account to join the conversation.

  • Posts: 54
  • Thank you received: 0
I tried my Z6 some time back and the only issue I had was with the ISO setting not working.

I've just prep'ed a SD card to set up a 3B+ to try on the Z6 (my RPI4 is on my main scope). I'm interested in using the focus directly on the Z6 from Stellarmate, if this works I'll be quite happy!
2 months 1 hour ago #67685

Please Log in or Create an account to join the conversation.

Time to create page: 0.510 seconds