×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

Avoiding Sony A7S star-eating problem using manual mode instead of BULB

  • Posts: 16
  • Thank you received: 1
Hi guys,

Many good affordable common Sony camera's (like my A7S) have a problem where the data gets filtered in-camera, eating up many tiny wanna-be stars. This only occurs in BULB mode. In manual mode this problem is absent. It's well-documented and in fact in the last four years about 10,000 signed this petition for Sony to address it (www.change.org/p/sony-remove-the-star-ea...-i-ii-and-a9-cameras) but it didn't happen.

I assume Sony will never fix it. It would be real nice if KStars could use the manual (M) mode instead of the BULB mode. Currently it is advised against it here: indilib.org/ccds/gphoto.html (section Exposure Modes). Indeed when I test with M mode and Ekos it behaves badly. Could somebody fix this? I would love to file the bug report, help test and debug. Unfortunately I don't develop in C myself.

I have tested with another program called AstroDSLR which shares some code with KStars. AstroDSLR is capable to use the M mode so I'm hoping KStars will do too.

Cheers,
Jurgen
3 months 2 weeks ago #68116

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
Thanks Jurgen to join my request to debug A7S driver.
To add some details, I would say that M mode is possible but when switching to non Bulb mode, capturing an image will result on a faulty situation. The first image will be ok but the second one is still the first, the third one is the second and so on. This situation avoid using autofocus and astrometry since Kstar is not analyzing the good image.
In the last version of indi and gphoto driver, I notice that in fact when using "RAW" mode the capture download "RAW + JPG". This situation leads to use RAW for the first shoot and JPG for the second, introducing a gap between gphoto driver and Kstar.
I open 2 bugs in github here github.com/indilib/indi-3rdparty/issues/339 and here github.com/gphoto/libgphoto2/issues/630

Like Jurgen I'm not skilled to debug myself the driver code, but I can contribute doing test sessions.

Joseph
Mount : Avalon Fast Linear
FSQ 106 + Lakerside focuser
CCD : QHY290 MM Cool Guider : QHY5L-II
DSRL : Sony A7S Baader Mooded
Last edit: 3 months 2 weeks ago by Ferraro.
3 months 2 weeks ago #68125

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 1
I guess this would be a nice thread for posting on the "wish list" in this forum and as a feature request of the github issue tracker. Sorry for cross posting.
3 months 2 weeks ago #68233

Please Log in or Create an account to join the conversation.

Time to create page: 0.334 seconds