×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Problem with ASI 1600MM on remote RPI

  • Posts: 55
  • Thank you received: 2
Hello,I am experiencing a problem with following setup:RPI with Indi-web and Indi latest git version connected to Camera, scope, etc.MacBook Air tested with  Kstars 3.5.2 stable and 3.5.3 beta. When you start the profile in Kstars, all devices appear and everything looks ok.When you now enter a temperature (e.g: -20) the status line in Kstars states cooler on, while the camera states failed to activate cooler.The camera does not cool down.... .
Has anyone experience similar  behavior ? See here: [2021-03-24T16:25:43.765 CET INFO ][   org.kde.kstars.ekos.capture] - "Cooler is on"[2021-03-24T16:25:43.779 CET DEBG ][           org.kde.kstars.indi] - < ZWO CCD ASI1600MM Pro >: < CCD_CONTROLS >[2021-03-24T16:25:43.782 CET DEBG ][           org.kde.kstars.indi] - < ZWO CCD ASI1600MM Pro >: < CCD_CONTROLS_MODE >[2021-03-24T16:25:43.783 CET DEBG ][           org.kde.kstars.indi] - < ZWO CCD ASI1600MM Pro >: < CCD_VIDEO_FORMAT >[2021-03-24T16:25:43.785 CET DEBG ][           org.kde.kstars.indi] - < ZWO CCD ASI1600MM Pro >: < BLINK >[2021-03-24T16:25:43.785 CET DEBG ][           org.kde.kstars.indi] - < ZWO CCD ASI1600MM Pro >: < ADC_DEPTH >[2021-03-24T16:25:43.786 CET DEBG ][           org.kde.kstars.indi] - < ZWO CCD ASI1600MM Pro >: < SDK > [2021-03-24T16:26:04.832 CET INFO ][   org.kde.kstars.ekos.capture] - "Cooler is on". <
this is where I entered -20[2021-03-24T16:26:04.849 CET INFO ][           org.kde.kstars.indi] - ZWO CCD ASI1600MM Pro :  "[ERROR] Failed to activate cooler. "[    
iOptron CEM25P
Skywatcher Evostar 72 ED DSPro
Explore Scientific ED 102
ASI 1600Mm Pro ASI EFW Mini
QHY 8L
DeepSky Dad AF1 motor focus
ASI 120MM Mini and Bresser (Touptek) 290 Guidecams
Sykwatch EvoGuide 50/242 and NoName 50/175 Guidescopes
Raspberry Pi 3 and 4
1 year 6 months ago #69208

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 2
Hello,
just directly on the Raspberry PI, the result is the same.

Regards

Dirk
iOptron CEM25P
Skywatcher Evostar 72 ED DSPro
Explore Scientific ED 102
ASI 1600Mm Pro ASI EFW Mini
QHY 8L
DeepSky Dad AF1 motor focus
ASI 120MM Mini and Bresser (Touptek) 290 Guidecams
Sykwatch EvoGuide 50/242 and NoName 50/175 Guidescopes
Raspberry Pi 3 and 4
1 year 6 months ago #69209

Please Log in or Create an account to join the conversation.

Power to camera OK?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 6 months ago #69214

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 2
Power is ok and camera is cooling to 0 degrees, it is just not possible to set other values. This applies to both, the camera tab Kstars as well as the Indi driver gui .

Regards
Dirk
iOptron CEM25P
Skywatcher Evostar 72 ED DSPro
Explore Scientific ED 102
ASI 1600Mm Pro ASI EFW Mini
QHY 8L
DeepSky Dad AF1 motor focus
ASI 120MM Mini and Bresser (Touptek) 290 Guidecams
Sykwatch EvoGuide 50/242 and NoName 50/175 Guidescopes
Raspberry Pi 3 and 4
1 year 6 months ago #69222

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 2
Hello Jasem, could that be a type Problem?
the return value of bool ASICCD::activateCooler(bool enable) is of type ASI_ERROR_CODE which is more like an int type...

Especially ASI_SUCCESS should be 0 (?) which would translate to false.
That would explain as well, why I see only 1 "Failed to activate cooler." in the logs, it should be 2 entries, not from SetTemperature and one from activateCooler... .

I will check that later today...


Regards

Dirk
iOptron CEM25P
Skywatcher Evostar 72 ED DSPro
Explore Scientific ED 102
ASI 1600Mm Pro ASI EFW Mini
QHY 8L
DeepSky Dad AF1 motor focus
ASI 120MM Mini and Bresser (Touptek) 290 Guidecams
Sykwatch EvoGuide 50/242 and NoName 50/175 Guidescopes
Raspberry Pi 3 and 4
1 year 6 months ago #69287

Please Log in or Create an account to join the conversation.

Dirk,

Good catch, I just submitted a fix. Can you please update from GIT and check again?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 6 months ago #69290

Please Log in or Create an account to join the conversation.

  • Posts: 55
  • Thank you received: 2
I already checked successfully with my "version", which was almost the same as yours. I was trying to submit a pull request, but you were faster....

Thank you....

Regards

Dirk
iOptron CEM25P
Skywatcher Evostar 72 ED DSPro
Explore Scientific ED 102
ASI 1600Mm Pro ASI EFW Mini
QHY 8L
DeepSky Dad AF1 motor focus
ASI 120MM Mini and Bresser (Touptek) 290 Guidecams
Sykwatch EvoGuide 50/242 and NoName 50/175 Guidescopes
Raspberry Pi 3 and 4
1 year 6 months ago #69291

Please Log in or Create an account to join the conversation.

Time to create page: 0.246 seconds