×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Problems connecting QHY268C (different IDs on Raspberry and Odroid)

  • Posts: 87
  • Thank you received: 9
Hello,
I stucked into the following problem:
I wanted to set up an Odroid system with Kstars, EKOS, INDI... Regarding the setup I followed the instructions from Jerry:

www.indilib.org/forum/ekos/5333-setting-...use-kstars-ekos.html

So yesterday I tried a "dryrun" of the system (kstars 3.5.2, indi 1.8.9) with my ASI290 mini, QHY268C and telescope simulator. The ASI camera was connected without problems, but the QHY wasnt found. So I checked per lsusb, which shows an entry for the QHY. But it was not found by kstars. I also tried different USB ports, connected it before or after starting the odroid, no change.

Today I tried an update to kstars 3.5.3 and indi 1.9.0, but still the same. So again I checked lsusb and dmesg (which I didnt checked yesterday) with the following result (see dmesg_lsusb_ODROID.png).
 

I was wondering about the "unsupported device" in the dmesg! Since the QHY worked on Stellarmate and Astroberry with Raspberry Pi4B 4GB I connected the QHY on the Raspi with the following result (see dmesg_lsusb_RASPI.png):
 

There are some differences: on the Raspi the QHY is listed in lsusb as ID1618:C269, on Odroid as ID1618:c268! In dmesg the c268 can also be seen in the Raspi, but after that the 1618:c269 is connected.

Can anybody give me advice whats going wrong here? The setup works on two different Raspberrys in the same way. What is wrong in the Odroid setup?

CS

Jürgen
 
1 year 3 weeks ago #70916
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 108
  • Thank you received: 19
Ji Jürgen,

I had the same problem with my QHY183C.
I installed lasted sdk from qhy for the camera and installed the sdk (it installs fxload file in /sbin also)
see this discussion about an another qhy camera (www.indilib.org/forum/ccds-dslrs/8161-in...ono-pro.html?start=0).

Clear skies
----
ES ED 127mm FCD100, AZEQ6 GT, FocusLynx ESX25, Nikon D800 , ASI120mm-s, Polemaster
-- RPi4 4Gb Stellarmate , Windows 10 Pro, Kstars/VNC
-- RPi4 8Gb Ubuntu mate 20.04.1 LTS - Kstars/NoMachine
The following user(s) said Thank You: Juergen
1 year 3 weeks ago #70918

Please Log in or Create an account to join the conversation.

  • Posts: 87
  • Thank you received: 9
Hi. Thank you for your reply :-) Now it works, kstars connects to the QHY! I took some frames, works well. But in dmesg there are still some weired comments: 
 

"unsupported device"... I reinstalled the current qhy-files from the official repo from Jasem, because I thought I overwrote something due to the SDK installation, but no change. Maybe I dont have to worry, but would be good to know whats going on...
1 year 3 weeks ago #70920
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 1.136 seconds