×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

plate-solving fails after upgrade to KStars/Ekos 3.5.4 stable [SOLVED - somehow]

  • Posts: 62
  • Thank you received: 14
I recently upgraded to kstars 3.5.4 stable and now I cannot plate-solve anymore.

I am using astrometry local on an astroberry and installed astrometry-data-2mass and astrometry-data-tycho for all the data files. 
After exposing a frame and downloading it, I am able to platesolve that image doing:

$ solve-field name-of-frame.fits.

Unfortunately, I seem not to be able to get Ekos to solve that image. I enabled debugging infos for astrometry and plate-solving and are now able to see the invocation that is done for solve-field:
It looks something like this (I already modifies this one a bit, this is here so you can get the picture):

/usr/bin/solve-field -O --no-plots --no-verify --crpix-center --match none --corr none --new-fits none --rdls none --resort --odds-to-solve 1e+09 --odds-to-tune-up 1e+06 -L 1.47357 -H 2.21036 -u arcsecperpix -3 0.184083 -4 89.8773 -5 15 -v --backend-config /tmp/externalSextractorSolver_1.cfg --cancel /tmp/externalSextractorSolver_1.cancel -W /tmp/externalSextractorSolver_1.wcs --keep-xylist /tmp/externalSextractorSolver_1.xyls 

Unfortunately with this, I am not able to reproduce the call and the configuration, as the /tmp/* files get deleted after the invocation. So I resorted to deleteing parameters and in the end, I was able to determine, that the given "-L 1.47357 -H 2.21036 -u arcsecperpix" seems to be the culprit. As you might have guessed, from a lot of user questions and advice you can glean from this forum, these have to do with pixel sizes and focal lengthes. 

My Google-fu was not good enough to turn up a page, that explains, what I now need to enter as focal length and pixel sizes. If you give me a hand in this, I would appreciate that. 

Here now are my requests:
  1. Could you make it so, that the invocation of solve-field can be copied verbatim and then be run on the command line, so one can reinvoke it?
  2. There are options to "ignore scale" and "ignore position", could you also provide a "ignore pixel size & focal length" configuration option? This would at best give some indication which settings to correct, to be able to invoke it next time with these options. I was not able to configure this from the forms that I looked at (see above).
  3. If and when the solver fails, could you just run solve-field with-out any of the optimization options, so that it would at least solve?
Judging from the entries in the forum, this seems to be one of biggest obstacles for people to get plate-solving to work. And personally it has cost me at least one of the precious clear sky nights, that we had. 
Thanks, Grimaldi
 
Last edit: 1 month 2 weeks ago by Grimaldi.
1 month 2 weeks ago #75134

Please Log in or Create an account to join the conversation.

  • Posts: 62
  • Thank you received: 14
Calculating parameters -L and -H myself for my ASI224mc, yields different values than the ones used by Ekos:

The cam has a pixel pitch of 3,75µm and 1396x976 pixel², given the calculated field of view of 81.4'x60.9' (as displayed, when selecting the right telescope in the align module), this gives a scale factor of ~3.75 arcsecperpix. So when invoked like this (modified command from above):

/usr/bin/solve-field -O --no-plots --no-verify --crpix-center --match none --corr none --new-fits none --rdls none --resort --odds-to-solve 1e+09 --odds-to-tune-up 1e+06 -L 3.7 -H 3.8 -u arcsecperpix -3 0.184083 -4 89.8773 -5 15 -v

This command is able to solve!!
So something seems to be wrong with the scale calculation. See the attached screen shot.

How can I now hot-fix this, so I can use the alignment module?
1 month 2 weeks ago #75140
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 705
  • Thank you received: 322
I believe you are asking (paraphrasing):  "I know the problem in the code, how can I re-compile the code so that my solving works".

If so, the commands to solve-field are inside the StellarSolver package.
I took a quick look, and it looks like inside the file stellarsolver/externalsextractorsolver.cpp
You'd need to clone StellarSolver from github, make your changes to StellarSolver, compile and install it, then recompile KStars
(probably best to remove the KStars binary so that it is forced to re-link with StellarSolver).

You can find StellarSolver here:
github.com/rlancaste/stellarsolver

Follow Rob's instructions at the bottom of that page for cloning/compiling/installing.

KStars compile instructions are in the README at the bottom of the KStars git page:
invent.kde.org/education/kstars

You could run with latest Indi, which you've likely already have.

Hy
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
1 month 2 weeks ago #75142

Please Log in or Create an account to join the conversation.

  • Posts: 62
  • Thank you received: 14
Thanks Hy, I was more looking into how to get the rig running fast, as one of the rare clear sky nights is happening. If necessary I will get into git and recompiling. I am determined to get it running.

Now 5 seconds ago, while I am typing, a solve happened and the mount moved!
1 month 2 weeks ago #75143

Please Log in or Create an account to join the conversation.

  • Posts: 62
  • Thank you received: 14
In hindsight and with-out being able to prove it, I believe the key to get it working was in the „Align Options Profiles Editor“ to click on the „down circumflex“ to discard custom settings. See screen shot 

 
]
 
1 month 2 weeks ago #75156
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.289 seconds