INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

getProperties returns EOF

  • Posts: 3
  • Thank you received: 1
I have a long list of drivers that I have developed in C over the years starting in the early Elwood Downey days. I just installed a new fresh ubuntu 22.04 and the latest indi from the mutlaqja PPA.. My drivers build okay.. I had to change some include paths.. no biggie. When I run them in indiserver and connect using phd2 or xephem, they don't show up in the list of drivers.

Here is my tests so far

First I started indiserver:
indiserver ./indi_vatt_guide

While indiserver was still running I used netcat and did this:
echo \<getProperties version="1.5"/\> | nc localhost 7624

netcat returns:
indi_vatt_guide: EOF

So I stopped the indiserver and tried running it standalone. I tried this:
echo \<getProperties version="1.5"/\> | ./indi_vatt_guide

again I got back
indi_vatt_guide: EOF

I tried changing "version=1.5" to "version=1.7", I repeated the above tests, and got the same results.

I tried with a few of the bundled 3rd party drivers and they all worked... so I wasn't sure what to do.

I had a similar issue a few months back on the raspberry pi that a fresh build of indi solved... so I downloaded indi and indi_3rdparty from github and built fresh. My drivers now work... I didn't have to rebuild my drivers... they just worked correctly with the freshly built libindi(1.9.7). Could there be some missing dependency for the mutlaqja PPA? or maybe some outdated lib?
2 months 2 weeks ago #86542

Please Log in or Create an account to join the conversation.

In principle it should work if the driver implements v1.7 of the protocol. Using telnet to connect directly to the server has the same issue? Maybe it's time to migrate the driver to the modern INDI system?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 1 week ago #86579

Please Log in or Create an account to join the conversation.

Time to create page: 0.260 seconds