×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Driver OnStep (LX200 like) for INDI

  • Posts: 334
  • Thank you received: 42
Hi James_Lan,

I have to try this, I am 7:38 so thta may explain why I did not notice that.
I rememebr there was a change sometime ago with negative / positive.
I have to check that
4 years 11 months ago #23109

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
To James Lan,

after a check it is the lx200driver that uses the following
snprintf(read_buffer, sizeof(read_buffer), ":Sg%03d:%02d#", d, m);
which should workbut doesnt

I created a OnStep local function that uses
snprintf(read_buffer, sizeof(read_buffer), ":Sg%.03d:%02d#", d, m);
remark the "." before 03d
and it now works.

didn't see the forset, too much trees!, thanks for the bug discover.
Hope this will solve you problem.

will include in next push
4 years 11 months ago #23113

Please Log in or Create an account to join the conversation.

  • Posts: 257
  • Thank you received: 22
Just setting up...that is not right. The bug is exactly as it was before Jasem patched it with sync working then reporting target below horizon while I'm looking at it. Frantically reverting in hopes of getting some Orion data tonight. Try flipping your fix? Pretty sure I can test in the rain since it's the interface with the problem. One star alignment with the phone and proper location went right to target. Then with no changes to location kstars shows telescope indicator underground. (more china!?) LOL

[Followup thoughts,
I don't think its only all positive longitudes, it may need them to be flipped. I.E. I put +80.21 in the phone app when the phone itself is reporting -80.21 as my position. But when I put -80 into the phone it gave my position as east of the prime meridian. So i think flipping would work better than absolute value in this case.
It's also possible my "git pull" didn't get the latest code on this and its already fixed but wasn't in azwing/master yet.
I managed to get going with an early "working" version I set aside and did a few things, including verifying phd2 guiding works really well. I got 6 -180 second exposures before it all came crashing down, (don't click save in the preview pane if you value your time) ...only to find the pictures unusable due to the weird way ekos gets its ASI driver settings from indi. - the gamma was wrong. :Frustrated: -- still learning.
After the crashing was finally halted by restarting the indiserver along with everything else, the cams still misbehaved and I had to trek out to the mount and repower them.
I'm learning that a remote system needs a way to reset/repower(ask nasa about that one) and probably a pi-cam aimed to monitor the mount. The latter may be done by Monday.
Last edit: 4 years 11 months ago by Ray Wells. Reason: followup
4 years 11 months ago #23124

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
Hi Blueshawk,

If I understand weel, you do the follwing:
1) You do 1 star Alignment with Android App
2) Your KStars telescope position is somewhere in Siberia or China

I tried to do exactly this:
1) Cold Start od OnStep, plugging in computer
2) Use KStars and connect (using KStars Geographic Set-Up)
3) Use Android app to make One Star Alaignment
4) App porpes me a Star List
5) I select one of the proposed stars
6) I selkect Goto in Android App
7) When position reached I make just some corrections with App
8) I select align in the App

I did this procedure many times using different locations (My Home, Baton Rouge in Louisiana, Minsk In Siberia) and never could reproduce that Kstars shows a telescope position at the opposite where it should be.

I repeated the same procedure but this time using KStars without the phone app and same results.
1) Cold Start
2) Select Align 1 Star in the Main Control Tab
3) Using KStars, right click select a Star and Track
4) KStars slew to this star
5) made some guiding movements
6) Just Right Click on the Star and Sync

When you are speaking about Jasem's Patch could you please send the link, have no idea which patch it could be.

Testing in the rain, with umbrella? I see weather conditions are not better than here

Sorry for the late answer, I was again more in the learning phase than in the progress.
- James Lan challenged me (thank you James) with Github, he raised a pull request ... since I am not a pro of Github was reading a bit
- Had some problems with QTcreator set-up despite the good video from Jasem, till now I did everything with vi and command line, it was a bit hard for an old fashioned guy to get out of the water :), but at the end it works including GDB

How could I live without this for 62 years !!!

Regards
4 years 11 months ago #23139

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
Some brainstorming:

The Driver as it is for now is a little bit like fruit salad, not really consistent.
Blueshawk already made some comments about that and he is right.

I tried to go trough some drivers for different telescope and I found the same different approach everywhere.
Since I have an Eq6-Pro I decided to see how these guys did design the interface.
Attached a pdf with all the screen shots of the Eqmod interface
I think if I could achieve to have similar layout, at least the driver look and feel would be more consistent.

Any suggestionon this?
4 years 11 months ago #23141
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
Hi James,

Pull request accepted.
It works great.

Now I understand what you mean with flip, (Google translates it as crazy in french or gambling with a coin).
4 years 11 months ago #23161

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
Hi,

I played a little bit arround Manual Alaign.

Normally all the three options are functioning:
- 1 Star, 2 Stars, 3 Stars
When selecting a button the Align Process Dialog shows the actual Status, (e.g 312 Manual Align; Star 1/2)
When choosen star is reached and scope back to tracking a dialog box remembers user to apply corrections and validate witl the Align button.
At the end of the process the Align Process shows "Manual Align Completed"
Maybe an Abort button would be necessary in case of mistake
Check the process with Phone and Indi is update during the process
4 years 11 months ago #23176

Please Log in or Create an account to join the conversation.

  • Posts: 257
  • Thank you received: 22
Oh wow that sounds good. I suspect my previous attempt may not have had latest, likely due to the confusion about git pull requests. It sounds like you got it fixed since you could work with Kstars updating the mount and select locations both sides of Prime meridian(PM). Should be shaping up. I'll try to get some tests soon and see what I can break next.

oops. Flip==invert/inverser. My English is worse than your translator apparently. :P
Last edit: 4 years 11 months ago by Ray Wells. Reason: premature submission
4 years 11 months ago #23182

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
Hi Blueshawk,

Yes, now I think I understand how to manage these git pulls.
Was unsure and didn't want to break everything :)
I did play with Ekos Align using the plate solving, seems possible to have this working with OnStep, that would be really fine.

PS: have a look in the files head comments and tell me if you agree / have comments
4 years 11 months ago #23184

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
Today finally added OnStep Stepper Focuser support:

Focuser Tab is shown depending on the hardware capability:
- No Focuser => No Focuser Tab
- One or Two Focusers => the Focuser Tab show up with relevant controls

I made the choice to implements only:
- Buttons for In, Out and stop where In and out are 0,1 s pulses
- Focuser rates min, 0,01, 0,1, 1 mm/s
- Relative Focuser target that allows to give relative displacement vs actual value (+/- 25000) and Focuser Absolute position is updated by polling.

Cannot test in reality since no stepper focuser at the moment.
Not really convinced it will fit the requirements for everybody, but is a starting point.
4 years 11 months ago #23244

Please Log in or Create an account to join the conversation.

  • Posts: 257
  • Thank you received: 22
I used an extra arduino nano and drv8825 to make my focus module so I've not tried it either. I did notice it loaded in the tab after tonight's pull from azwing/indi. I'm not sure what the status is of focus in my version, or if it was even implemented yet. I suppose I should update that. I'm worried I'll have to redo changes I made to get things running again in the mount if I do, a lengthy code comparison may be needed before updating.
More on tonights indoor testing tomorrow as I ran out of time tonight.

zzzzz(thud)
4 years 11 months ago #23248

Please Log in or Create an account to join the conversation.

  • Posts: 334
  • Thank you received: 42
Hi Blueshawk,

The OnStep driver assume the focuser connected via the same Prot as the Telescope so it won't work with a separate hardware.

I see no workarround here except to write a dedicated driver for your hardware.
4 years 11 months ago #23254

Please Log in or Create an account to join the conversation.

Time to create page: 0.560 seconds