×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Driver OnStep (LX200 like) for INDI

  • Posts: 58
  • Thank you received: 2
Thx Alain!

Someone else has to test.
Can't test because i don't know how to install that.
Don't know anything about linux. 
Last edit: 10 months 7 hours ago by Michael Siethoff.
10 months 7 hours ago #79969

Please Log in or Create an account to join the conversation.

  • Posts: 219
  • Thank you received: 40
I’ve not tested yet. My thank you was for the tip to enter West < East as a workaround for the problem.
10 months 1 hour ago #79973

Please Log in or Create an account to join the conversation.

  • Posts: 329
  • Thank you received: 42
I still have sometimes failures, OnStep complaining "Underpole Limit".
After increasing limits in Config.h
#define AXIS1_LIMIT_MIN              -200 //   -180, n. Where n= -90..-270 (degrees.) Minimum "Hour Angle" for Eq modes.      Adjust
                                          //         n. Where n=-180..-360 (degrees.) Minimum Azimuth for AltAzm mode.
#define AXIS1_LIMIT_MAX               200 //    180, n. Where n=  90.. 270 (degrees.) Maximum "Hour Angle" for Eq modes.      Adjust
                                          //         n. Where n= 180.. 360 (degrees.) Maximum Azimuth for AltAzm mode.
No more failures
 
9 months 4 weeks ago #79978

Please Log in or Create an account to join the conversation.

  • Posts: 329
  • Thank you received: 42
Today the Meridian Flip fix has been merged to "libindi master" github.com/indilib/indi.
Most probably nightly builds will be available pretty soon.

Meridian Flip works fine as long as AXIS1_LIMIT_MIN and AXIS1_LIMIT_MAX are set respectively < -180 and > 180 (tested with -185, + 185)
Onstep version 4.24.p (Control Panel Firmware Data Tab)
indi_lx200_OnStep Version is 1.14 (Control Panel Connection Tab)
INDI Library: 1.9.5
kstars version 3.5.8 Beta
 
 
 
 
 
Last edit: 9 months 4 weeks ago by Alain Zwingelstein.
9 months 4 weeks ago #80072
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 5
Can you post your configuration please?
   
INDI/KStars on Raspberry Pi 4, 4gb
Raspberry Bull 64bit
Skywatcher 150PDS
CGE-PRO Mount
Nikon D5300 Camera
ZWO183MM
ZWO ASI120mm
Whaveshave focuser
9 months 4 weeks ago #80073
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 329
  • Thank you received: 42
Buongiorno Ettore,
here my Motion setup.
OnStep Config.h
#define AXIS1_LIMIT_MIN              -185
#define AXIS1_LIMIT_MAX              185
 
 


 
9 months 3 weeks ago #80129
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
I'm confused, autoflip should be set to off when you want Ekos to control the flip no?
9 months 3 weeks ago #80130

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 5
Thanks Alain.
Ettore
INDI/KStars on Raspberry Pi 4, 4gb
Raspberry Bull 64bit
Skywatcher 150PDS
CGE-PRO Mount
Nikon D5300 Camera
ZWO183MM
ZWO ASI120mm
Whaveshave focuser
9 months 3 weeks ago #80131

Please Log in or Create an account to join the conversation.

  • Posts: 329
  • Thank you received: 42
Ettore,

Meridian Flip e un Casino infernale :-)

There is a lot of confusion with Autoflip.
In fact there is no command to issue Autoflip.
There are only limits that define a windows (between limiot East and limit West) where Onstep executes a flip when a goto is issued in this window and only if Autoflip is set to ON.
Otherwise when you reach the meridian cross Onstep will stop track or slew.
Ekos simply issues a goto when the HA is reached.

Maybe It is still not clear see references:
onstep.groups.io/g/main/wiki/5650
docs.google.com/document/d/11NlWvWyI5RxN...ekqkZmgQoIBw91M/edit
ma in Tedesco!
www.astrotreff.de/forum/index.php?thread...ian-flip-verhindern/
9 months 3 weeks ago #80132

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 22
I updated INDI to latest from PPA (1.9.5) and OnStep to 4.24 and now getting error upon connecting to the mount:
"Error setting UTC Offset"
I have "Time & Location Updates" enabled in INDI settings tab of Kstars.
I am getting same error even if I am using INDI settings window for changing UTC offset.
Given that UTC is not set correctly, the mount is totally lost.
Any thoughts on what is causing this issue?
8 months 1 week ago #81491

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
Yes i have the same problem!
8 months 1 week ago #81498

Please Log in or Create an account to join the conversation.

  • Posts: 237
  • Thank you received: 49
A while ago there was an update to the lx200 driver to remove some extra space in commands sent.
The offending area may be here
lx200driver.cpp

OLD = snprintf(read_buffer, sizeof(read_buffer), ":SG %+03d#", static_cast<int>;(hours));
// Meade Telescope Serial Command Protocol Revision 2010.10
// :SGsHH.H#
// Set the number of hours added to local time to yield UTC
// Returns:
// 0 – Invalid
// 1 - Valid
NEW = snprintf(read_buffer, sizeof(read_buffer), ":SG%+04.01lf#", hours);

return (setStandardProcedure(fd, read_buffer));
}

The lx200 2010 manual has:
:SGsHH.H# Set the number of hours added to local time to yield UTC Returns: 0 – Invalid 1 - Valid

The Command.ino of OnStep shows this
github.com/hjd1964/OnStep/blob/release-4.24/Command.ino

//  :SG[sHH]# or :SG[sHH:MM]# (where MM is 30 or 45)^M
//            Set the number of hours added to local time to yield UTC^M
//            Return: 0 on failure^M
//  
The following user(s) said Thank You: Alex Varakin
8 months 1 week ago #81504

Please Log in or Create an account to join the conversation.

Time to create page: 1.074 seconds