×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Produced .fits files by EKOS / Kstars do not follow the fits file specification

  • Posts: 29
  • Thank you received: 1

Rendering Error in layout Message/Item: array_keys(): Argument #1 ($array) must be of type array, null given. Please enable debug mode for more information.

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 1
Also for some reason I can not create an account at KDE to report it at their git repo directly. It keeps rejecting my client due to anti spam measures
1 month 5 days ago #100378

Please Log in or Create an account to join the conversation.

  • Posts: 363
  • Thank you received: 114
Then this may be problem with cfitsio library because that is used to write FITS files.
1 month 4 days ago #100396

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 1
1 month 4 days ago #100398

Please Log in or Create an account to join the conversation.

  • Posts: 363
  • Thank you received: 114
Tried this with simulator but I can't reproduce it. My FITS file is multiple of 2880 and I can see zero padding at end of the file.
1 month 4 days ago #100402

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 1
That's interesting, every single fits file I have from EKOS (and I have 1000's) that I have tested had this issue.

That would imply that something else is causing this, maybe the filesystem?
1 month 4 days ago #100404

Please Log in or Create an account to join the conversation.

  • Posts: 363
  • Thank you received: 114
Just checked my archive. I have around 9000 files that have correct 2880 size multiple and 987 that are not. All bad ones were produced around august - september 2022. No idea why it happened. Files after that are good.
Last edit: 1 month 4 days ago by nou.
1 month 4 days ago #100406

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 1
Just went through my fits files, it appears that the issue started somewhere around Mid 2022, fits before that are fine, but fits files that are younger all have this issue.
The "youngest" fits file I tested it with is one from sept. 2023 which also had this issue.
1 month 3 days ago #100417

Please Log in or Create an account to join the conversation.

  • Posts: 302
  • Thank you received: 46
The version I have installed is 4.0.0 and the latest version from github is 4.4.0 since about 2 months ago.

Br,
/Markku
1 month 3 days ago #100421

Please Log in or Create an account to join the conversation.

  • Posts: 212
  • Thank you received: 104
The date correspond to this old issue: github.com/indilib/indi/issues/1719
It was quickly fixed and is probably present only in INDI version 1.9.7
1 month 3 days ago #100425

Please Log in or Create an account to join the conversation.

Time to create page: 0.582 seconds