×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Custom CCD Drivers Stopped Working in Latest Version of Kstars / Ekos

4 months 3 weeks ago
dh
Fresh Boarder
Fresh Boarder
Posts: 4
More
Topic Author
Custom CCD Drivers Stopped Working in Latest Version of Kstars / Ekos #47982
I developed two new CCD camera drivers based on the Generic CCD example and got both of them working fine with the version of KStars and Ekos that I downloaded in November (2019). I just updated KStars to version 3.3.9 and now my drivers no longer work. I am using Ubuntu 18.04.3 (Ubuntu Mate) on a Raspberry Pi 3B+. The drivers show up in the selection list, but will no longer Connect & Disconnect. They can also be started with INDI Server and all indications are that they are working fine, but applications like PHD2 cannot connect to the cameras. I have created a persistent USB name for each of these and can verify that the name is listed in /dev/. Any suggestions would be appreciated.

Also, related - I could not find how to back up to a previous version of KStars. Are the older versions for Ubuntu located somewhere that I can access them and verify that my problem is from loading the new version only?

Thanks,
Doug

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
dh
Fresh Boarder
Fresh Boarder
Posts: 4
More
Topic Author
Custom CCD Drivers Stopped Working in Latest Version of Kstars / Ekos #47984
After further investigation, I have also determined that the supplied example Generic CCD driver no longer Connects and Disconnects in Ekos. I believe this worked with version 3.3.7, but no longer functions with version 3.3.9 of Kstars. Given that the same issue is occurring when trying to start INDI Server and then use PHD2, I am wondering if the problem is in the change from INDI Library 1.8.2 to 1.8.3. Any help would be appreciated.

Thanks,
Doug

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
Ihoujin
Platinum Boarder
Platinum Boarder
Posts: 875
Karma: 3
More
Custom CCD Drivers Stopped Working in Latest Version of Kstars / Ekos #48000
I use a custom driver for my focuser. Sometimes I have to recompile it after kstars/indilib is updated.

INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
dh
Fresh Boarder
Fresh Boarder
Posts: 4
More
Topic Author
Custom CCD Drivers Stopped Working in Latest Version of Kstars / Ekos #48001
Thanks for the input. I did try recompiling the drivers, but it did not help.

Just by dumb luck, I found something that fixed the problem. Redoing the process shown in 'Building INDI Tutorials' under Develop => Tutorials on the INDI web page to build and install the tutorials fixed the problem. (Somehow) The Generic CCD example and my drivers now work again. I would like to understand it, but I am glad it is working now. I am going to be reluctant to upgrade again in the future.

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
Ihoujin
Platinum Boarder
Platinum Boarder
Posts: 875
Karma: 3
More
Custom CCD Drivers Stopped Working in Latest Version of Kstars / Ekos #48013
Always make a backup image or a working setup before updating.

INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
wotalota
Expert Boarder
Expert Boarder
Posts: 140
More
Custom CCD Drivers Stopped Working in Latest Version of Kstars / Ekos #48047
Take a look at the end of indilib.org/forum/general/6232-update-crashing.html#47821 to see if your library directory shows similar situation. Not sure what that directory is on Ubuntu.
/Tom

Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro

Please Log in or Create an account to join the conversation.

Time to create page: 0.323 seconds